BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
European Auto Source
Post Reply
 
Thread Tools Search this Thread
      06-05-2012, 11:01 AM   #1
e92V8
Private
0
Rep
51
Posts

 
Drives: F30 330d MPPK, 981C GTS
Join Date: Jan 2012
Location: London

iTrader: (0)

iDrive Dead

Hi

A couple of times recently when I've hit bumps the iDrive screen has reset itself, displaying the BMW logo, and then worked fine afterwards. Today I went over a speed hump and the unit blacked out. It's been out for the last few hours and the fuses appear to be fine. I thought it may be a loose connection.

Any ideas?

Thanks
Appreciate 0
      06-05-2012, 11:06 AM   #2
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,121
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
You can pull it out and physically check the connection. Also check the pins in the harnesses.
__________________
Appreciate 0
      06-05-2012, 11:24 AM   #3
tom @ eas
BimmerPost Supporting Vendor
tom @ eas's Avatar
United_States
328
Rep
10,632
Posts


 
Drives: BMW
Join Date: Nov 2005
Location: Anaheim, CA

iTrader: (13)

Garage List
Quote:
Originally Posted by e92V8 View Post
Hi

A couple of times recently when I've hit bumps the iDrive screen has reset itself, displaying the BMW logo, and then worked fine afterwards. Today I went over a speed hump and the unit blacked out. It's been out for the last few hours and the fuses appear to be fine. I thought it may be a loose connection.

Any ideas?

Thanks
Likely a short somewhere.

In the meantime, press the volume knob in for ~30 seconds to reboot. See if this works.
__________________
Appreciate 0
      06-05-2012, 11:53 AM   #4
e92V8
Private
0
Rep
51
Posts

 
Drives: F30 330d MPPK, 981C GTS
Join Date: Jan 2012
Location: London

iTrader: (0)

Thanks for the help. I've had a look and cables appear fine. Tried reset to no avail. Dealership it is then!
Appreciate 0
      07-30-2012, 07:00 AM   #5
e92V8
Private
0
Rep
51
Posts

 
Drives: F30 330d MPPK, 981C GTS
Join Date: Jan 2012
Location: London

iTrader: (0)

Sorry for resurrecting this after so long. The issue was an apparent short circuit with the cabling contacting the body somewhere.

Anyway, I've had my car back for some time but only just noticed that the Point of Interest search is greyed out. I can select categories but can't search.

Any ideas?
Appreciate 0
      10-01-2013, 05:05 AM   #6
Siciliano611
Captain
15
Rep
811
Posts

 
Drives: 2015 SS M4
Join Date: Mar 2007
Location: TriState area/ATL

iTrader: (3)

E92v8 I'm having this exact same issue, how did the dealer fix the short circuit? Anyone else get this fixed?
Appreciate 0
      01-30-2014, 09:58 PM   #7
GregW / Oregon
Commander-In-Chief
United_States
137
Rep
7,647
Posts

 
Drives: 2015 M4 Coupe, 2012 ML350
Join Date: Nov 2005
Location: Lake Oswego, OR

iTrader: (2)

Garage List
Failed iDrive

My iDrive has been flaking out intermittently ('08 Coupe, 52,000 mi). Started first time 12/17/13 just after leaving the dealer from a service appointment, coincidentally. Recurred last couple days. BMW "splash" screen would come up sometimes and lock, then reboot a few time over several minutes, then maybe make it to the accept screen, but with controls inactive, then to main screen with controls still not working. Also one time, radio would not turn off even after locking car (went off after a few minutes).

Took into dealer today - they report the computer (SA said "hard drive" was failing. $880 part. The good news is BMW is covering it under "good will". I pay for installation and programming. Of course while there, they also said I had 9 logged thermostat faults (sticking). So I throw a few hundred more at it. I'm selling this car in a few months (M4 on preorder), and I will not sell a car I don't feel is right.

Will report back on final diagnosis and results
__________________

Greg Lake Oswego, Oregon, USA
2015 M4 Coupe - Silverstone/Sakhir/CF
2012 ML350
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:17 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST