BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
European Auto Source
Post Reply
 
Thread Tools Search this Thread
      06-19-2013, 01:59 AM   #1
Mahmood07
Captain
 
Mahmood07's Avatar
 
Drives: 2010 E92 M3 DCT
Join Date: Sep 2009
Location: Boston->San Diego->Bahrain

Posts: 808
iTrader: (0)

"Increased Emissions" Message. Hardware Issue?

I have the Turner Test Pipes and ESS tune on my car. Now, after two years with no problems, I got the SES light and 'increased emissions' message. Is it possible that I need to retune the car to remove the message? I took the car to the dealer and they just said ignore it because its from your exhaust.

ESS guys, any help?
__________________
///M3 Mods: | Eisenmann Race Exhaust | Primary Cats Delete (TTP) | ESS Tune | 19" Advan RS | Eibach Springs | MS Air Filter | BMW Perf. Spoiler | BMW Perf. Splitters | Euro LCI Tail lights | Angel iBright v.3.0 | 20% Tint | Matte black Kidney Grills | CF Side Gills | Painted Reflectors | Black M3 emblem

Last edited by Mahmood07; 06-24-2013 at 03:07 AM.
Mahmood07 is offline   Bahrain
0
Reply With Quote
      06-19-2013, 03:35 AM   #2
Longwong
Banned
 
Drives: e92 m3 catless
Join Date: Jun 2013
Location: USA

Posts: 371
iTrader: (0)

The tune if you specified to ESS you are catless gets rid of the code. So your code is from something else and probably need to get a code reader yourself to be sure.
Longwong is offline  
0
Reply With Quote
      06-19-2013, 09:51 AM   #3
Roman@ESS
BimmerPost Supporting Vendor

 
Roman@ESS's Avatar
 
Drives: ESS Supercharged E92 M3
Join Date: May 2007
Location: AZ

Posts: 2,592
iTrader: (5)

Quote:
Originally Posted by Mahmood07 View Post
I have the Turner Test Pipes and ESS tune on my car. Now, after two years with no problems, I got the SES light and 'increased emissions' message. Is it possible that I need to retune the car to remove the message? I took the car to the dealer and they just said ignore it because its from your exhaust.

ESS guys, any help?
This could only be from a fault related to a hardware failure or the car was flashed back to stock by the dealer. Read the codes stored and email them to me.
__________________
Web: www.esstuning.com
Email: Roman@esstuning.com
Phone: (480) 525-9155
Like us on Facebook
Follow us on Instagram esstuning
Roman@ESS is offline  
0
Reply With Quote
      06-20-2013, 01:38 AM   #4
Mahmood07
Captain
 
Mahmood07's Avatar
 
Drives: 2010 E92 M3 DCT
Join Date: Sep 2009
Location: Boston->San Diego->Bahrain

Posts: 808
iTrader: (0)

Quote:
Originally Posted by Longwong View Post
The tune if you specified to ESS you are catless gets rid of the code. So your code is from something else and probably need to get a code reader yourself to be sure.
Yes it is the catless tune and I've had it for 2 years with no problems.

Quote:
Originally Posted by Roman@ESS View Post
This could only be from a fault related to a hardware failure or the car was flashed back to stock by the dealer. Read the codes stored and email them to me.
I am thinking it is a hardware issue since I got the warning before I took it to the dealer. Also, I still have my 8600 RPM limit and No rough cold start so I'm pretty sure the car was not flashed back to stock.

Is there anything specific I could tell them to look at (o2 sensors, spark plugs etc.) that you would know of? We don't have the best dealership here in Bahrain, and they rarely see modified cars, so I have to point them to the right direction.

I will email you the codes as soon as I get them from my SA.
__________________
///M3 Mods: | Eisenmann Race Exhaust | Primary Cats Delete (TTP) | ESS Tune | 19" Advan RS | Eibach Springs | MS Air Filter | BMW Perf. Spoiler | BMW Perf. Splitters | Euro LCI Tail lights | Angel iBright v.3.0 | 20% Tint | Matte black Kidney Grills | CF Side Gills | Painted Reflectors | Black M3 emblem
Mahmood07 is offline   Bahrain
0
Reply With Quote
      06-20-2013, 08:47 AM   #5
Curt2000
Colonel
 
Curt2000's Avatar
 
Drives: '13 ///M3
Join Date: Jun 2007
Location: Sin City

Posts: 2,412
iTrader: (21)

Probably should have just emailed ESS to resolve the issue first instead of posting on a public forum?
__________________

Current Car: '13 SANTORINI BLUE E92///M3--6MT/Speed Cloth/ZCP (ED Thread)
Former Cars:'10 E90 335i MSport / '07 Interlagos ///M5 / '09 135i / '10 E93 335i
Instagram: @C2KMotorsports
Curt2000 is offline   United_States
0
Reply With Quote
      06-20-2013, 04:13 PM   #6
Zaw
Private First Class
 
Drives: 2011 E90 M3 DCT Competition
Join Date: Aug 2010
Location: Studio City, CA

Posts: 101
iTrader: (0)

Quote:
Originally Posted by Curt2000 View Post
Probably should have just emailed ESS to resolve the issue first instead of posting on a public forum?
Agreed. A phone call or email could have resolved his issue far more quickly and without drama. Some people may feel like posting potentially damaging information on a public forum will get them better attention. But I think it's in poor taste. Just my opinion.
Zaw is offline  
0
Reply With Quote
      06-20-2013, 07:45 PM   #7
Mmmdreamer
Lieutenant
 
Mmmdreamer's Avatar
 
Drives: 08 e90 M3 Jet Black
Join Date: Oct 2011
Location: Jersey City

Posts: 537
iTrader: (1)

pull the codes, it's still possible something else went wrong as ESS tune doesn't suppress all codes, just the one about primary cat...i had issue w/ o2 sensor and had CEL.

You could also just clear the light and see if it comes back.
__________________
[08 e90 M3. Jet Black/Black. Dinan Rear Exhaust. ACM Test Pipes. ESS Tune. Eibach Pro-Kit + e36 bumpstops. 18x10 Apex Arc-8. AA Air Filter. RPI Scoops. CREE Angel Eyes. OEM Blacklines. Black Reflectors. Gloss Black Grills. Matte Black Gills. ZCP Shift Knob]
Mmmdreamer is offline   United_States
0
Reply With Quote
      06-20-2013, 08:01 PM   #8
M3ANMACHINE
Hella Functional
 
M3ANMACHINE's Avatar
 
Drives: 2004 BMW E46 M3
Join Date: Jan 2010
Location: Mission Viejo, CA

Posts: 1,535
iTrader: (5)

02 sensor failure maybe? Not sure how the ESS tune works though.
__________________

E90///M3 x 6MT x APEX x AE Performance x Bimmerworld x Dinan x Evolve x KW x Mode Carbon x PFC x TMS

M3ANMACHINE is offline   United_States
0
Reply With Quote
      06-21-2013, 02:15 AM   #9
SlowSaloonM3
Major General
 
SlowSaloonM3's Avatar
 
Drives: m3 saloon in granny mode.
Join Date: Dec 2009
Location: lost angeles

Posts: 7,001
iTrader: (0)

How are you guys turning this into a bash? He said it had no problems for two years and suggested it may be from something else. Gees. He asked for help.

And the company responded early in the morning. How much quicker can you get? Lol.
__________________
the intardnet is 95% troll, 5% actual good shit. so are my posts.
my channel: pkim
SlowSaloonM3 is offline  
0
Reply With Quote
      06-23-2013, 11:23 AM   #10
Mahmood07
Captain
 
Mahmood07's Avatar
 
Drives: 2010 E92 M3 DCT
Join Date: Sep 2009
Location: Boston->San Diego->Bahrain

Posts: 808
iTrader: (0)

Quote:
Originally Posted by Curt2000 View Post
Probably should have just emailed ESS to resolve the issue first instead of posting on a public forum?
Quote:
Originally Posted by Zaw View Post
Agreed. A phone call or email could have resolved his issue far more quickly and without drama. Some people may feel like posting potentially damaging information on a public forum will get them better attention. But I think it's in poor taste. Just my opinion.
Are you guys serious? What drama are you talking about? I am not even sure it's an issue with the tune, so I posted it in an M3 forum hoping of finding people who have experienced the same problem. Two years on, I'm still happy with my ESS tune, so please move on to another thread where you might be helpful.

Quote:
Originally Posted by Mmmdreamer View Post
pull the codes, it's still possible something else went wrong as ESS tune doesn't suppress all codes, just the one about primary cat...i had issue w/ o2 sensor and had CEL.

You could also just clear the light and see if it comes back.
Thanks, I will post the codes as soon as I get them from the dealer. The light disappears for a week then comes back on.

Quote:
Originally Posted by pkim1079 View Post
How are you guys turning this into a bash? He said it had no problems for two years and suggested it may be from something else. Gees. He asked for help.

And the company responded early in the morning. How much quicker can you get? Lol.
Thanks for understanding. Maybe the thread title is unintentionally misleading?
__________________
///M3 Mods: | Eisenmann Race Exhaust | Primary Cats Delete (TTP) | ESS Tune | 19" Advan RS | Eibach Springs | MS Air Filter | BMW Perf. Spoiler | BMW Perf. Splitters | Euro LCI Tail lights | Angel iBright v.3.0 | 20% Tint | Matte black Kidney Grills | CF Side Gills | Painted Reflectors | Black M3 emblem
Mahmood07 is offline   Bahrain
0
Reply With Quote
      06-23-2013, 11:31 AM   #11
W///
Brigadier General
 
W///'s Avatar
 
Drives: 2008 E92 M3/1999 E36 M3 Coupe
Join Date: Sep 2011
Location: SC

Posts: 4,699
iTrader: (11)

Quote:
Originally Posted by Mahmood07 View Post
Are you guys serious? What drama are you talking about? I am not even sure it's an issue with the tune, so I posted it in an M3 forum hoping of finding people who have experienced the same problem. Two years on, I'm still happy with my ESS tune, so please move on to another thread where you might be helpful.



Thanks, I will post the codes as soon as I get them from the dealer. The light disappears for a week then comes back on.



Thanks for understanding. Maybe the thread title is unintentionally misleading?
I'd say it's a little misleading, yes.
__________________
2008 E92 M3: Sparkling Graphite | Bamboo Beige | 6MT | CF Roof | HRE | Eisenmann | BPM Sport | Swift | Arkym | Mode Carbon | M.Perf
W/// is online now  
0
Reply With Quote
      06-24-2013, 03:13 AM   #12
Mahmood07
Captain
 
Mahmood07's Avatar
 
Drives: 2010 E92 M3 DCT
Join Date: Sep 2009
Location: Boston->San Diego->Bahrain

Posts: 808
iTrader: (0)

Quote:
Originally Posted by W/// View Post
I'd say it's a little misleading, yes.
I changed the title, but people should really read the content of the thread before throwing accusations. Even if I wanted to complain about a company or a product (which I am NOT), I'm pretty sure I am allowed to do it on a car forum. I, along with others, like to hear the problems people face with companies or their products so I can have a balanced view.
__________________
///M3 Mods: | Eisenmann Race Exhaust | Primary Cats Delete (TTP) | ESS Tune | 19" Advan RS | Eibach Springs | MS Air Filter | BMW Perf. Spoiler | BMW Perf. Splitters | Euro LCI Tail lights | Angel iBright v.3.0 | 20% Tint | Matte black Kidney Grills | CF Side Gills | Painted Reflectors | Black M3 emblem
Mahmood07 is offline   Bahrain
0
Reply With Quote
      06-24-2013, 04:03 AM   #13
h4nh
Captain
 
h4nh's Avatar
 
Drives: 09 SC E90 M3 / 13 F10 M5
Join Date: Sep 2011
Location: Dallas, TX

Posts: 807
iTrader: (0)

Garage List
2013 M5  [0.00]
2009 E90 M3 (superc ...  [5.00]
Quote:
Originally Posted by Mahmood07 View Post
I changed the title, but people should really read the content of the thread before throwing accusations. Even if I wanted to complain about a company or a product (which I am NOT), I'm pretty sure I am allowed to do it on a car forum. I, along with others, like to hear the problems people face with companies or their products so I can have a balanced view.
I had this happen on my e92 with no cats and active tune. It turned out to be 02 sensors and bmw replaced them. Maybe the techs didn't test them?
__________________
h4nh is offline   United_States
0
Reply With Quote
      06-24-2013, 04:08 AM   #14
Mahmood07
Captain
 
Mahmood07's Avatar
 
Drives: 2010 E92 M3 DCT
Join Date: Sep 2009
Location: Boston->San Diego->Bahrain

Posts: 808
iTrader: (0)

Quote:
Originally Posted by h4nh View Post
I had this happen on my e92 with no cats and active tune. It turned out to be 02 sensors and bmw replaced them. Maybe the techs didn't test them?
Thanks, I will take it in this week to see if it's the O2 sensors. I don't think they checked them. Do you know if the bad O2 sensor will affect performance in any way?
__________________
///M3 Mods: | Eisenmann Race Exhaust | Primary Cats Delete (TTP) | ESS Tune | 19" Advan RS | Eibach Springs | MS Air Filter | BMW Perf. Spoiler | BMW Perf. Splitters | Euro LCI Tail lights | Angel iBright v.3.0 | 20% Tint | Matte black Kidney Grills | CF Side Gills | Painted Reflectors | Black M3 emblem
Mahmood07 is offline   Bahrain
0
Reply With Quote
      06-24-2013, 04:35 AM   #15
h4nh
Captain
 
h4nh's Avatar
 
Drives: 09 SC E90 M3 / 13 F10 M5
Join Date: Sep 2011
Location: Dallas, TX

Posts: 807
iTrader: (0)

Garage List
2013 M5  [0.00]
2009 E90 M3 (superc ...  [5.00]
Quote:
Originally Posted by Mahmood07 View Post
Thanks, I will take it in this week to see if it's the O2 sensors. I don't think they checked them. Do you know if the bad O2 sensor will affect performance in any way?
no issues with performance. It just displays 'increased emissions' warning. Search it on here. I think 02 sensors are a common fault.
__________________
h4nh is offline   United_States
0
Reply With Quote
      06-24-2013, 02:15 PM   #16
happos2
Dingleberries
 
Drives: Gray E92 M3
Join Date: May 2012
Location: Indiana

Posts: 1,137
iTrader: (2)

Quote:
Originally Posted by Mahmood07 View Post
Thanks, I will take it in this week to see if it's the O2 sensors. I don't think they checked them. Do you know if the bad O2 sensor will affect performance in any way?
Bad pre-cat O2 sensors can affect how your engine runs. This is a great place for the computer to sample the oxygen and determine if the combustion process was carried out correctly (in non-technical terms). Depending on how bad the reading, the car could be overcompensating or undercompensating the amount of fuel input which might cause your car to run lean or rich. It is the post O2 cat that really doesn't matter after you remove cats as it WAS trying to evaluate how effective the cat was.

That being said, I am having the same issue as you. I have a different brand of test pipes and a different stage II tune, however I get an SES light with the faults being the 02 sensors (I made a thread about it in this section of the forum which Alexshop was very helpful helping me decipher what the codes mean).
With that information, I ordered two pre-cat O2 sensors from ebay and will be replacing them tonight or tomorrow.

Hope this helps.
happos2 is offline  
0
Reply With Quote
      06-25-2013, 10:02 PM   #17
Dave07997S
Colonel
 
Drives: 2013 BMW M3 ZCP Coupe
Join Date: May 2009
Location: Playa del Rey, CA

Posts: 2,459
iTrader: (1)

You can have a post cat sensor go bad even with a tune that doesn't pull codes for inefficient catalyst and kick off a code for another problem. It could be sensing an exhaust leak or the rear 02s can go faulty. I know this happened to me.

Mahmood post the codes and someone will steer you in the right direction.
__________________
2013 M3 Coupe-MR/BLK ZCP, ACM test pipes, BPM Stg2 dev. tune and Megan catback, AFE Stg2. with C/F elbow
Previous rides: 2011 M3 Coupe-MR/Blk
2007 Porsche 997C2S Speed Yellow/Blk sport seats
2004 BMW M3 Imola/Blk
Dave07997S is offline  
0
Reply With Quote
      06-25-2013, 11:11 PM   #18
tim944s
New Member
 
Drives: 2008 BMW M3
Join Date: Mar 2013
Location: Calgary

Posts: 29
iTrader: (0)

Codes are good. I have had the same. I also had it come sporadically go on and off. Ended up being the fuel pump controller. Same redline and no adverse operation or idle. Just glitchy.
tim944s is offline  
0
Reply With Quote
      06-26-2013, 06:56 AM   #19
Mahmood07
Captain
 
Mahmood07's Avatar
 
Drives: 2010 E92 M3 DCT
Join Date: Sep 2009
Location: Boston->San Diego->Bahrain

Posts: 808
iTrader: (0)

Quote:
Originally Posted by Roman@ESS View Post
This could only be from a fault related to a hardware failure or the car was flashed back to stock by the dealer. Read the codes stored and email them to me.
Quote:
Originally Posted by happos2 View Post
Bad pre-cat O2 sensors can affect how your engine runs. This is a great place for the computer to sample the oxygen and determine if the combustion process was carried out correctly (in non-technical terms). Depending on how bad the reading, the car could be overcompensating or undercompensating the amount of fuel input which might cause your car to run lean or rich. It is the post O2 cat that really doesn't matter after you remove cats as it WAS trying to evaluate how effective the cat was.

That being said, I am having the same issue as you. I have a different brand of test pipes and a different stage II tune, however I get an SES light with the faults being the 02 sensors (I made a thread about it in this section of the forum which Alexshop was very helpful helping me decipher what the codes mean).
With that information, I ordered two pre-cat O2 sensors from ebay and will be replacing them tonight or tomorrow.

Hope this helps.
Quote:
Originally Posted by Dave07997S View Post
You can have a post cat sensor go bad even with a tune that doesn't pull codes for inefficient catalyst and kick off a code for another problem. It could be sensing an exhaust leak or the rear 02s can go faulty. I know this happened to me.

Mahmood post the codes and someone will steer you in the right direction.
Quote:
Originally Posted by tim944s View Post
Codes are good. I have had the same. I also had it come sporadically go on and off. Ended up being the fuel pump controller. Same redline and no adverse operation or idle. Just glitchy.
Thanks for the tips guys. I called my SA and he could only give me the codes by phone so here is what I got:

27ca O2 sensor after cat bank 1
27cb O2 sensor after cat bank 2

Does this mean I have to replace the o2 sensors after the primary cats ?
__________________
///M3 Mods: | Eisenmann Race Exhaust | Primary Cats Delete (TTP) | ESS Tune | 19" Advan RS | Eibach Springs | MS Air Filter | BMW Perf. Spoiler | BMW Perf. Splitters | Euro LCI Tail lights | Angel iBright v.3.0 | 20% Tint | Matte black Kidney Grills | CF Side Gills | Painted Reflectors | Black M3 emblem
Mahmood07 is offline   Bahrain
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:25 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST