BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
E92-lighting
Post Reply
 
Thread Tools Search this Thread
      06-20-2013, 11:32 PM   #1
eL fUcHiLa
New Member
0
Rep
19
Posts

 
Drives: E93
Join Date: Mar 2013
Location: Thibodaux, Louisiana

iTrader: (3)

High beam not working after replacing HID control unit.

Hi,

I recently replaced the passenger side HID control unit in my '08 E93 and now the high beam doesn't work on that side.

Is that something that needs to be coded in order to make it work? I bought the control unit off ebay. I didn't feel like paying $500+ plus labor to the stealership and bought the control unit used off ebay for $89 and changed it myself.

The adaptive headlights seems to be working fine (I need to double check because I never turn them on), the adaptive headlight led illuminates by the knob area, and they both move when starting on the car. Low beams work fine.


Any ideas? Suggestions?
Appreciate 0
      06-21-2013, 07:12 AM   #2
elm3
M3 Lover
elm3's Avatar
United_States
26
Rep
1,864
Posts

 
Drives: 2009 e92 M3 Interlagos Blue
Join Date: Sep 2008
Location: Canton, GA.

iTrader: (1)

Garage List
Quote:
Originally Posted by eL fUcHiLa View Post
Hi,

I recently replaced the passenger side HID control unit in my '08 E93 and now the high beam doesn't work on that side.

Is that something that needs to be coded in order to make it work? I bought the control unit off ebay. I didn't feel like paying $500+ plus labor to the stealership and bought the control unit used off ebay for $89 and changed it myself.

The adaptive headlights seems to be working fine (I need to double check because I never turn them on), the adaptive headlight led illuminates by the knob area, and they both move when starting on the car. Low beams work fine.


Any ideas? Suggestions?
Maybe the actual bulb might be faulty, since the same bulb is low and high beam. Try switching the bulb from the left and put it on the right and try the high beam and see if it works. If it works, then you know the sytem is working properly and it is indeed the bulb.
__________________
'09 E92 ///M3 Interlagos Blue, 6MT, Silver Novillo Leather, CF Trim, Premium Package, Technology Package, Cold Weather Package, Premium Sound, 19" Wheels, Moonroof-Toy/ '14 335i, Sport Line, Premium Package, Technology Package, 19" wheels, Heated Seats - Daily Driver/ '04 Yamaha R1 - Toy/ '06 Yamaha Raptor 350-Toy
Appreciate 0
      06-21-2013, 09:08 AM   #3
eL fUcHiLa
New Member
0
Rep
19
Posts

 
Drives: E93
Join Date: Mar 2013
Location: Thibodaux, Louisiana

iTrader: (3)

Quote:
Originally Posted by elm3 View Post
Maybe the actual bulb might be faulty, since the same bulb is low and high beam. Try switching the bulb from the left and put it on the right and try the high beam and see if it works. If it works, then you know the sytem is working properly and it is indeed the bulb.
I don't think the light bulb is faulty. I believe the fault is in the "shutter mechanism" that needs to be coded to the control unit in order to make it work...

I bought a new pair of HID bulbs before realizing the control unit was bad. I can always give it a try and change bulbs if needed, but I'm sticking to coding the control unit.
Appreciate 0
      06-21-2013, 09:48 AM   #4
elm3
M3 Lover
elm3's Avatar
United_States
26
Rep
1,864
Posts

 
Drives: 2009 e92 M3 Interlagos Blue
Join Date: Sep 2008
Location: Canton, GA.

iTrader: (1)

Garage List
Quote:
Originally Posted by eL fUcHiLa View Post
I don't think the light bulb is faulty. I believe the fault is in the "shutter mechanism" that needs to be coded to the control unit in order to make it work...

I bought a new pair of HID bulbs before realizing the control unit was bad. I can always give it a try and change bulbs if needed, but I'm sticking to coding the control unit.
Yeah, I forgot that everything with BMW has to be coded.
__________________
'09 E92 ///M3 Interlagos Blue, 6MT, Silver Novillo Leather, CF Trim, Premium Package, Technology Package, Cold Weather Package, Premium Sound, 19" Wheels, Moonroof-Toy/ '14 335i, Sport Line, Premium Package, Technology Package, 19" wheels, Heated Seats - Daily Driver/ '04 Yamaha R1 - Toy/ '06 Yamaha Raptor 350-Toy
Appreciate 0
      06-21-2013, 11:48 PM   #5
eL fUcHiLa
New Member
0
Rep
19
Posts

 
Drives: E93
Join Date: Mar 2013
Location: Thibodaux, Louisiana

iTrader: (3)

Quote:
Originally Posted by eL fUcHiLa View Post
Hi,

I recently replaced the passenger side HID control unit in my '08 E93 and now the high beam doesn't work on that side.

Is that something that needs to be coded in order to make it work? I bought the control unit off ebay. I didn't feel like paying $500+ plus labor to the stealership and bought the control unit used off ebay for $89 and changed it myself.

The adaptive headlights seems to be working fine (I need to double check because I never turn them on), the adaptive headlight led illuminates by the knob area, and they both move when starting on the car. Low beams work fine.


Any ideas? Suggestions?
I drove with the adaptive headlights for about 20 minutes and they seemed to be working fine, I noticed the corner lights came on and the headlights moved when I turn. After that, the adaptive headlight malfunction came on the screen and the led by the knob area started to blink.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:10 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST