BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing
 
Lux Angel Eyes
Post Reply
 
Thread Tools Search this Thread
      05-18-2013, 03:49 PM   #1
E90M3velocity
Second Lieutenant
Philippines
2
Rep
236
Posts

 
Drives: Silverstone II E90 M3
Join Date: Oct 2012
Location: Bay Area CA

iTrader: (2)

Engine Malfunction

I was on the bay bridge today to heading to brisbane when an "engine malfunction" message appeared and the car went into limp mode, but i could not keep throttle and the motor eventually died. Started the motor again (i was still on the bridge!) and it sounded and ran fine with no error lights and drove to a place to park. Inspected the motor real quick, no leaks, no odd smell, and so i drove it home until i can bring it to my shop (car has no warranty). It seems like a wiring issue, and i was wondering if anyone has encountered a similar issue? The car is an 08 with a unmodified motor and has had the throttle actuators replaced, updated to the lastest software, and the low fuel pressure sensor replaced in less than 5000 miles since i owned it. This isnt looking good for the rest of the miles i plan to make with this car.
__________________

Last edited by E90M3velocity; 05-18-2013 at 03:58 PM.
Appreciate 0
      05-18-2013, 04:00 PM   #2
Lorde
Ya ya ya, I am Lorde, ya ya!
Lorde's Avatar
No_Country
32
Rep
2,519
Posts

 
Drives: E90 M3, 2015 SQ5
Join Date: May 2011
Location: Snig

iTrader: (5)

Garage List
2008 BMW M3 E90  [0.00]
Another member just reported back that what he thought was an actuator issue, turned out to be one of the individual throttle bodies.
Appreciate 0
      05-18-2013, 04:16 PM   #3
E90M3velocity
Second Lieutenant
Philippines
2
Rep
236
Posts

 
Drives: Silverstone II E90 M3
Join Date: Oct 2012
Location: Bay Area CA

iTrader: (2)

Thanks, i will check the itb's. Do you happen to remember which topic that thread was in?
__________________
Appreciate 0
      05-19-2013, 09:30 AM   #4
Lorde
Ya ya ya, I am Lorde, ya ya!
Lorde's Avatar
No_Country
32
Rep
2,519
Posts

 
Drives: E90 M3, 2015 SQ5
Join Date: May 2011
Location: Snig

iTrader: (5)

Garage List
2008 BMW M3 E90  [0.00]
Quote:
Originally Posted by E90M3velocity
Thanks, i will check the itb's. Do you happen to remember which topic that thread was in?
http://www.m3post.com/forums/showthread.php?p=14013932

Page 5
Appreciate 0
      05-19-2013, 06:53 PM   #5
E90M3velocity
Second Lieutenant
Philippines
2
Rep
236
Posts

 
Drives: Silverstone II E90 M3
Join Date: Oct 2012
Location: Bay Area CA

iTrader: (2)

Cool thanks, just subscribed. It happened again today, when i turned on the car to move it. Luckily i wasnt on the road or somewhere far away.
__________________
Appreciate 0
      05-20-2013, 01:30 PM   #6
E90M3velocity
Second Lieutenant
Philippines
2
Rep
236
Posts

 
Drives: Silverstone II E90 M3
Join Date: Oct 2012
Location: Bay Area CA

iTrader: (2)

idle actuator monitoring, bank
intake manifold pressure sensor
Misfire with cutoff, cyl. 1-8
Ambient pressure signal implausible
Leaning towards the idle control valve
__________________
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:09 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST