BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing
 
INDustry distribution
Post Reply
 
Thread Tools Search this Thread
      05-17-2012, 08:59 AM   #23
elm3
M3 Lover
 
elm3's Avatar
 
Drives: 2009 e92 M3 Interlagos Blue
Join Date: Sep 2008
Location: Canton, GA.

Posts: 1,821
iTrader: (1)

Garage List
Quote:
Originally Posted by flip View Post
Ok cool. I did read that other places as well. I dont' mind, always sounds more agressive like my drift car tune .

I got the O2 done fairly easily but the code came back so I'm waiting on my code reader to get in in the mail. I'll post back up as soon as I get that and pull the codes again.

I had the codes reset JUST before I replaced the O2. I drove it home from the auto store after resetting it and replaced the O2. The code came back days later. Is there any way resetting it before replacing the O2 could cause the code to come back days later? Or is there likely simply another code (or the same code)?
That means that it wasn't the correct one. The faulty O2 still inuse.
__________________
'09 E92 ///M3 Interlagos Blue, 6MT, Silver Novillo Leather, CF Trim, Premium Package, Technology Package, Cold Weather Package, Premium Sound, 19" Wheels, Moonroof-Toy/ '11 E90 328i Black Saphire Metallic, Premium Package, Technology Package - Daily Driver '02 Nissan Xterra- Daily Driver/ '04 Yamaha R1-Toy/ '06 Yamaha Raptor 350-Toy
elm3 is offline   United_States
0
Reply With Quote
      05-17-2012, 12:11 PM   #24
flip
Private
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 94
iTrader: (0)

Quote:
Originally Posted by elm3 View Post
That means that it wasn't the correct one. The faulty O2 still inuse.
Hum. Ok, I'll double check to make sure I replaced the correct one and pull codes again tonight. Tool should be here tonight after being "mis-shipped" by amazon .
flip is offline  
0
Reply With Quote
      05-17-2012, 12:15 PM   #25
Archiebabes
Lieutenant
 
Drives: 2008 BMW M3
Join Date: Jul 2011
Location: Van Nuys, CA

Posts: 473
iTrader: (10)

Did you replace both of your upstream 02 sensors?

If you only replaced one then it will still throw the code.

When you pulled the codes it says X2 so you will have to replace both upstream 02 sensors.
Archiebabes is offline  
0
Reply With Quote
      05-17-2012, 12:32 PM   #26
flip
Private
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 94
iTrader: (0)

Quote:
Originally Posted by Archiebabes View Post
Did you replace both of your upstream 02 sensors?

If you only replaced one then it will still throw the code.

When you pulled the codes it says X2 so you will have to replace both upstream 02 sensors.
Well it said bank 2 so I thought that I would only need to replace one. I can't see why they would always both go bad at the same time either.

Also thought the x2 meant the code occurred twice. Is this incorrect?
flip is offline  
0
Reply With Quote
      05-17-2012, 12:42 PM   #27
elm3
M3 Lover
 
elm3's Avatar
 
Drives: 2009 e92 M3 Interlagos Blue
Join Date: Sep 2008
Location: Canton, GA.

Posts: 1,821
iTrader: (1)

Garage List
Quote:
Originally Posted by flip View Post
Well it said bank 2 so I thought that I would only need to replace one. I can't see why they would always both go bad at the same time either.

Also thought the x2 meant the code occurred twice. Is this incorrect?
I have to check, but I think that Archiebabes is correct. When it says x2, it means that both of them are bad. But I have to check. I know that Bank 2 means that it is on the side of the number 2 cylinder. Pull up the codes again and posted for us, so we can help you more. Without me there, I really can't help much. Let me know.

Eric
__________________
'09 E92 ///M3 Interlagos Blue, 6MT, Silver Novillo Leather, CF Trim, Premium Package, Technology Package, Cold Weather Package, Premium Sound, 19" Wheels, Moonroof-Toy/ '11 E90 328i Black Saphire Metallic, Premium Package, Technology Package - Daily Driver '02 Nissan Xterra- Daily Driver/ '04 Yamaha R1-Toy/ '06 Yamaha Raptor 350-Toy
elm3 is offline   United_States
0
Reply With Quote
      05-17-2012, 12:57 PM   #28
flip
Private
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 94
iTrader: (0)

Quote:
Originally Posted by elm3 View Post
I have to check, but I think that Archiebabes is correct. When it says x2, it means that both of them are bad. But I have to check. I know that Bank 2 means that it is on the side of the number 2 cylinder. Pull up the codes again and posted for us, so we can help you more. Without me there, I really can't help much. Let me know.

Eric
Ok, thanks! I'll pull codes and post as soon as I can. This time I may take a ride out to meet ya if its not obvious after I pull the codes...

I read something here:
http://www.m3post.com/forums//showthread.php?t=310475

about exhaust gas traveling back if some valve is stuck and setting off the trigger for the opposite side. Not sure if its the same as my issue tho...
flip is offline  
0
Reply With Quote
      05-17-2012, 02:48 PM   #29
flip
Private
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 94
iTrader: (0)

This time only it was a different code. Ironically enough, my check engine light disappeared today but I pulled the code anyway.

P0192 (Fuel Rail Pressure Sensor Low Input)

??
flip is offline  
0
Reply With Quote
      05-17-2012, 06:13 PM   #30
flip
Private
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 94
iTrader: (0)

Reset them and more came back, this time pulled:
P0175 System Too Rich (Bank 2)
Po172 System Too Rich (Bank 1)
P0175 System Too Rich (Bank 2)
P0172 System Too Rich (Bank 1)
flip is offline  
0
Reply With Quote
      05-17-2012, 06:21 PM   #31
flip
Private
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 94
iTrader: (0)

Maybe I need low pressure fuel sensor?

#20?
http://realoem.com/bmw/showparts.do?...96&hg=16&fg=15
flip is offline  
0
Reply With Quote
      05-17-2012, 08:55 PM   #32
Archiebabes
Lieutenant
 
Drives: 2008 BMW M3
Join Date: Jul 2011
Location: Van Nuys, CA

Posts: 473
iTrader: (10)

Quote:
Originally Posted by flip View Post
Reset them and more came back, this time pulled:
P0175 System Too Rich (Bank 2)
Po172 System Too Rich (Bank 1)
P0175 System Too Rich (Bank 2)
P0172 System Too Rich (Bank 1)
Did you purchase an OEM upstream 02 sensor from the dealership?
Archiebabes is offline  
0
Reply With Quote
      05-17-2012, 10:38 PM   #33
flip
Private
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 94
iTrader: (0)

Quote:
Originally Posted by Archiebabes View Post
Did you purchase an OEM upstream 02 sensor from the dealership?
Nope, but it was Bosch. Shouldn't matter where it came from.
flip is offline  
0
Reply With Quote
      05-18-2012, 07:07 AM   #34
elm3
M3 Lover
 
elm3's Avatar
 
Drives: 2009 e92 M3 Interlagos Blue
Join Date: Sep 2008
Location: Canton, GA.

Posts: 1,821
iTrader: (1)

Garage List
I need to look at your car. Do you want to meet this weekend? Let me know. That is strange that you are getting too rich mixture on both banks, but replaced the O2 on one of the bank. Your fuel pressure sensor might be going bad. That is why your getting that code and then the too rich code. Because it can not regulate the pressure. Sending too much to the rails? Bring it to my house and lets take a look at it.
__________________
'09 E92 ///M3 Interlagos Blue, 6MT, Silver Novillo Leather, CF Trim, Premium Package, Technology Package, Cold Weather Package, Premium Sound, 19" Wheels, Moonroof-Toy/ '11 E90 328i Black Saphire Metallic, Premium Package, Technology Package - Daily Driver '02 Nissan Xterra- Daily Driver/ '04 Yamaha R1-Toy/ '06 Yamaha Raptor 350-Toy
elm3 is offline   United_States
0
Reply With Quote
      05-18-2012, 08:32 AM   #35
flip
Private
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 94
iTrader: (0)

Quote:
Originally Posted by elm3 View Post
I need to look at your car. Do you want to meet this weekend? Let me know. That is strange that you are getting too rich mixture on both banks, but replaced the O2 on one of the bank. Your fuel pressure sensor might be going bad. That is why your getting that code and then the too rich code. Because it can not regulate the pressure. Sending too much to the rails? Bring it to my house and lets take a look at it.
That's what I'm thinning as well.sounds good. I'll pm you.
flip is offline  
0
Reply With Quote
      05-18-2012, 08:37 AM   #36
elm3
M3 Lover
 
elm3's Avatar
 
Drives: 2009 e92 M3 Interlagos Blue
Join Date: Sep 2008
Location: Canton, GA.

Posts: 1,821
iTrader: (1)

Garage List
Let me know and I'll give you my number. Is your car still under warranty? And you do not want to wait too long. Dumping too much raw fuel in the system can really mess up your cats.
__________________
'09 E92 ///M3 Interlagos Blue, 6MT, Silver Novillo Leather, CF Trim, Premium Package, Technology Package, Cold Weather Package, Premium Sound, 19" Wheels, Moonroof-Toy/ '11 E90 328i Black Saphire Metallic, Premium Package, Technology Package - Daily Driver '02 Nissan Xterra- Daily Driver/ '04 Yamaha R1-Toy/ '06 Yamaha Raptor 350-Toy
elm3 is offline   United_States
0
Reply With Quote
      05-18-2012, 09:08 AM   #37
flip
Private
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 94
iTrader: (0)

Quote:
Originally Posted by elm3 View Post
Let me know and I'll give you my number. Is your car still under warranty? And you do not want to wait too long. Dumping too much raw fuel in the system can really mess up your cats.
No warranty... I went ahead and ordered that fuel pressure sensor and will just return if it I don't need it. And yeah, don't want to ruin cats .
flip is offline  
0
Reply With Quote
      05-18-2012, 07:16 PM   #38
elm3
M3 Lover
 
elm3's Avatar
 
Drives: 2009 e92 M3 Interlagos Blue
Join Date: Sep 2008
Location: Canton, GA.

Posts: 1,821
iTrader: (1)

Garage List
Quote:
Originally Posted by flip View Post
No warranty... I went ahead and ordered that fuel pressure sensor and will just return if it I don't need it. And yeah, don't want to ruin cats .
Hey Philip, it was meeting you. Did that fix your car? BTW, nice car. We need to lower that thing.

Eric
__________________
'09 E92 ///M3 Interlagos Blue, 6MT, Silver Novillo Leather, CF Trim, Premium Package, Technology Package, Cold Weather Package, Premium Sound, 19" Wheels, Moonroof-Toy/ '11 E90 328i Black Saphire Metallic, Premium Package, Technology Package - Daily Driver '02 Nissan Xterra- Daily Driver/ '04 Yamaha R1-Toy/ '06 Yamaha Raptor 350-Toy
elm3 is offline   United_States
0
Reply With Quote
      05-18-2012, 09:50 PM   #39
flip
Private
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 94
iTrader: (0)

Quote:
Originally Posted by elm3 View Post
Hey Philip, it was meeting you. Did that fix your car? BTW, nice car. We need to lower that thing.

Eric
You too man! Had a great time. I've driven the car a few times tonight and the code hasn't come back. Looks like that might have done the trick.

And thanks! Your's is rather nice as well. Love the color. Still need to hear that exhaust... Looks so nice.

Thanks again for all your help! I gotta remember to order that ground wire... And yes, lower it too
flip is offline  
0
Reply With Quote
      05-20-2012, 03:45 PM   #40
flip
Private
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 94
iTrader: (0)

Posted a thread about replacing the Sensor for Low Pressure in the fuel system. Hopefully it will help someone else out that runs into this problem!

http://www.m3post.com/forums/showthread.php?p=12000511
flip is offline  
0
Reply With Quote
      04-30-2013, 05:08 PM   #41
a0s4957
New Member
 
Drives: 2008 M3 - Interlagos Blue
Join Date: Apr 2013
Location: Houston, Texas

Posts: 5
iTrader: (0)

Garage List
2008 BMW M3  [0.00]
M3 SES light

Guys, read your thread and i thought this had to be my issue, now I am being told I have all of these other faults. Can anyone please help me...


04/04/12 2B4C Intake air temp fault plus sensor plausibility (LEAN code).
03/08/13 2737 Change plausibility, cold start B1.
2737 Change plausibility, cold start B2.
2B3B Misfire #7.
04/10/13 27BB Fuel system lamda/charge plausibility B2
27BA Fuel system lamda/charge plausibility B1
a0s4957 is offline  
0
Reply With Quote
      05-01-2013, 07:09 AM   #42
elm3
M3 Lover
 
elm3's Avatar
 
Drives: 2009 e92 M3 Interlagos Blue
Join Date: Sep 2008
Location: Canton, GA.

Posts: 1,821
iTrader: (1)

Garage List
Quote:
Originally Posted by a0s4957 View Post
Guys, read your thread and i thought this had to be my issue, now I am being told I have all of these other faults. Can anyone please help me...


04/04/12 2B4C Intake air temp fault plus sensor plausibility (LEAN code).
03/08/13 2737 Change plausibility, cold start B1.
2737 Change plausibility, cold start B2.
2B3B Misfire #7.
04/10/13 27BB Fuel system lamda/charge plausibility B2
27BA Fuel system lamda/charge plausibility B1
It looks like the coil on cylinder# 7 is faulty. Your cylinder# 7 is a dead cylinder or not firing.
__________________
'09 E92 ///M3 Interlagos Blue, 6MT, Silver Novillo Leather, CF Trim, Premium Package, Technology Package, Cold Weather Package, Premium Sound, 19" Wheels, Moonroof-Toy/ '11 E90 328i Black Saphire Metallic, Premium Package, Technology Package - Daily Driver '02 Nissan Xterra- Daily Driver/ '04 Yamaha R1-Toy/ '06 Yamaha Raptor 350-Toy
elm3 is offline   United_States
0
Reply With Quote
      05-01-2013, 06:25 PM   #43
a0s4957
New Member
 
Drives: 2008 M3 - Interlagos Blue
Join Date: Apr 2013
Location: Houston, Texas

Posts: 5
iTrader: (0)

Garage List
2008 BMW M3  [0.00]
Quote:
Originally Posted by elm3 View Post
It looks like the coil on cylinder# 7 is faulty. Your cylinder# 7 is a dead cylinder or not firing.

Well i thought that might be the case, and in that instance, i turned the car off and when i restarted it everything went back to normal.

Move forward a month and now i have the lamba errors on B1 and B2. Could it be that the oxygen sensors are causing all of this?
__________________
08 Interlagos Blue M3 | ACSchnitzer front lip, Hamman rear difuser, Vossen 20" wheels, Remus exhaust| http://razzi.me/albums/11942-bimmer
a0s4957 is offline  
0
Reply With Quote
      05-02-2013, 08:03 AM   #44
elm3
M3 Lover
 
elm3's Avatar
 
Drives: 2009 e92 M3 Interlagos Blue
Join Date: Sep 2008
Location: Canton, GA.

Posts: 1,821
iTrader: (1)

Garage List
Quote:
Originally Posted by a0s4957 View Post
Well i thought that might be the case, and in that instance, i turned the car off and when i restarted it everything went back to normal.

Move forward a month and now i have the lamba errors on B1 and B2. Could it be that the oxygen sensors are causing all of this?
It might be and the ones at fault are the upstream ones (before cats), not the downstream (after cats). Let me know if this make sense??? I can help you.

Eric
__________________
'09 E92 ///M3 Interlagos Blue, 6MT, Silver Novillo Leather, CF Trim, Premium Package, Technology Package, Cold Weather Package, Premium Sound, 19" Wheels, Moonroof-Toy/ '11 E90 328i Black Saphire Metallic, Premium Package, Technology Package - Daily Driver '02 Nissan Xterra- Daily Driver/ '04 Yamaha R1-Toy/ '06 Yamaha Raptor 350-Toy
elm3 is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:34 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST