BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
Post Reply
 
Thread Tools Search this Thread
      03-29-2013, 09:44 PM   #1
EliteM3
Private First Class
 
Drives: 2009 E90 M3
Join Date: May 2012
Location: Morgan Hill, CA

Posts: 170
iTrader: (0)

iPhone / iDrive Bluetooth irregularities

Hello, I have an iPhone 5 on IOS 6.1.2, 09 E90 DCT With iDrive and just recently Started behaving erratically. Phone pairs, but when trying to read phone book, drops connection and then reconnects in a loop

I can see my phone connect and drop every 20-30 seconds.

When someone Calls and I answer, I get a brief piercing sound, drop of Bluetooth, then reconnect 10 seconds into the conversation.

I am also noticing the SOS led going on and off.

Something isn't right.

Anyone else experiencing something similar?
__________________
09 Space Gray E90 M3 DCT: BPM (Stage 1, DCT and Servotronic) tune, Gintani Sport Exhaust, Dinan Intake
EliteM3 is offline   United_States
0
Reply With Quote
      04-04-2013, 04:28 PM   #2
EliteM3
Private First Class
 
Drives: 2009 E90 M3
Join Date: May 2012
Location: Morgan Hill, CA

Posts: 170
iTrader: (0)

Is there really nobody out there with a similar problem?

I just received a replacement iPhone from Apple as we both thought this could be hardware related since full resets and restores did nothing. The problem remains.

Phone pairs with the car just fine, but every 30-40 seconds, it looses connection (both car can't see the phone and phone can't see the car), then reconnectes for another 30-40 seconds.

Anyone?
EliteM3 is offline   United_States
0
Reply With Quote
      04-04-2013, 07:52 PM   #3
Fen335i
Captain
 
Fen335i's Avatar
 
Drives: e92 M3 / Z4 M Roadster
Join Date: Jun 2008
Location: Pacific Northwest

Posts: 783
iTrader: (0)

Quote:
Originally Posted by EliteM3 View Post
Is there really nobody out there with a similar problem?

I just received a replacement iPhone from Apple as we both thought this could be hardware related since full resets and restores did nothing. The problem remains.

Phone pairs with the car just fine, but every 30-40 seconds, it looses connection (both car can't see the phone and phone can't see the car), then reconnectes for another 30-40 seconds.

Anyone?
I've had similar problems with my 08 M3. But it wasn't limited to just the iPhone..I've had the same problem w/Androids, BBerries, etc. Mine never made any weird noises, but would constantly drop calls back to the handset and sometimes would re-pair mid-call. I had the dealer look at it, but they came up with nothing, other than rebooting it (disconnecting the car's battery). I did the same thing myself a few months later after it started acting up again and that helped for a while. But, it's doing it again now. Actually, I can't even get it to pair at all. I go into the pairing menu and get nothing. It's strange. There is also a setting in my CCC iDrive where you can supposedly check and uncheck the bluetooth box, but when I go in there I can't un-check it. It won't accept any commands from the iDrive controller. Very strange...

I'm about to disconnect the battery again and see if that frees it up again.

My mic also picks up a ton of road noise (when the thing is actually working). I haven't found much info yet (you may have seen my post from yesterday on this topic). I've heard you can replace the factory mic...to a "762" noise suppressing mic (which I think the car came with BTW), but haven't gone there yet. If anyone has info on this, please share.
Fen335i is offline  
0
Reply With Quote
      04-05-2013, 08:26 AM   #4
THE TECH
BimmerPost Supporting Vendor

 
THE TECH's Avatar
 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

Posts: 13,030
iTrader: (42)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Have you updated the bluetooth software in the car?
__________________
THE TECH is offline   United_States
0
Reply With Quote
      04-05-2013, 08:47 AM   #5
Fen335i
Captain
 
Fen335i's Avatar
 
Drives: e92 M3 / Z4 M Roadster
Join Date: Jun 2008
Location: Pacific Northwest

Posts: 783
iTrader: (0)

Quote:
Originally Posted by THE TECH View Post
Have you updated the bluetooth software in the car?
No, I don't believe the dealer ever tried that. How is that done?
Fen335i is offline  
0
Reply With Quote
      04-05-2013, 08:50 AM   #6
THE TECH
BimmerPost Supporting Vendor

 
THE TECH's Avatar
 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

Posts: 13,030
iTrader: (42)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Quote:
Originally Posted by Fen335i View Post
No, I don't believe the dealer ever tried that. How is that done?
Go to this site and follow the directions:

http://www.bmw.com/com/en/owners/nav...update_vin.jsp
__________________
THE TECH is offline   United_States
0
Reply With Quote
      04-05-2013, 09:23 AM   #7
Fen335i
Captain
 
Fen335i's Avatar
 
Drives: e92 M3 / Z4 M Roadster
Join Date: Jun 2008
Location: Pacific Northwest

Posts: 783
iTrader: (0)

Thanks Tech. I have the older iDrive (CCC)...it's an 08' car. I'm not sure I have the "software update" function with that older system. At least I've never seen it burried in the menus anywhere...I could be wrong though. I'll double check.
Fen335i is offline  
0
Reply With Quote
      04-05-2013, 09:25 AM   #8
THE TECH
BimmerPost Supporting Vendor

 
THE TECH's Avatar
 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

Posts: 13,030
iTrader: (42)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Quote:
Originally Posted by Fen335i View Post
Thanks Tech. I have the older iDrive (CCC)...it's an 08' car. I'm not sure I have the "software update" function with that older system. At least I've never seen it burried in the menus anywhere...I could be wrong though. I'll double check.
Yeah I didn't know what year car you had. This is for 2010+ or cars with CIC conversions.
__________________
THE TECH is offline   United_States
0
Reply With Quote
      04-05-2013, 09:35 AM   #9
Fen335i
Captain
 
Fen335i's Avatar
 
Drives: e92 M3 / Z4 M Roadster
Join Date: Jun 2008
Location: Pacific Northwest

Posts: 783
iTrader: (0)

Quote:
Originally Posted by THE TECH View Post
Yeah I didn't know what year car you had. This is for 2010+ or cars with CIC conversions.
No worries...I entered the VIN anyway on the BMW site and sure enough it says I have the latest software for my car. ;-)

Has anyone ever replaced their OEM bluetooth system with these CCC iDrive cars? It doesn't sound like there is a way to update them...maybe it's just a matter of pulling out the old module and replacing with a new one that's compatible?
Fen335i is offline  
0
Reply With Quote
      04-06-2013, 02:34 AM   #10
EliteM3
Private First Class
 
Drives: 2009 E90 M3
Join Date: May 2012
Location: Morgan Hill, CA

Posts: 170
iTrader: (0)

So I did a little more troubleshooting and it seems it is the data on my phone causing the issue.

My wife's iPhone 5, my old iPhone 4, and my replaced iPhone 5 with nothing on it (ios 6.1.3) works fine, pairs and can read the phone book of test names.

But when I do a restore of my data, it no longer works.

I have deleted or corrected every entry that has a special character. I have deleted the pairing on both sides and reset all settings multiple time. No idea what it is about the data on the phone is causing this problem, but it sucks.

I have an 09 with CiC, so I can't update the car Bluetooth software, correct?
__________________
09 Space Gray E90 M3 DCT: BPM (Stage 1, DCT and Servotronic) tune, Gintani Sport Exhaust, Dinan Intake
EliteM3 is offline   United_States
0
Reply With Quote
      04-07-2013, 01:23 PM   #11
toddcc1
Private First Class
 
Drives: M3
Join Date: Mar 2013
Location: Monument, CO

Posts: 156
iTrader: (0)

Quote:
Originally Posted by EliteM3 View Post
So I did a little more troubleshooting and it seems it is the data on my phone causing the issue.

My wife's iPhone 5, my old iPhone 4, and my replaced iPhone 5 with nothing on it (ios 6.1.3) works fine, pairs and can read the phone book of test names.

But when I do a restore of my data, it no longer works.

I have deleted or corrected every entry that has a special character. I have deleted the pairing on both sides and reset all settings multiple time. No idea what it is about the data on the phone is causing this problem, but it sucks.

I have an 09 with CiC, so I can't update the car Bluetooth software, correct?
Are you using Exchange Active Sync? If so, disable your Exchange account or delete it all together and attempt. Not sure if it's a data problem, but rather the versioning the contacts were created under. I believe there's a way to export all of your contacts in .xml format, erase your phone, then import your contacts from the .xml. That should tag it with whatever "new" data/metadata is needed for it to upload. Just suggestions, not sure it will work. My iPhone 5 works great with the bluetooth/contacts list. Though, I lost 100's of contacts in the conversion from 4 to 5. All of my contacts were created net-new with the iPhone 5.
toddcc1 is offline  
0
Reply With Quote
      04-11-2013, 02:38 AM   #12
EliteM3
Private First Class
 
Drives: 2009 E90 M3
Join Date: May 2012
Location: Morgan Hill, CA

Posts: 170
iTrader: (0)

Interesting. I do have active sync. But I need it for work and its synced over the air. I suppose I could decouple it.

One thing is for sure...when I disable contact sync on the phone, it doesn't drop Bluetooth anymore.
__________________
09 Space Gray E90 M3 DCT: BPM (Stage 1, DCT and Servotronic) tune, Gintani Sport Exhaust, Dinan Intake
EliteM3 is offline   United_States
0
Reply With Quote
      05-21-2013, 09:28 PM   #13
Pinocchio Wood
Registered
 
Drives: E90 M3 DCt with iDrive
Join Date: May 2013
Location: Sydney, Australia

Posts: 2
iTrader: (0)

iPhone / iDrive Bluetooth irregularities

Hi EliteM3,

I have experienced exactly the issue you have outlined in your original post. I have a 2009 e90 M3 DCT with iDrive. I first noticed this issue in early may after I updated to 6.1.4 with an iphone 5. Exactly the same. Kept trying to sync contacts to the car, circle rotating, green SOS led popping up ahile screen would say "ending call" and then on the bluetooth screen would connect and then disconnect phone. During call, a high pitched squeal and call would drop out. I tried a friends iphone 4 on 6.1.3 and no problem. Went to Apple demanded a new phone thinking it was the 6.1.4 patch. no luck - apologies to Apple staff who were harrassed. If I sync only favourites and recent calls no problem. I now presume a corrupt contact, so after reading this post/replies have deleted exchange account and will test tonight. Very frustrating. Thought I had a faulty bluetooth module but now are certain it is a contacts issue. Read idrive only handles 1,000. Overflow?
Pinocchio Wood is offline  
0
Reply With Quote
      05-22-2013, 05:39 PM   #14
EliteM3
Private First Class
 
Drives: 2009 E90 M3
Join Date: May 2012
Location: Morgan Hill, CA

Posts: 170
iTrader: (0)

Did you find which contact(s) were the culprit.

It sucks, I have bluetooth to answer calls, but I can't search my contacts to make calls anymore. Weak.
EliteM3 is offline   United_States
0
Reply With Quote
      05-22-2013, 10:49 PM   #15
Pinocchio Wood
Registered
 
Drives: E90 M3 DCt with iDrive
Join Date: May 2013
Location: Sydney, Australia

Posts: 2
iTrader: (0)

No. I deleted my exchange account and re-loaded. Didn't work. I don't know how I could work out which one is corrupt. So I am going to sync my contacts to my apple contacts account then switch off contacts on my exchange account. I can't think of another way of handling this.
Pinocchio Wood is offline  
0
Reply With Quote
      07-15-2013, 03:59 PM   #16
EliteM3
Private First Class
 
Drives: 2009 E90 M3
Join Date: May 2012
Location: Morgan Hill, CA

Posts: 170
iTrader: (0)

Hey there Pinocchio, did you successfully get your contacts out of exchange and onto the iphone...and more importantly, do you again have the ability to sync your phone with BMW bluetooth again?

I am getting ready to try this now, and wanted to know if you have successfully done what you were going to try.

Thanks!
EliteM3 is offline   United_States
0
Reply With Quote
      07-20-2013, 06:08 PM   #17
z4wannabe
Registered
 
Drives: BMW 325d Touring 2008
Join Date: Jul 2013
Location: London

Posts: 3
iTrader: (0)

Hi Elite M3,

I have just bought a 325d (58 plate) and have experienced exactly the same problem you describe in the OP when syncing my iPhone 5 (disconnect, reconnect...etc and phonebook doesn't download to the car).

I have even tried my son's iPhone 5, which worked fine, contacts synced etc.

I can receive calls, but can't obviously scan my phonebook to make them (can dial manually). I also get the 'ending call' popping up and the SOS light flashes.

So exactly the same symptoms.

Today I reset my phone and also my son's phone and we restored our settings to each others phone. Alas, my set up on his hardware still had the problem (so it's not the phone itself).

Have you had any luck? I'm really keen to get this sorted...

Many thanks.
z4wannabe is offline  
0
Reply With Quote
      07-20-2013, 06:57 PM   #18
z4wannabe
Registered
 
Drives: BMW 325d Touring 2008
Join Date: Jul 2013
Location: London

Posts: 3
iTrader: (0)

I should say, mine is CIC system, same as EliteM3 an Pinnochio.

I was running iOS 6.0 when I found the problem, and updating to 6.1.4 made no difference.

For what it's worth I do use Exchange, so perhaps this is the common denominator.

How did you get on Pinnochio - resolved?
z4wannabe is offline  
0
Reply With Quote
      07-24-2013, 02:45 AM   #19
EliteM3
Private First Class
 
Drives: 2009 E90 M3
Join Date: May 2012
Location: Morgan Hill, CA

Posts: 170
iTrader: (0)

Workaround found

It seems correct that the exchange contacts (but not all) are the problem. I went through my contacts and selected a bunch of them and added them to favorites.

Then on the iPhone, set it to synch only favorites, and now I have my contacts back and selectable through Bluetooth. However, it only shows my favorites.

I can probably add them one at a time and test to find out which contact(s) are the problem. But that will take a lot of time.

I'm just happy I can dial from iDrive contacts again!
__________________
09 Space Gray E90 M3 DCT: BPM (Stage 1, DCT and Servotronic) tune, Gintani Sport Exhaust, Dinan Intake
EliteM3 is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:38 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST