BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > General M3 Forum (E90 + E92 + E93)
 
VF Engineering
Post Reply
 
Thread Tools Search this Thread
      03-17-2013, 02:19 PM   #23
72dan
New Member
 
72dan's Avatar
 
Drives: 2009 M3 DCT coupe white/beige
Join Date: Nov 2010
Location: Los Angeles

Posts: 12
iTrader: (1)

I have run many tanks of gas through the car with the problem. A buddy who races dirt bikes said California has been putting in more ethanol and that may be it. I tried blending super unleaded with 100 octane unleaded. I think I picked up a few horsepower but didn't fix the idle problem. The race gas here is over $9 a gallon, ouch. Don't know if it threw any codes.

I used to build race engines over 20 years ago. My normal routine with something like this is change the spark plugs, clean the throttle bodies. Had a similar issue with my first Toyota Tundra, an independent said I needed a throttle position sensor, I cleaned everything out, new spark plugs and it was perfect.

The problem with dealership mechanics is flat rate, they get paid x hours for a job so there is incentive to rush it. If I have them clean the throttle bodies they will spray carb cleaner in with the motor running. That washes down the cylinder walls with the crap which isn't good for the engine.

If I want it done right I think I have to do it myself.
__________________
Regards,
72dan
72dan is offline   United_States
0
Reply With Quote
      03-17-2013, 02:33 PM   #24
Arben72
Banned
 
Drives: E92 M3
Join Date: Apr 2011
Location: Illinois

Posts: 466
iTrader: (0)

It's the gas. Even if your using 93-91 it's still the gas quality. I had the same problem from 93 from bp.
Arben72 is offline   Albania
0
Reply With Quote
      03-17-2013, 03:05 PM   #25
Dkhan23
Banned
 
Drives: BMW
Join Date: Jan 2013
Location: Canada/USA

Posts: 360
iTrader: (0)

Are you sure it's not the Winter Blend gasoline which I think California uses?
Dkhan23 is offline  
0
Reply With Quote
      03-17-2013, 03:39 PM   #26
thekurgan
Bad Lieutenant
 
thekurgan's Avatar
 
Drives: E90M3
Join Date: Aug 2007
Location: Sacramento

Posts: 2,684
iTrader: (0)

Garage List
2008 BMW M3  [0.00]
Do it yourself, if techron hasn't helped.
__________________

08 E90M3 6MT Alpinweiss/Carbon/BMW Pedals/Dinan Exhaust/Rattle fixes
thekurgan is offline   United_States
0
Reply With Quote
      04-01-2013, 02:42 AM   #27
Magnetic Fusion
Private
 
Magnetic Fusion's Avatar
 
Drives: 2008 E92 M3, 1995 E36 M3
Join Date: Apr 2012
Location: United States

Posts: 76
iTrader: (0)

Send a message via Skype™ to Magnetic Fusion
Quote:
Originally Posted by e92zero View Post
Hi, I have just started to notice this on my car also. I have about 24k miles on my car. Happened 2 x the last couple of months when it's really cold and I left the car outside for the whole day. If I start driving off right away (like 10-15 seconds after start up), at the first stop sign that I get to, the idle would jump between 500-800. Never feel like it wants to stall and will go away if I just let it do that for maybe 10 seconds. If I let the engine warm up for 30 seconds or so before driving off, this won't happen. Sean05/Richpuer, does your car need any fix or it runs perfectly fine as time go on. Thanks in advance.
I just moved from sunny Arizona to freezing ass cold NY and starting noticing this same problem...like the car has to warm up or something. This is my 6th BMW and I always like to clean the ICV but I usually will do this when I need to take the intake off...which is a hassle! I let it run for about a minute and it goes away and I have a smooth idle. I'm throwing no codes but I know it never used to do this in Arizona. I used to travel for work and within 1 year of owning the car I had only driven it three times for about a week at a time. Now I driving it everyday and its getting annoying. Is there anything I can do to clean this without removing it? I like my cars to run smooth and I've never had a BMW break down on me in 10 years of owning one. The inline 6 is one thing but this V8 is another....its a very tight squeeze in the engine bay! A quick fix it needed please
__________________
2008 M3 Space Grey, 2003 M3 Silver Grey, 1995 M3 Avus Blue Metallic, 1995 M3 Cosmos Racing Black,
1994 318i Hellrot Red, 1992 318is Hellrot Red
Magnetic Fusion is offline   United_States
0
Reply With Quote
      04-01-2013, 02:47 AM   #28
Magnetic Fusion
Private
 
Magnetic Fusion's Avatar
 
Drives: 2008 E92 M3, 1995 E36 M3
Join Date: Apr 2012
Location: United States

Posts: 76
iTrader: (0)

Send a message via Skype™ to Magnetic Fusion
Quote:
Originally Posted by Dkhan23 View Post
Are you sure it's not the Winter Blend gasoline which I think California uses?
The M3 engines are calibrated to run 87 octane because idiots don't like to read the "Premium Unleaded Fuel Only", and they would complain their car ran like shit. So with the E9XX cars BMW calibrated for use with 87 to solve the "idiot" problem but still use the "Premium Unleaded Fuel Only" sticker. If you can afford a M3 you can afford to pay an extra $0.30 cents a gallon! So, yes...the gas shouldn't be a big deal. BMW recommends Shell because they use nitrogen that will keep your valves clean. Of course, no Shell where I live
__________________
2008 M3 Space Grey, 2003 M3 Silver Grey, 1995 M3 Avus Blue Metallic, 1995 M3 Cosmos Racing Black,
1994 318i Hellrot Red, 1992 318is Hellrot Red
Magnetic Fusion is offline   United_States
0
Reply With Quote
      04-01-2013, 09:40 AM   #29
e92zero
Lieutenant
 
Drives: 2011 E92 BW
Join Date: May 2010
Location: somewhere in US

Posts: 534
iTrader: (0)

Quote:
Originally Posted by Magnetic Fusion View Post
I just moved from sunny Arizona to freezing ass cold NY and starting noticing this same problem...like the car has to warm up or something. This is my 6th BMW and I always like to clean the ICV but I usually will do this when I need to take the intake off...which is a hassle! I let it run for about a minute and it goes away and I have a smooth idle. I'm throwing no codes but I know it never used to do this in Arizona. I used to travel for work and within 1 year of owning the car I had only driven it three times for about a week at a time. Now I driving it everyday and its getting annoying. Is there anything I can do to clean this without removing it? I like my cars to run smooth and I've never had a BMW break down on me in 10 years of owning one. The inline 6 is one thing but this V8 is another....its a very tight squeeze in the engine bay! A quick fix it needed please
I think we are talking about a different issue. Mine is as the OP stated, it only happens when driving off right after it starts and the engine jumps around a bit . My idle don't really jump around if I am not moving. I just let it run for like 20 seconds on start up before driving off and I don't experience the jumpy/jerky engine response. You might have a different issue with the ICV which seems to be a common thing on this engine. Hope you find the issue.
e92zero is offline  
0
Reply With Quote
      04-01-2013, 11:36 AM   #30
Sandye90m3
Captain
 
Sandye90m3's Avatar
 
Drives: M3
Join Date: Oct 2009
Location: SoCal

Posts: 759
iTrader: (0)

Anybody know the cost to replace the ICV without warranty?
__________________
M3.e90 JZB blacked out.coded
Sandye90m3 is offline   Canada
0
Reply With Quote
      04-01-2013, 01:22 PM   #31
e92zero
Lieutenant
 
Drives: 2011 E92 BW
Join Date: May 2010
Location: somewhere in US

Posts: 534
iTrader: (0)

Quote:
Originally Posted by Sandye90m3 View Post
Anybody know the cost to replace the ICV without warranty?
I think Mike has it done and listed the bmw work order here:

http://www.m3post.com/forums/showthr...+control+vavle
e92zero is offline  
0
Reply With Quote
      04-01-2013, 03:11 PM   #32
Magnetic Fusion
Private
 
Magnetic Fusion's Avatar
 
Drives: 2008 E92 M3, 1995 E36 M3
Join Date: Apr 2012
Location: United States

Posts: 76
iTrader: (0)

Send a message via Skype™ to Magnetic Fusion
Quote:
Originally Posted by e92zero View Post
I think we are talking about a different issue. Mine is as the OP stated, it only happens when driving off right after it starts and the engine jumps around a bit . My idle don't really jump around if I am not moving. I just let it run for like 20 seconds on start up before driving off and I don't experience the jumpy/jerky engine response. You might have a different issue with the ICV which seems to be a common thing on this engine. Hope you find the issue.
No. We are talking about the same issue. When I drive off the car kinda studders a bit when its getting going for about 20 seconds, then goes away. My idle doesn't jump around at idle either. I was just stating that I try to let the car warm up for a few secs before I take off because I hate when it studders. Like its starving for gas for 20 seconds. Trying to find out if theres a cleaner or system flush I can do to the intake or gas system to fix this.
__________________
2008 M3 Space Grey, 2003 M3 Silver Grey, 1995 M3 Avus Blue Metallic, 1995 M3 Cosmos Racing Black,
1994 318i Hellrot Red, 1992 318is Hellrot Red
Magnetic Fusion is offline   United_States
0
Reply With Quote
      04-01-2013, 03:18 PM   #33
thekurgan
Bad Lieutenant
 
thekurgan's Avatar
 
Drives: E90M3
Join Date: Aug 2007
Location: Sacramento

Posts: 2,684
iTrader: (0)

Garage List
2008 BMW M3  [0.00]
Quote:
Originally Posted by Magnetic Fusion View Post
No. We are talking about the same issue. When I drive off the car kinda studders a bit when its getting going for about 20 seconds, then goes away. My idle doesn't jump around at idle either. I was just stating that I try to let the car warm up for a few secs before I take off because I hate when it studders. Like its starving for gas for 20 seconds. Trying to find out if theres a cleaner or system flush I can do to the intake or gas system to fix this.
Have you tried a couple of tanks with Techron concentrate plus? Maybe two tanks back-to-back? Cheap enough to give it a try, in the event it's not the ICV causing your issue.
__________________

08 E90M3 6MT Alpinweiss/Carbon/BMW Pedals/Dinan Exhaust/Rattle fixes
thekurgan is offline   United_States
0
Reply With Quote
      04-01-2013, 03:32 PM   #34
Magnetic Fusion
Private
 
Magnetic Fusion's Avatar
 
Drives: 2008 E92 M3, 1995 E36 M3
Join Date: Apr 2012
Location: United States

Posts: 76
iTrader: (0)

Send a message via Skype™ to Magnetic Fusion
Quote:
Originally Posted by thekurgan View Post
Have you tried a couple of tanks with Techron concentrate plus? Maybe two tanks back-to-back? Cheap enough to give it a try, in the event it's not the ICV causing your issue.
No but I will on my days off. Now that I have a recommendation. The car has 88,000 miles Im sure its time for some fuel system cleaner
__________________
2008 M3 Space Grey, 2003 M3 Silver Grey, 1995 M3 Avus Blue Metallic, 1995 M3 Cosmos Racing Black,
1994 318i Hellrot Red, 1992 318is Hellrot Red
Magnetic Fusion is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:35 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST