BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E46 M3 Coupe and Convertible > General E46 M3 Talk
 
INDustry distribution
Post Reply
 
Thread Tools Search this Thread
      03-13-2013, 02:50 PM   #1
iclukay
Enlisted Member
 
Drives: 2007 335i Black/Terra
Join Date: Nov 2010
Location: Windermere, FL

Posts: 31
iTrader: (0)

Exclamation 02' E46 M3 Rough/Jerky takeoff (Video)

Hey guys,

I've been having a strange issue with my baby recently. Whenever I take off under hard acceleration, the car jerks and the engine acts like it's starving for fuel or the computer is cutting off power whether the DSC is engaged or not It had some recent work, including:

-Air filter
-Fuel Filter
-Spark Plugs
-Oil + Oil filter
-MAF sensor

(The problem was happening before this maintenance as well)

My friend who is an ex BMW technician said 99% of the time problems like these are related to the MAF sensor, and that this was very strange. It's throwing no EML or SES codes either, and I know it's not my driving. I added a youtube link to a video as well trying to capture the symptoms, it's been a couple months now and I ran out of ideas to try



Any help or suggestions would be more than appreciated!
iclukay is offline  
0
Reply With Quote
      03-13-2013, 03:09 PM   #2
Chriskm3
Colonel
 
Chriskm3's Avatar
 
Drives: M3
Join Date: Jul 2012
Location: Toronto

Posts: 2,218
iTrader: (4)

I definitely would not drive like that. Take it to the dealer.
Chriskm3 is offline   Canada
0
Reply With Quote
      03-13-2013, 07:46 PM   #3
iclukay
Enlisted Member
 
Drives: 2007 335i Black/Terra
Join Date: Nov 2010
Location: Windermere, FL

Posts: 31
iTrader: (0)

I can take off fine as long as its slow and it drives perfectly, in second I can mash the throttle and it drives just like it came off the lot. I wouldn't drive it if I felt like I was hurting it or if it happened every time I accelerate. It's only under hard, sudden acceleration in first that the engine is cutting power and jerking like that. Any BMW techs on the forums??
iclukay is offline  
0
Reply With Quote
      03-14-2013, 01:18 AM   #4
Krozi
Deutsche Jung aus Kölle
 
Krozi's Avatar
 
Drives: 2008 E92 ///M3 Alpine White
Join Date: Oct 2009
Location: SoFla - Bonita Springs

Posts: 2,702
iTrader: (21)

Jesus o_O

Sorry can't help, but curious what it is lol...
__________________

2008 E92 ///M3 Alpine White//Fox Red//6MT//
Florida Bimmer - Join us on FaceBook!
Krozi is offline   Germany
0
Reply With Quote
      03-17-2013, 03:35 PM   #5
iclukay
Enlisted Member
 
Drives: 2007 335i Black/Terra
Join Date: Nov 2010
Location: Windermere, FL

Posts: 31
iTrader: (0)

Bump... Been going on for a couple months now and would really appreciate any and all advice!
iclukay is offline  
0
Reply With Quote
      03-24-2013, 02:11 PM   #6
cheesus
New Member
 
Drives: 2005 325i
Join Date: Apr 2012
Location: Germany

Posts: 14
iTrader: (0)

Did you take the car to your dealer? What´s in the error memory?
Looks really strange
cheesus is offline  
0
Reply With Quote
Post Reply

Bookmarks

Tags
e46, maintenance, problem, takeoffs

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:34 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST