BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > General M3 Forum (E90 + E92 + E93)
 
Stick to Clutch
Post Reply
 
Thread Tools Search this Thread
      03-17-2013, 01:35 PM   #1
swein1992
Enlisted Member
 
Drives: 2010 E92 M3 Silverstone
Join Date: Feb 2013
Location: Indiana

Posts: 36
iTrader: (0)

Clicking noise and engine reving at idle

Hey guys I am new here. I just got my 2010 e92 M3 few weeks ago and I am really new to the vehicle. The car has 40000 miles on it and it is equipped with DCT. So I have had this problem recently. When I turn the steering wheel and release it at stationary, it will make a really annoying sound inside. It feels like the steering wheel is knocking something. I went to the dealer and they said the noise is from the release of tension and steering wheel going back to the place. I also notice that when I turn the steering wheel at stationary, the engine revs up and bounces between 600~1000 rpm. The dealer said its normal due to power steering gives load to the engine. Do your M3s act the same?
swein1992 is offline   United_States
0
Reply With Quote
      03-17-2013, 07:37 PM   #2
4nroots
Subluxator
 
4nroots's Avatar
 
Drives: E90 335d, E93 M3
Join Date: Sep 2005
Location: Toronto

Posts: 450
iTrader: (0)

My car did this too. It was really annoying and the techs had a really tough time figuring it out. Turns out that the front passenger side spring wasn't sitting in its perch properly. Once they fixed that the noise went away. Ask the dealer to check it.
__________________
E90 335d LeMans Blue, M-Sport, Exec, Premium, Nav, 260s
E93 M3 Space Grey, Fully loaded
If I lived in Germany, I'd be proud to drive domestic!
4nroots is offline   Canada
0
Reply With Quote
      03-17-2013, 10:13 PM   #3
swein1992
Enlisted Member
 
Drives: 2010 E92 M3 Silverstone
Join Date: Feb 2013
Location: Indiana

Posts: 36
iTrader: (0)

Thanks!! I will have that checked immediately!!
Quote:
Originally Posted by 4nroots View Post
My car did this too. It was really annoying and the techs had a really tough time figuring it out. Turns out that the front passenger side spring wasn't sitting in its perch properly. Once they fixed that the noise went away. Ask the dealer to check it.
swein1992 is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:55 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST