BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
Steve Thomas BMW
Post Reply
 
Thread Tools Search this Thread
      03-07-2013, 01:45 PM   #1
edwinm3
Lieutenant Colonel
 
edwinm3's Avatar
 
Drives: E92 MELBOURNE RED M3
Join Date: Nov 2011
Location: Doral

Posts: 1,751
iTrader: (8)

What controls cold start?

What specific engine component makes the engine cycle through the cold start function? I know software can turn it on and off but I ask because my car is not cold cycling like it used to. It tries to cycle for a couple of seconds and then it idles normal. I have a tune but the cold start was kept on.
__________________

Evolve Stage 2, GTS-DCT Software, Akrapovic Exhaust, AA Catless X Pipe, AA Geen Air filter, AA Pulley, Stoptech BBK, KW V3 Coilovers
"If it feels like it's on rails, you're not driving fast enough"
edwinm3 is offline   United_States
0
Reply With Quote
      03-09-2013, 11:40 PM   #2
BMRLVR
Grease Monkey
 
BMRLVR's Avatar
 
Drives: 2011 E90 M3,1994 Euro E36 M3/4
Join Date: Apr 2006
Location: Fort McMurray, Alberta, Canada

Posts: 2,325
iTrader: (3)

Pretty sure that the DME uses coolant temperature to decide wether to enable cold start or not.
__________________
2011 E90 M3 ZCP - Individual Moonstone/Individual Amarone Extended/Individual Piano Black With Inlay:LINK!!!
1994 Euro E36 M3 Sedan - Daytona Violet/Mulberry:LINK!!!
BMRLVR is offline   Canada
0
Reply With Quote
      03-10-2013, 04:12 AM   #3
M3takesNYC
Banned
 
Drives: m3
Join Date: Feb 2013
Location: NYC

Posts: 426
iTrader: (0)

You would think but countless times I have turned my car off for a few minutes and then restarted after a quick trip in the store or something and the cold start loudness happens and the car is still fully warm so I wondered this same question myself.
M3takesNYC is offline  
0
Reply With Quote
      03-10-2013, 08:08 AM   #4
edwinm3
Lieutenant Colonel
 
edwinm3's Avatar
 
Drives: E92 MELBOURNE RED M3
Join Date: Nov 2011
Location: Doral

Posts: 1,751
iTrader: (8)

Quote:
Originally Posted by M3takesNYC
You would think but countless times I have turned my car off for a few minutes and then restarted after a quick trip in the store or something and the cold start loudness happens and the car is still fully warm so I wondered this same question myself.
Yeah exactly mine did the same thing. I just tested the secondary air pump and it is good but still no cold starts
__________________

Evolve Stage 2, GTS-DCT Software, Akrapovic Exhaust, AA Catless X Pipe, AA Geen Air filter, AA Pulley, Stoptech BBK, KW V3 Coilovers
"If it feels like it's on rails, you're not driving fast enough"
edwinm3 is offline   United_States
0
Reply With Quote
      03-10-2013, 05:34 PM   #5
BMRLVR
Grease Monkey
 
BMRLVR's Avatar
 
Drives: 2011 E90 M3,1994 Euro E36 M3/4
Join Date: Apr 2006
Location: Fort McMurray, Alberta, Canada

Posts: 2,325
iTrader: (3)

Quote:
Originally Posted by M3takesNYC
You would think but countless times I have turned my car off for a few minutes and then restarted after a quick trip in the store or something and the cold start loudness happens and the car is still fully warm so I wondered this same question myself.
The coolant temp is probably the main thing but no doubt some other values may be taken into consideration, like oil temp, IAT, catalyst temp, etc
__________________
2011 E90 M3 ZCP - Individual Moonstone/Individual Amarone Extended/Individual Piano Black With Inlay:LINK!!!
1994 Euro E36 M3 Sedan - Daytona Violet/Mulberry:LINK!!!
BMRLVR is offline   Canada
0
Reply With Quote
      03-10-2013, 05:40 PM   #6
aussiem3
Lieutenant Colonel
 
aussiem3's Avatar
 
Drives: Goggomobil
Join Date: Jul 2007
Location: Kangaroo land

Posts: 1,566
iTrader: (1)

Garage List
2014 BMW X5 30d  [0.00]
2007 E92 M3  [0.00]
Quote:
Originally Posted by edwinm3 View Post
What specific engine component makes the engine cycle through the cold start function? I know software can turn it on and off but I ask because my car is not cold cycling like it used to. It tries to cycle for a couple of seconds and then it idles normal. I have a tune but the cold start was kept on.
Why won't you ask Mike Benvo. He can disable cold start in his stage I tune and I am sure he can tell wheat exactly is involved. I think cold start is all about the cat pre-heating process.
__________________

2007 E92 6MT - Silverstone II with /// Performance Exhaust with ACM Test Pipes and BPM Sport Stage II Dev-Tune - Proper engine warm up, 12-monthly oil change, Castrol TWS 10w-60
2014 F15 X5 3.0d
aussiem3 is offline   Australia
0
Reply With Quote
      03-10-2013, 06:58 PM   #7
edwinm3
Lieutenant Colonel
 
edwinm3's Avatar
 
Drives: E92 MELBOURNE RED M3
Join Date: Nov 2011
Location: Doral

Posts: 1,751
iTrader: (8)

Quote:
Originally Posted by aussiem3 View Post
Why won't you ask Mike Benvo. He can disable cold start in his stage I tune and I am sure he can tell wheat exactly is involved. I think cold start is all about the cat pre-heating process.
Yeah I'm hoping Mike can chime in. I'm catless and tuned but the cold start was definitely kept on. No codes or anything when scanned. It sounds like it wants to go through the cycle but it cuts off, weird
__________________

Evolve Stage 2, GTS-DCT Software, Akrapovic Exhaust, AA Catless X Pipe, AA Geen Air filter, AA Pulley, Stoptech BBK, KW V3 Coilovers
"If it feels like it's on rails, you're not driving fast enough"
edwinm3 is offline   United_States
0
Reply With Quote
      03-10-2013, 07:09 PM   #8
VCP
Lieutenant
 
VCP's Avatar
 
Drives: F82 Sakhir / E92 Dakar
Join Date: Mar 2011
Location: Canada

Posts: 576
iTrader: (0)

why dont you call or email active since you have a tune from them and they can help you out

Quote:
Originally Posted by edwinm3 View Post
Yeah I'm hoping Mike can chime in. I'm catless and tuned but the cold start was definitely kept on. No codes or anything when scanned. It sounds like it wants to go through the cycle but it cuts off, weird
VCP is offline   Canada
0
Reply With Quote
      03-10-2013, 08:34 PM   #9
edwinm3
Lieutenant Colonel
 
edwinm3's Avatar
 
Drives: E92 MELBOURNE RED M3
Join Date: Nov 2011
Location: Doral

Posts: 1,751
iTrader: (8)

Quote:
Originally Posted by VCMperformance View Post
why dont you call or email active since you have a tune from them and they can help you out
I did that already and they couldn't help because no codes come up. Car runs fine but it bugs me that I know there is something wrong. It's just one of those things
__________________

Evolve Stage 2, GTS-DCT Software, Akrapovic Exhaust, AA Catless X Pipe, AA Geen Air filter, AA Pulley, Stoptech BBK, KW V3 Coilovers
"If it feels like it's on rails, you're not driving fast enough"
edwinm3 is offline   United_States
0
Reply With Quote
      03-11-2013, 07:07 AM   #10
aussiem3
Lieutenant Colonel
 
aussiem3's Avatar
 
Drives: Goggomobil
Join Date: Jul 2007
Location: Kangaroo land

Posts: 1,566
iTrader: (1)

Garage List
2014 BMW X5 30d  [0.00]
2007 E92 M3  [0.00]
Quote:
Originally Posted by VCMperformance View Post
why dont you call or email active since you have a tune from them and they can help you out
I am not the one with a cycle issue. Read the thread properly before getting a bee on your bonnet.
__________________

2007 E92 6MT - Silverstone II with /// Performance Exhaust with ACM Test Pipes and BPM Sport Stage II Dev-Tune - Proper engine warm up, 12-monthly oil change, Castrol TWS 10w-60
2014 F15 X5 3.0d
aussiem3 is offline   Australia
0
Reply With Quote
      03-11-2013, 07:11 AM   #11
aussiem3
Lieutenant Colonel
 
aussiem3's Avatar
 
Drives: Goggomobil
Join Date: Jul 2007
Location: Kangaroo land

Posts: 1,566
iTrader: (1)

Garage List
2014 BMW X5 30d  [0.00]
2007 E92 M3  [0.00]
Quote:
Originally Posted by edwinm3 View Post
Yeah I'm hoping Mike can chime in. I'm catless and tuned but the cold start was definitely kept on. No codes or anything when scanned. It sounds like it wants to go through the cycle but it cuts off, weird
Is this a new issue or has existed since the tune and the catless option? The reason me asking is because the DME may be sensing there are no more cats and cuts off early. It might be normal. From your signature I picked up you have AA Tune. So I don't think it will be a good idea to ask Mike about the issue. He might be able to give you some direction but not a fix. Good luck
__________________

2007 E92 6MT - Silverstone II with /// Performance Exhaust with ACM Test Pipes and BPM Sport Stage II Dev-Tune - Proper engine warm up, 12-monthly oil change, Castrol TWS 10w-60
2014 F15 X5 3.0d

Last edited by aussiem3; 03-11-2013 at 07:17 AM.
aussiem3 is offline   Australia
0
Reply With Quote
      03-11-2013, 12:23 PM   #12
IMG
VT3
 
IMG's Avatar
 
Drives: E36 M3 Track car,Ess E90 M3 DD
Join Date: Feb 2008
Location: The Couch

Posts: 6,975
iTrader: (5)

Quote:
Originally Posted by BMRLVR View Post
The coolant temp is probably the main thing but no doubt some other values may be taken into consideration, like oil temp, IAT, catalyst temp, etc
+1
__________________
NO FEAR.NO LIMITS.NO EQUAL

Ess VT3 LC built motor,Volk TE37SL,Euro taillights,Dinan Xpipe,Custom Headers,Akra axle back CF tips,ModeCarbon FR lip,BMW CF wing
LOW BOOST 60-130 6.7 sec
IMG is offline  
0
Reply With Quote
      03-11-2013, 01:42 PM   #13
edwinm3
Lieutenant Colonel
 
edwinm3's Avatar
 
Drives: E92 MELBOURNE RED M3
Join Date: Nov 2011
Location: Doral

Posts: 1,751
iTrader: (8)

Quote:
Originally Posted by aussiem3
Quote:
Originally Posted by edwinm3 View Post
Yeah I'm hoping Mike can chime in. I'm catless and tuned but the cold start was definitely kept on. No codes or anything when scanned. It sounds like it wants to go through the cycle but it cuts off, weird
Is this a new issue or has existed since the tune and the catless option? The reason me asking is because the DME may be sensing there are no more cats and cuts off early. It might be normal. From your signature I picked up you have AA Tune. So I don't think it will be a good idea to ask Mike about the issue. He might be able to give you some direction but not a fix. Good luck
It's a new issue, cold start was working fine with the tune.
I totally understand what you're saying about Asking Mike, I was just hoping anyone would help, thread wasn't directed to him.
__________________

Evolve Stage 2, GTS-DCT Software, Akrapovic Exhaust, AA Catless X Pipe, AA Geen Air filter, AA Pulley, Stoptech BBK, KW V3 Coilovers
"If it feels like it's on rails, you're not driving fast enough"
edwinm3 is offline   United_States
0
Reply With Quote
      03-11-2013, 01:47 PM   #14
edwinm3
Lieutenant Colonel
 
edwinm3's Avatar
 
Drives: E92 MELBOURNE RED M3
Join Date: Nov 2011
Location: Doral

Posts: 1,751
iTrader: (8)

Quote:
Originally Posted by aussiem3
Quote:
Originally Posted by VCMperformance View Post
why dont you call or email active since you have a tune from them and they can help you out
I am not the one with a cycle issue. Read the thread properly before getting a bee on your bonnet.
Not sure what you guys mean
__________________

Evolve Stage 2, GTS-DCT Software, Akrapovic Exhaust, AA Catless X Pipe, AA Geen Air filter, AA Pulley, Stoptech BBK, KW V3 Coilovers
"If it feels like it's on rails, you're not driving fast enough"
edwinm3 is offline   United_States
0
Reply With Quote
      03-11-2013, 04:01 PM   #15
aussiem3
Lieutenant Colonel
 
aussiem3's Avatar
 
Drives: Goggomobil
Join Date: Jul 2007
Location: Kangaroo land

Posts: 1,566
iTrader: (1)

Garage List
2014 BMW X5 30d  [0.00]
2007 E92 M3  [0.00]
Quote:
Originally Posted by edwinm3 View Post
Not sure what you guys mean
I was reacting to OP, nothing to worry.
__________________

2007 E92 6MT - Silverstone II with /// Performance Exhaust with ACM Test Pipes and BPM Sport Stage II Dev-Tune - Proper engine warm up, 12-monthly oil change, Castrol TWS 10w-60
2014 F15 X5 3.0d
aussiem3 is offline   Australia
0
Reply With Quote
      03-12-2013, 06:22 PM   #16
VCMpower
Banned
 
Drives: 2010 Dakar, 2013 Fire Orange
Join Date: Jan 2010
Location: Victoria B.C.

Posts: 941
iTrader: (0)

So who is the OP? Maybe down under you are upside down



Quote:
Originally Posted by aussiem3 View Post
I was reacting to OP, nothing to worry.
VCMpower is offline   Canada
0
Reply With Quote
      03-21-2013, 12:00 AM   #17
JHFW89225
Major
 
JHFW89225's Avatar
 
Drives: E92 M3
Join Date: Nov 2006
Location: HK/Vancouver

Posts: 1,095
iTrader: (5)

Garage List
2009 BMW M3  [0.00]
2008 335i  [0.00]
I am curious about this too because I have a issue which I just noticed this week and it happens when I start up the car after parking it for around 5 min and I put it in gear and drive off right away. When I do that it sounds harsh like my 335i when it was misfiring... But when I let the car wait for as little as 20 seconds and drive off its perfectly fine.

No idle issue whatsoever... Dinan tune + Akrapovic delete R +
__________________
2013 Scion FR-S Raven Black
2009 BMW E92 M3 Alpine White/Foxtrot Red Leather/M-DCT/Dinan Intake/Dinan ECU/Dinan Stage 1 Suspension/Dinan Strut Bar/Akrapovic Evolution Exhaust
2008 BMW E90 335i
2005 BMW X3 3.0i
JHFW89225 is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:26 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST