BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > M3 Photos/Video/Media Gallery
 
Evolve Automotive
Post Reply
 
Thread Tools Search this Thread
      02-14-2013, 10:42 AM   #23
j2m
Colonel
 
j2m's Avatar
 
Drives: '11 E92 M3 DCT
Join Date: Jun 2011
Location: Calgary, Ab

Posts: 2,452
iTrader: (8)

Garage List
2011 BMW E92 M3  [5.00]
Your car looks great
__________________

11' E92 M3 Space Grey | DCT | ESS VT2- 625 | Gintani Race (valved) + Quad Res Catless X-Pipe | KW Sleeve's | GC Camber Plates|Arkym Diffuser | Vorsteiner VRS Lip | P3 Boost Guage | Stud Conversion
PHOTO's: Click Here ESS VT2 625 PHOTOS: Click Here
j2m is offline   Canada
0
Reply With Quote
      02-15-2013, 09:15 AM   #24
Conzyo
Sup
 
Conzyo's Avatar
 
Drives: JRZ E90 M3
Join Date: Jun 2012
Location: MN

Posts: 410
iTrader: (3)

Looks awesome.
__________________

2008 | 6 SPD | Fox Red | Volk G2 | B&G Springs | MagnaFlow
instagram @conzy0
Conzyo is offline   United_States
0
Reply With Quote
      02-16-2013, 10:38 AM   #25
RingMeister01
Colonel
 
RingMeister01's Avatar
 
Drives: The Ultimate Driving Machine
Join Date: Dec 2012
Location: Long Island, NY

Posts: 2,358
iTrader: (0)

Garage List
Man that looks just right
__________________
F82 M4 Individual / F87 M2 (on the list) / E36 M3 (track) / E21 320i (S52 + Getrag 420G Swap) / RR Sport (daily)
RingMeister01 is offline   United_States
0
Reply With Quote
      02-16-2013, 03:57 PM   #26
Ivan@PYSpeed.com
 
Ivan@PYSpeed.com's Avatar
 
Drives: E90
Join Date: Jan 2013
Location: San Jose, CA

Posts: 3,953
iTrader: (4)

the drop is perfect!!
Ivan@PYSpeed.com is offline  
0
Reply With Quote
      11-22-2013, 07:37 PM   #27
jahn_baakus
Member
 
jahn_baakus's Avatar
 
Drives: 2008 E92 M3
Join Date: Jan 2011
Location: NorCal

Posts: 68
iTrader: (0)

Garage List
2008 E92 M3  [0.00]
Quote:
Originally Posted by REDBULL View Post
thanks! Yeah i do not think it is bottoming out either. hopefully someone else here may chime in knowing what specifically might cause the popping sound under that load. otherwise i am going back end of week to double check everything anyway.
Did you ever figure out what was causing the noise? What resolved it?
__________________
2008 E92 M3 MT6 | Melbourne Red | KW Clubsport |
Rogue SSK


jahn_baakus is offline  
0
Reply With Quote
      11-22-2013, 08:01 PM   #28
REDBULL
Captain
 
REDBULL's Avatar
 
Drives: '12 SG M3/Fox Red
Join Date: Feb 2010
Location: NoVA

Posts: 693
iTrader: (6)

Quote:
Originally Posted by jahn_baakus View Post
Did you ever figure out what was causing the noise? What resolved it?
Yup! I guess it was part of the "break in". it went away on its own. when i had it double checked everything was installed correctly. Thousands of miles later i am having no issues at all.
__________________

12 E92 M3 SG/Fox Red - ESS VT2-650 | Mode Carbon | KW Clubsports | IPE | Challenge Race X pipe
10 E92 M3 MR/Black - rod bearing failure
REDBULL is offline   United_States
0
Reply With Quote
      11-23-2013, 02:59 AM   #29
jahn_baakus
Member
 
jahn_baakus's Avatar
 
Drives: 2008 E92 M3
Join Date: Jan 2011
Location: NorCal

Posts: 68
iTrader: (0)

Garage List
2008 E92 M3  [0.00]
Quote:
Originally Posted by REDBULL View Post
Yup! I guess it was part of the "break in". it went away on its own. when i had it double checked everything was installed correctly. Thousands of miles later i am having no issues at all.
Great. Thanks for the update, glad everything worked out! How many miles on your suspension in total before the noise subsided?

I'm getting my clubsports checked as well for a similar noise, nice to know this went away..
__________________
2008 E92 M3 MT6 | Melbourne Red | KW Clubsport |
Rogue SSK


jahn_baakus is offline  
0
Reply With Quote
      11-23-2013, 12:33 PM   #30
JEllis
Brigadier General
 
JEllis's Avatar
 
Drives: E36 M3, E92 M3
Join Date: Oct 2006
Location: SD CA/Yuma

Posts: 4,706
iTrader: (4)

I would check your strut mounts and make sure they are snug in the rear. Also, check your front camber plates just in case. I never had any popping with my Clubsports from day one.
__________________
http://www.m3post.com/forums/signaturepics/sigpic14547_7.gif
JEllis is offline  
0
Reply With Quote
      11-23-2013, 12:39 PM   #31
ILSMKU
BMW FTW
 
ILSMKU's Avatar
 
Drives: E92 M3
Join Date: Jul 2011
Location: ///OC

Posts: 1,732
iTrader: (5)

Garage List
Rear shock tower is probably loose. You have to tighten it until it STOPS. Pulls your plastics and check each side.
__________________
///2013 AW 6MT E92 ZCP M3/// Black 359M Wheels/BMW Performance Carbon Fiber Spoiler and Mirror Caps/Arkym AeroSport Front Lip/Turner 15MM Spacers/LUX 8 LED Halo/IND Gloss Black Grills, Gills and M3 Emblem/30% 3M Tint/BMW Interior LED/MusicCar Subwoofer Enclosure/JL Audio 12" W6 Sub and XD600:1 Amp/Euro Sunglasses Tray/Ceramic Coated Megan Racing Exhaust/AFe Dry Air Filter/RPI Intake Scoops/Euro MDM/Feature Coded.
ILSMKU is online now   No_Country
0
Reply With Quote
      11-23-2013, 03:54 PM   #32
1M_@teewhybs
Lieutenant
 
1M_@teewhybs's Avatar
 
Drives: E92
Join Date: Jun 2013
Location: NJ

Posts: 591
iTrader: (0)

Garage List
2010 BMW M3  [4.17]
Sweet. All she needs is a lip
1M_@teewhybs is offline  
0
Reply With Quote
      11-24-2013, 12:32 AM   #33
REDBULL
Captain
 
REDBULL's Avatar
 
Drives: '12 SG M3/Fox Red
Join Date: Feb 2010
Location: NoVA

Posts: 693
iTrader: (6)

Quote:
Originally Posted by jahn_baakus View Post
Great. Thanks for the update, glad everything worked out! How many miles on your suspension in total before the noise subsided?

I'm getting my clubsports checked as well for a similar noise, nice to know this went away..
Quote:
Originally Posted by JEllis View Post
I would check your strut mounts and make sure they are snug in the rear. Also, check your front camber plates just in case. I never had any popping with my Clubsports from day one.
a few thousand can't remember exactly now. as suggested by JEllis check camber plates. there was one that came lose at one point (again it has been awhile don't remember)

Quote:
Originally Posted by 1M_@teewhybs View Post
Sweet. All she needs is a lip
Mode Carbon Equipped Updated thread: http://www.m3post.com/forums/showthread.php?t=911823
__________________

12 E92 M3 SG/Fox Red - ESS VT2-650 | Mode Carbon | KW Clubsports | IPE | Challenge Race X pipe
10 E92 M3 MR/Black - rod bearing failure
REDBULL is offline   United_States
0
Reply With Quote
      11-24-2013, 01:52 AM   #34
jahn_baakus
Member
 
jahn_baakus's Avatar
 
Drives: 2008 E92 M3
Join Date: Jan 2011
Location: NorCal

Posts: 68
iTrader: (0)

Garage List
2008 E92 M3  [0.00]
Quote:
Originally Posted by JEllis View Post
I would check your strut mounts and make sure they are snug in the rear. Also, check your front camber plates just in case. I never had any popping with my Clubsports from day one.
Quote:
Originally Posted by ILSMKU View Post
Rear shock tower is probably loose. You have to tighten it until it STOPS. Pulls your plastics and check each side.
Thanks everyone for the advice!! I'll check it out..
__________________
2008 E92 M3 MT6 | Melbourne Red | KW Clubsport |
Rogue SSK


jahn_baakus is offline  
0
Reply With Quote
      11-24-2013, 04:38 AM   #35
Nang Vann
Lieutenant Colonel
 
Nang Vann's Avatar
 
Drives: E46 M3, R35 GT-R
Join Date: May 2011
Location: Australia

Posts: 1,519
iTrader: (0)

Sweet ride
Nang Vann is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:45 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST