BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
GTB Performance
Post Reply
 
Thread Tools Search this Thread
      01-03-2013, 11:21 AM   #45
Presence25
New Member
0
Rep
7
Posts

 
Drives: 2013 Jerez Black E92
Join Date: Sep 2012
Location: Dallas, TX

iTrader: (0)

Hi guys,

Newbie here. Picked up my '13 E92 in September and have been loving it. I have an iPhone 4S with iOS 6.0.1. I installed the BMW update and everything seemed to work fine except my texts are now integrating oddly into my car via bluetooth. I still am notified and receive texts as messages in the car but rather than indicating the name of the person at the top it says "sender unknown". Then, in the body of the text, it will say the contact name and follow with the text. So, it'll read something like "John Smith: [TEXT]."

I searched and couldn't find anything about this topic in the forum. Has anyone else encountered this problem generally or since installing this latest updated? If so, can anyone shed some light? Thanks!
Appreciate 0
      01-03-2013, 01:48 PM   #46
drew313
Enlisted Member
drew313's Avatar
United_States
0
Rep
34
Posts

 
Drives: 12 E92 M3, 12 X5 3.5i, 09 S2k
Join Date: Aug 2008
Location: Irvine, CA

iTrader: (0)

Garage List
Quote:
Originally Posted by Presence25 View Post
Hi guys,

Newbie here. Picked up my '13 E92 in September and have been loving it. I have an iPhone 4S with iOS 6.0.1. I installed the BMW update and everything seemed to work fine except my texts are now integrating oddly into my car via bluetooth. I still am notified and receive texts as messages in the car but rather than indicating the name of the person at the top it says "sender unknown". Then, in the body of the text, it will say the contact name and follow with the text. So, it'll read something like "John Smith: [TEXT]."

I searched and couldn't find anything about this topic in the forum. Has anyone else encountered this problem generally or since installing this latest updated? If so, can anyone shed some light? Thanks!
I noticed this too after updating. Before the update, it would correctly show the sender's name at the top.
Appreciate 0
      01-03-2013, 06:46 PM   #47
kscarrol
Colonel
United_States
38
Rep
2,308
Posts

 
Drives: 2011 E90 M3
Join Date: Jun 2010
Location: New Orleans, LA

iTrader: (0)

Quote:
Originally Posted by ///M Ryder View Post
Make sure the "jump drive" has nothing but the update on it............Phil
This is SO frustrating! I tried the latest update and my car again refuses to recognize it. Had this issue earlier and the dealer updated my software so that the version I am currently running is MX 3.5.4 and TX 3.5.5. The UPS01006 update should update my TX to 3.5.6 according to the documentation but I insert the jump drive and the car simply says something to the effect that no software is recognized on the drive.

Since the dealer updated the software I have had some coding done and don't want to lose that so I doubt I will pursue this with the dealer but something is clearly amiss with my car. The port works fine as my iPod plays through it without any issues...
__________________
Current: 2011 Space Grey E90 M3, DCT, Comp. Pkg., Conv. Pkg., everything but Cold Weather Pkg!
Gone: 2008 550, Space Grey, Sports Package, Sport Auto Transmission.
Sold: 2004 545i (U.S.), Steptronic, Silver Gray.

Last edited by kscarrol; 01-03-2013 at 07:05 PM.
Appreciate 0
      01-04-2013, 12:13 AM   #48
mark896
Warrant Officer
mark896's Avatar
United_States
9
Rep
458
Posts

 
Drives: 2011 E92 335is
Join Date: Dec 2011
Location: Alabama

iTrader: (0)

Quote:
Originally Posted by kscarrol View Post
This is SO frustrating! I tried the latest update and my car again refuses to recognize it. Had this issue earlier and the dealer updated my software so that the version I am currently running is MX 3.5.4 and TX 3.5.5. The UPS01006 update should update my TX to 3.5.6 according to the documentation but I insert the jump drive and the car simply says something to the effect that no software is recognized on the drive.

Since the dealer updated the software I have had some coding done and don't want to lose that so I doubt I will pursue this with the dealer but something is clearly amiss with my car. The port works fine as my iPod plays through it without any issues...
Are you POSITIVE the file is a .bin format instead of a .tar format? For some of us, the file downloads as a .tar format instead of .bin.
Appreciate 0
      01-04-2013, 01:47 AM   #49
Mike Benvo
BimmerPost Supporting Vendor
Mike Benvo's Avatar
United_States
98
Rep
4,814
Posts


 
Drives: Harrop SC M3 / E46 M3 / 7Turbo
Join Date: Apr 2008
Location: SoCal

iTrader: (7)

Garage List
2008 BMW M3  [5.00]
1990 BMW 735i Turbo  [5.00]
2004 BMW M3  [0.00]
Send a message via Skype™ to Mike Benvo
Quote:
Originally Posted by mark896 View Post
Are you POSITIVE the file is a .bin format instead of a .tar format? For some of us, the file downloads as a .tar format instead of .bin.
Downloaded as a bin for me.

You on a mac or PC? What browser?
__________________

-----| Like us on Facebook | Instagram || Tuning Information | Remote Coding |-----
----Visit us at www.BPMSport.com - Emotion. Driven. | Toll Free: (888) 557-5133----
Appreciate 0
      01-04-2013, 03:56 AM   #50
aussiem3
Lieutenant Colonel
aussiem3's Avatar
Australia
32
Rep
1,705
Posts

 
Drives: Goggomobil
Join Date: Jul 2007
Location: Kangaroo land

iTrader: (1)

Garage List
2014 BMW X5 30d  [0.00]
2007 E92 M3  [0.00]
This is very confusing ... a handful are experiencing file type issues. I think it's browser related.

Just click on the link to download, rather than right clicking and use "save as". This might be causing the extension issue. My 2c.
__________________

2007 E92 6MT - Silverstone II with /// Performance Exhaust with ACM Test Pipes and BPM Sport Stage II Dev-Tune - Proper engine warm up, 12-monthly oil change, Castrol TWS 10w-60
2014 F15 X5 3.0d
Appreciate 0
      01-04-2013, 05:22 AM   #51
kscarrol
Colonel
United_States
38
Rep
2,308
Posts

 
Drives: 2011 E90 M3
Join Date: Jun 2010
Location: New Orleans, LA

iTrader: (0)

Using a Mac and the Safari browser. Been down this path last time, tried downloading from a PC etc with no luck.

As for the .bin, what actually got downloaded for me was a folder named bin. It holds several different files. Maybe that is the problem... I'll download it again an see what I get from my PC at work.
__________________
Current: 2011 Space Grey E90 M3, DCT, Comp. Pkg., Conv. Pkg., everything but Cold Weather Pkg!
Gone: 2008 550, Space Grey, Sports Package, Sport Auto Transmission.
Sold: 2004 545i (U.S.), Steptronic, Silver Gray.
Appreciate 0
      01-04-2013, 06:02 AM   #52
aussiem3
Lieutenant Colonel
aussiem3's Avatar
Australia
32
Rep
1,705
Posts

 
Drives: Goggomobil
Join Date: Jul 2007
Location: Kangaroo land

iTrader: (1)

Garage List
2014 BMW X5 30d  [0.00]
2007 E92 M3  [0.00]
Quote:
Originally Posted by kscarrol View Post
Using a Mac and the Safari browser. Been down this path last time, tried downloading from a PC etc with no luck.

As for the .bin, what actually got downloaded for me was a folder named bin. It holds several different files. Maybe that is the problem... I'll download it again an see what I get from my PC at work.
clear your cookies and the cache and give it a go, and may be the history as well. Sometime some old files can cause the issue you're experiencing. Worth the try ...
__________________

2007 E92 6MT - Silverstone II with /// Performance Exhaust with ACM Test Pipes and BPM Sport Stage II Dev-Tune - Proper engine warm up, 12-monthly oil change, Castrol TWS 10w-60
2014 F15 X5 3.0d
Appreciate 0
      01-04-2013, 07:32 AM   #53
kscarrol
Colonel
United_States
38
Rep
2,308
Posts

 
Drives: 2011 E90 M3
Join Date: Jun 2010
Location: New Orleans, LA

iTrader: (0)

Will try that... But about the download, was yours a single file or a folder like I downloaded?
__________________
Current: 2011 Space Grey E90 M3, DCT, Comp. Pkg., Conv. Pkg., everything but Cold Weather Pkg!
Gone: 2008 550, Space Grey, Sports Package, Sport Auto Transmission.
Sold: 2004 545i (U.S.), Steptronic, Silver Gray.
Appreciate 0
      01-04-2013, 08:11 AM   #54
Smoult
Registered
England
0
Rep
1
Posts

 
Drives: F10
Join Date: Aug 2012
Location: Uk

iTrader: (0)

Using a mac, just copy the .bin file to the usb memory stick.
IMPORTANT: Don't decompress the .bin file.
Make sure the stick is formatted in a pc format. If it's not use "Disk Utility" [Applications>Utilities>Disk Utility] to erase and format as MS-DOS (FAT16). Copy the "UPD01006.bin" file to the USB stick, dont put it in any other folder. It should take about 15 seconds for the car to recognize the usb drive and software.
Appreciate 0
      01-04-2013, 09:01 AM   #55
kscarrol
Colonel
United_States
38
Rep
2,308
Posts

 
Drives: 2011 E90 M3
Join Date: Jun 2010
Location: New Orleans, LA

iTrader: (0)

Right on the decompress. Didn't do it intentionally, my mac just did it as part of the download. Trying again today downloading from my office PC. But as I noted earlier, I had this same issue with earlier updates and could never get the car to recognize the software. I've used mac and PC's, reformatted the USB stick every way possible etc and still no luck. I'm not optimistic about this one given my prior experiences.
__________________
Current: 2011 Space Grey E90 M3, DCT, Comp. Pkg., Conv. Pkg., everything but Cold Weather Pkg!
Gone: 2008 550, Space Grey, Sports Package, Sport Auto Transmission.
Sold: 2004 545i (U.S.), Steptronic, Silver Gray.
Appreciate 0
      01-04-2013, 09:27 AM   #56
kscarrol
Colonel
United_States
38
Rep
2,308
Posts

 
Drives: 2011 E90 M3
Join Date: Jun 2010
Location: New Orleans, LA

iTrader: (0)

Success! Finally...
__________________
Current: 2011 Space Grey E90 M3, DCT, Comp. Pkg., Conv. Pkg., everything but Cold Weather Pkg!
Gone: 2008 550, Space Grey, Sports Package, Sport Auto Transmission.
Sold: 2004 545i (U.S.), Steptronic, Silver Gray.
Appreciate 0
      01-04-2013, 08:01 PM   #57
aussiem3
Lieutenant Colonel
aussiem3's Avatar
Australia
32
Rep
1,705
Posts

 
Drives: Goggomobil
Join Date: Jul 2007
Location: Kangaroo land

iTrader: (1)

Garage List
2014 BMW X5 30d  [0.00]
2007 E92 M3  [0.00]
Quote:
Originally Posted by kscarrol View Post
Success! Finally...
So what did you do for it to work finally! Given that a couple of people on the forum have had this issue, I think it would be useful to share. Thank you.
__________________

2007 E92 6MT - Silverstone II with /// Performance Exhaust with ACM Test Pipes and BPM Sport Stage II Dev-Tune - Proper engine warm up, 12-monthly oil change, Castrol TWS 10w-60
2014 F15 X5 3.0d
Appreciate 0
      01-04-2013, 08:39 PM   #58
kscarrol
Colonel
United_States
38
Rep
2,308
Posts

 
Drives: 2011 E90 M3
Join Date: Jun 2010
Location: New Orleans, LA

iTrader: (0)

Quote:
Originally Posted by aussiem3 View Post
So what did you do for it to work finally! Given that a couple of people on the forum have had this issue, I think it would be useful to share. Thank you.
Of course! Nothing special really, used my PC at work, reformatted USB stick to FAT 16 and downloaded a new copy of the file. Worked like a charm....

I was a bit jaded from my prior experiences and I had tried all of these variations of formatting before but could never get the car to recognize the new software. But my car is a Sept '10 build, one of the first with the combox, and I thought whatever early software version I had simply wouldn't handle the updates.

The dealer claimed it was resolved with the total car update I got a couple of months ago but this was the first chance I had to test it. Needless to say I was a bit frustrated when my first try did not work!
__________________
Current: 2011 Space Grey E90 M3, DCT, Comp. Pkg., Conv. Pkg., everything but Cold Weather Pkg!
Gone: 2008 550, Space Grey, Sports Package, Sport Auto Transmission.
Sold: 2004 545i (U.S.), Steptronic, Silver Gray.
Appreciate 0
      01-05-2013, 01:22 AM   #59
aussiem3
Lieutenant Colonel
aussiem3's Avatar
Australia
32
Rep
1,705
Posts

 
Drives: Goggomobil
Join Date: Jul 2007
Location: Kangaroo land

iTrader: (1)

Garage List
2014 BMW X5 30d  [0.00]
2007 E92 M3  [0.00]
Thank you, persistent pays off at the end of the day.
__________________

2007 E92 6MT - Silverstone II with /// Performance Exhaust with ACM Test Pipes and BPM Sport Stage II Dev-Tune - Proper engine warm up, 12-monthly oil change, Castrol TWS 10w-60
2014 F15 X5 3.0d
Appreciate 0
      01-05-2013, 01:33 AM   #60
mmcnulty
Enlisted Member
United_States
0
Rep
43
Posts

 
Drives: 2013 E93 M3 DCT SSII
Join Date: Oct 2012
Location: San Francisco

iTrader: (0)

Garage List
Interestingly, this or another recent update (I appear to have been at least two versions behind despite an 8/12 build month) fixed the issues connecting an iPod classic via regular dock cable (and not the Y cable). Previously in that config, if you selected the ipod from the media devices menu, things would just hang and no music would appear.

My music collection is big-ish and I didn't want to go buy a 64GB iPod Touch just to shove hidden away in the center console.

Also as others have noted, bluetooth connectivity speed/reliability with my iPhone 5 is much improved.

Sweet.
Appreciate 0
      01-05-2013, 01:40 AM   #61
MRSSIIM3
General
MRSSIIM3's Avatar
United_States
36
Rep
1,342
Posts

 
Drives: 2015 SSII/SO M4
Join Date: Apr 2009
Location: SoCal

iTrader: (5)

Quote:
Originally Posted by drew313 View Post
I noticed this too after updating. Before the update, it would correctly show the sender's name at the top.
+1 noticed the same
__________________
Current: 2015 M4, SSII / SO
Current: 2013 E92 M3, SSII, Black extended, ZCP, fully loaded
Mods: Black Hood Vents, Black Grilles, Black Side Grilles, Lux H8 v. 4.0, CF Mirrors, CF Spoiler, Black ///M Emblem, Evolve Tune, Dinan CF Intake, Dinan Pulley, Akrapovic GT4
Retired: 2011.5 E92 M3, SSII
Appreciate 0
      01-05-2013, 12:33 PM   #62
mark896
Warrant Officer
mark896's Avatar
United_States
9
Rep
458
Posts

 
Drives: 2011 E92 335is
Join Date: Dec 2011
Location: Alabama

iTrader: (0)

Quote:
Originally Posted by kscarrol View Post
Of course! Nothing special really, used my PC at work, reformatted USB stick to FAT 16 and downloaded a new copy of the file. Worked like a charm....

I was a bit jaded from my prior experiences and I had tried all of these variations of formatting before but could never get the car to recognize the new software. But my car is a Sept '10 build, one of the first with the combox, and I thought whatever early software version I had simply wouldn't handle the updates.

The dealer claimed it was resolved with the total car update I got a couple of months ago but this was the first chance I had to test it. Needless to say I was a bit frustrated when my first try did not work!
Yea, it just didn't sound like the port was broken to me.
Appreciate 0
      01-05-2013, 04:02 PM   #63
kscarrol
Colonel
United_States
38
Rep
2,308
Posts

 
Drives: 2011 E90 M3
Join Date: Jun 2010
Location: New Orleans, LA

iTrader: (0)

Quote:
Originally Posted by mark896 View Post
Yea, it just didn't sound like the port was broken to me.
Yes, I knew it wasn't the port and that it was something in the early combox software I had. Having been fully updated a couple of months ago I had hoped the issue was resolved so when the car wouldn't "recognize" the software update I was very frustrated. Ultimately it was operator error this go around and the update worked...
__________________
Current: 2011 Space Grey E90 M3, DCT, Comp. Pkg., Conv. Pkg., everything but Cold Weather Pkg!
Gone: 2008 550, Space Grey, Sports Package, Sport Auto Transmission.
Sold: 2004 545i (U.S.), Steptronic, Silver Gray.
Appreciate 0
      02-08-2013, 01:58 PM   #64
SpartanGA
First Lieutenant
United_States
3
Rep
388
Posts

 
Drives: TBD
Join Date: Feb 2007
Location: Atlanta, GA

iTrader: (0)

just thought I would add to this thread.

I didnt realize there were software updates until I was bored and browsing all my settings while parked. I had version 3.4.xx (dont recall exact).

I had only 1 issue and it was browser related. I normally use Chrome, but after putting in the VIN and selecting the latest file and agree button, the download button didnt work...this is somewhat common in Chrome. So I just redid it in IE and it worked fine.

Put it in a blank flash stick and went out to the car. It took a minute or 2 for it to find the flash drive initially, but then it found it and listed the 2 updates that were valid and going to be installed. multi and telephone. 3.5.4 and 3.5.6. I said OK and it went along for a few minutes. It wanted me to start the car first I noticed.

A few comments:

- I use my iPhone 5, os6.1 using bluetooth. I dont use USB anymore (I used to charge this way, but it then removes the bluetooth audio). I got a mini power port that gives me 2 USB ports for my power port in the center console...so I only charge it that way.

Anyway, bluetooth doesnt show artwork when playing Pandora, for example. However, the new update is very quick at updating the song info. However, when switching to Slacker radio app or SiriusXM app, it does NOT update the song info still.

I have a 2011 e93, build date is August 2011

I notice some are talking about getting texts and/or email. Is this an additional option on some idrives? I do not see anything in settings to allow this in my car. I can send the car a message from the bmw remote app.

One other comment, my car came with the iPhone adapter cable...however, I never had a pre iPhone5...so only the lightning cable. Am I missing some features because of this?

thx, sorry for all the questions.
Appreciate 0
      02-08-2013, 04:08 PM   #65
Johndong888
John
Johndong888's Avatar
United_States
10
Rep
792
Posts

 
Drives: '12 AW/FR M3 & '14 F15 X5
Join Date: Feb 2008
Location: Cherry Hill, NJ

iTrader: (8)

Send a message via Skype™ to Johndong888
Quote:
Originally Posted by SpartanGA View Post
just thought I would add to this thread.

I didnt realize there were software updates until I was bored and browsing all my settings while parked. I had version 3.4.xx (dont recall exact).

I had only 1 issue and it was browser related. I normally use Chrome, but after putting in the VIN and selecting the latest file and agree button, the download button didnt work...this is somewhat common in Chrome. So I just redid it in IE and it worked fine.

Put it in a blank flash stick and went out to the car. It took a minute or 2 for it to find the flash drive initially, but then it found it and listed the 2 updates that were valid and going to be installed. multi and telephone. 3.5.4 and 3.5.6. I said OK and it went along for a few minutes. It wanted me to start the car first I noticed.

A few comments:

- I use my iPhone 5, os6.1 using bluetooth. I dont use USB anymore (I used to charge this way, but it then removes the bluetooth audio). I got a mini power port that gives me 2 USB ports for my power port in the center console...so I only charge it that way.

Anyway, bluetooth doesnt show artwork when playing Pandora, for example. However, the new update is very quick at updating the song info. However, when switching to Slacker radio app or SiriusXM app, it does NOT update the song info still.

I have a 2011 e93, build date is August 2011

I notice some are talking about getting texts and/or email. Is this an additional option on some idrives? I do not see anything in settings to allow this in my car. I can send the car a message from the bmw remote app.

One other comment, my car came with the iPhone adapter cable...however, I never had a pre iPhone5...so only the lightning cable. Am I missing some features because of this?

thx, sorry for all the questions.
Bluetooth Streaming does not show playlist nor does it show album art. It shouldn't have issues to update song info.

In order to receive text in the phone, you go to your iphone settings -> Bluetooth -> Hit the Blue arrow next to the BMW XXXXX. Make sure "SHOW NOTIFICATIONS" is on. This will enable the text messages on your idrive. Text messages will be shown under "Office" or Telephone's Message.

Hope this helps.

-john
__________________

Current - 2012 AW/FR E92 M3 - DCT w EDC, ZPP w Tech, Apps, Enhanced Sound, SAT.
Mods - BPMTune Stg1 + Servo, Piano Black, Euro Visors, OEM Performance CF Spoiler + Grills + Pedals, IND Gloss Blk Pkg, Umnitza V4, ModeCarbon GTS V1 Lip, 19" HRE P40
Sold - 2008 BSM/Black E92 335i - Step, Premium, Sports, Logic7, Comfort, Navi, SAT, Alum.
Appreciate 0
      02-08-2013, 05:45 PM   #66
SpartanGA
First Lieutenant
United_States
3
Rep
388
Posts

 
Drives: TBD
Join Date: Feb 2007
Location: Atlanta, GA

iTrader: (0)

Quote:
Originally Posted by Johndong888 View Post
Bluetooth Streaming does not show playlist nor does it show album art. It shouldn't have issues to update song info.

In order to receive text in the phone, you go to your iphone settings -> Bluetooth -> Hit the Blue arrow next to the BMW XXXXX. Make sure "SHOW NOTIFICATIONS" is on. This will enable the text messages on your idrive. Text messages will be shown under "Office" or Telephone's Message.

Hope this helps.

-john
Perfect thx.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:00 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST