BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing
 
Stick to Clutch
Post Reply
 
Thread Tools Search this Thread
      01-25-2013, 05:08 PM   #1
ThatGuyMikee
Captain
 
ThatGuyMikee's Avatar
 
Drives: 2008 m3 e90 6spd
Join Date: Jul 2012
Location: Staten island

Posts: 694
iTrader: (2)

probelm after problem

i have a 08 e90 m3, only had her for about 5 months and she has 42k on the dash now, when i bought her best car i ever had, great power and fun to drive

bring it back a week ago, had the known fuel pump malfunction problem, brought it to the dealer and they changed the fuel pump module and it took 2 days to reporgram the whole car

picked up the car the other day and everything was fine, i noticed right away on first start up it isnt loud anymore with the cat warmup on idle, maybe they coded it off with the new program? idk

day after that start the car and its idling like crap but smooths out after a couple of seconds, did this 2 days in a row and didnt do it today, also when driving giving it some gas to say change lanes fast the car has no power(hesitates), then all of a sudden it has all the power as if it was restricted

idk if the program they did to the car isnt good or done right or the car has to relearn everything, just want some input, car is going back on monday, hopefully its a program problem and not the idle controle module going out now, warrenty is up in the 17th of feb.
__________________
Originally Posted by onebadmofo

Some people buy cars to look at them and call them their babies, but not me. This car is my bitch and I bought it to drive it.
ThatGuyMikee is offline  
0
Reply With Quote
      01-25-2013, 05:28 PM   #2
THE TECH
BimmerPost Supporting Vendor

 
THE TECH's Avatar
 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

Posts: 13,036
iTrader: (42)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Dealer really can't code so I would rule that out. Might be a slight relearn involved with the new programming/adaptations.
__________________
THE TECH is offline   United_States
0
Reply With Quote
      01-25-2013, 05:44 PM   #3
ThatGuyMikee
Captain
 
ThatGuyMikee's Avatar
 
Drives: 2008 m3 e90 6spd
Join Date: Jul 2012
Location: Staten island

Posts: 694
iTrader: (2)

Quote:
Originally Posted by THE TECH View Post
Dealer really can't code so I would rule that out. Might be a slight relearn involved with the new programming/adaptations.
idk i hope it needs just a relearn or something, never had the problem till after the dealer go figure lol, also i dont know why it doesnt do the warm up cycle anymore
__________________
Originally Posted by onebadmofo

Some people buy cars to look at them and call them their babies, but not me. This car is my bitch and I bought it to drive it.
ThatGuyMikee is offline  
0
Reply With Quote
      02-12-2013, 07:04 PM   #4
mdosu
Banned
 
Drives: Double Vanos'd Civic-M3
Join Date: Oct 2009
Location: San Francisco

Posts: 8,517
iTrader: (6)

If it's a rough idle then I think it's a idle air control valve issue. Fairly common issue for our cars.
mdosu is offline   No_Country
0
Reply With Quote
      02-12-2013, 07:30 PM   #5
Richbot
Lieutenant Colonel
 
Drives: Jerez Black E90
Join Date: Sep 2007
Location: STL

Posts: 1,971
iTrader: (2)

What well known fuel pump malfunction problem?
__________________
Richbot is offline  
0
Reply With Quote
      02-12-2013, 07:36 PM   #6
ThatGuyMikee
Captain
 
ThatGuyMikee's Avatar
 
Drives: 2008 m3 e90 6spd
Join Date: Jul 2012
Location: Staten island

Posts: 694
iTrader: (2)

this is all cleard up , went in for a fuel pump module malfunction, got the car back with a funky idle and hesitation on driving( lost its balls), went back in and go it back after they replaced two actuators and a coilpack(number3) once in a while on cold start it has a 30-40 second rough idle, not to where it will stall just not smooth, they gave me a bulletin saying its completly normal for the m3 to have a rough idle time to time on cold start( bullshit) it never did this before they touched it, its been a week so far since i got it back and so far so good, only had the rough idle one day for a breif moment then smooth out, everything else is fine, weil see what happens
__________________
Originally Posted by onebadmofo

Some people buy cars to look at them and call them their babies, but not me. This car is my bitch and I bought it to drive it.
ThatGuyMikee is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:44 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST