BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
Evolve Automotive
Post Reply
 
Thread Tools Search this Thread
      12-17-2012, 01:02 AM   #1
eddiek
Enlisted Member
 
Drives: '09 E93 DCT
Join Date: Aug 2009
Location: Portland, Oregon

Posts: 34
iTrader: (0)

Help! Blank right side of iDrive Screen

I have a 2009 E93 where intermittently ever since I've had it, the right side of the iDrive screen is black when I start the car. I usually have the map on the right side with radio on the left side. If I deselect the right side and then reselect this, it appears correctly. I've brought this in at least 4 times to the dealer and they can't seem to fix it. They've reprogrammed it each time, replaced the CIC twice and replaced the fiber optic cable most recently. This is still an ongoing issue. It's not life or death but it's really annoying paying this much for a car where they can't figure this out. Anyone else seen this issue? Thanks.
Attached Images
 
eddiek is offline  
0
Reply With Quote
      12-17-2012, 06:45 AM   #2
kscarrol
Colonel
 
Drives: 2011 E90 M3
Join Date: Jun 2010
Location: New Orleans, LA

Posts: 2,067
iTrader: (0)

I have a 2011 that has just started doing this. Actually started AFTER I had my software updated a little over a month ago... No clue as to what causes it and have yet to complain to the dealer.
__________________
Current: 2011 Space Grey E90 M3, DCT, Comp. Pkg., Conv. Pkg., everything but Cold Weather Pkg!
Gone: 2008 550, Space Grey, Sports Package, Sport Auto Transmission.
Sold: 2004 545i (U.S.), Steptronic, Silver Gray.
kscarrol is offline   United_States
0
Reply With Quote
      12-17-2012, 12:30 PM   #3
WillC310
Lieutenant
 
Drives: A car
Join Date: Apr 2009
Location: Los Angeles

Posts: 422
iTrader: (0)

I have the same problem. I just have a button programmed for split screen to "fix" the problem. Not sure if it's really worth bringing it to the dealership for just that. Seems like a case of crappy SW to me.
WillC310 is offline  
0
Reply With Quote
      12-19-2012, 02:04 AM   #4
eddiek
Enlisted Member
 
Drives: '09 E93 DCT
Join Date: Aug 2009
Location: Portland, Oregon

Posts: 34
iTrader: (0)

I live 5 minutes from the dealer and sometimes when the creaks and rattles get real bad, I'll have them address everything at once. I'm in the last year of my warranty so I want to get things taken care of before I start paying out of pocket.
eddiek is offline  
0
Reply With Quote
      12-19-2012, 07:45 PM   #5
Technic
Lieutenant General
 
Technic's Avatar
 
Drives: 2012 E92 M3, 2014 528i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

Posts: 10,850
iTrader: (16)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by eddiek View Post
I live 5 minutes from the dealer and sometimes when the creaks and rattles get real bad, I'll have them address everything at once. I'm in the last year of my warranty so I want to get things taken care of before I start paying out of pocket.
Is this only happens when the map display is selected on the right side?
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: September 2011 ED
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Technic is offline   United_States
0
Reply With Quote
      12-19-2012, 09:41 PM   #6
kscarrol
Colonel
 
Drives: 2011 E90 M3
Join Date: Jun 2010
Location: New Orleans, LA

Posts: 2,067
iTrader: (0)

No, I display entertainment details on the right and I occasionally get the blank right side...
__________________
Current: 2011 Space Grey E90 M3, DCT, Comp. Pkg., Conv. Pkg., everything but Cold Weather Pkg!
Gone: 2008 550, Space Grey, Sports Package, Sport Auto Transmission.
Sold: 2004 545i (U.S.), Steptronic, Silver Gray.
kscarrol is offline   United_States
0
Reply With Quote
      12-20-2012, 07:21 AM   #7
Technic
Lieutenant General
 
Technic's Avatar
 
Drives: 2012 E92 M3, 2014 528i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

Posts: 10,850
iTrader: (16)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by kscarrol View Post
No, I display entertainment details on the right and I occasionally get the blank right side...
I would guess that the dealer replaced the video cable and/or the screen at the last resort, correct?
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: September 2011 ED
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Technic is offline   United_States
0
Reply With Quote
      12-20-2012, 02:53 PM   #8
kscarrol
Colonel
 
Drives: 2011 E90 M3
Join Date: Jun 2010
Location: New Orleans, LA

Posts: 2,067
iTrader: (0)

My screen only started acting up after a software update a couple of months ago. The blank screen has happened maybe four or five times but I have not brought it to the dealer yet. Due for a service so will mention it then...
__________________
Current: 2011 Space Grey E90 M3, DCT, Comp. Pkg., Conv. Pkg., everything but Cold Weather Pkg!
Gone: 2008 550, Space Grey, Sports Package, Sport Auto Transmission.
Sold: 2004 545i (U.S.), Steptronic, Silver Gray.
kscarrol is offline   United_States
0
Reply With Quote
      12-21-2012, 09:52 AM   #9
eddiek
Enlisted Member
 
Drives: '09 E93 DCT
Join Date: Aug 2009
Location: Portland, Oregon

Posts: 34
iTrader: (0)

They did replace the screen at the first go around and the video cable. They keep on sending the data to BMW. What is so strange is that it is intermittent. Maybe happens 20% of the time.
eddiek is offline  
0
Reply With Quote
      12-31-2012, 01:33 AM   #10
eddiek
Enlisted Member
 
Drives: '09 E93 DCT
Join Date: Aug 2009
Location: Portland, Oregon

Posts: 34
iTrader: (0)

Accidently fixed this. The option for grayscale/traffic were unchecked on the main map but was on the side screen. When I checked this on the main map, it never blanks out anymore.
eddiek is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:02 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST