BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
INDustry distribution
Post Reply
 
Thread Tools Search this Thread
      11-20-2012, 03:54 PM   #1
e90m3_6MT
First Lieutenant
 
Drives: e90 M3 Silverstone, 6MT, 19's
Join Date: Apr 2010
Location: Montréal

Posts: 313
iTrader: (0)

Clutch sticking halfway!

It happened today. I did launch from the lights and I felt the back wheels were at the limit of traction.

When I released the clutch in first gear, it stuck half way, at that time I had me foot to the floor and felt like the car was behaving normaly/accelerating.

when I put the clutch peda back to the floor to shift in second it felt very light and was quick to spring back on the release.

I did not smell anything.

Can you guys diagnose the problem? it's the first time it's happening and the car has 90,000 km.
__________________
e90m3_6MT is offline   Canada
0
Reply With Quote
      11-20-2012, 04:34 PM   #2
Ilia@IND
BimmerPost Supporting Vendor

 
Ilia@IND's Avatar
 
Drives: F10 M5
Join Date: Oct 2006
Location: Chicago

Posts: 2,139
iTrader: (3)

If you are stopped in a parking lot, and push the clutch in and out several times, does the clutch movement or stiffness change? Is it difficult to put the transmission into gear?
__________________
Ilia@IND is offline  
0
Reply With Quote
      11-20-2012, 04:51 PM   #3
m3an
Banned
 
m3an's Avatar
 
Drives: M3
Join Date: Oct 2010
Location: South Florida

Posts: 1,611
iTrader: (2)

Quote:
Originally Posted by e90m3_6MT View Post
It happened today. I did launch from the lights and I felt the back wheels were at the limit of traction.

When I released the clutch in first gear, it stuck half way, at that time I had me foot to the floor and felt like the car was behaving normaly/accelerating.

when I put the clutch peda back to the floor to shift in second it felt very light and was quick to spring back on the release.

I did not smell anything.

Can you guys diagnose the problem? it's the first time it's happening and the car has 90,000 km.


clutch spring and/or assembly failing
m3an is offline  
0
Reply With Quote
      11-22-2012, 02:30 PM   #4
e90m3_6MT
First Lieutenant
 
Drives: e90 M3 Silverstone, 6MT, 19's
Join Date: Apr 2010
Location: Montréal

Posts: 313
iTrader: (0)

Not after the fact everything went back to normal.

Would it means I need to change my clutch soon?
__________________
e90m3_6MT is offline   Canada
0
Reply With Quote
      11-22-2012, 03:00 PM   #5
leigh
Major
 
leigh's Avatar
 
Drives: 2011 e92 zcp m3
Join Date: Aug 2010
Location: melbourne

Posts: 1,037
iTrader: (0)

It would be the fluid getting to hot. Change to castrol SRF racing
leigh is offline  
0
Reply With Quote
      11-22-2012, 03:48 PM   #6
6spdg37s
Captain
 
Drives: none
Join Date: Aug 2012
Location: dirty jerz

Posts: 753
iTrader: (3)

Quote:
Originally Posted by leigh View Post
It would be the fluid getting to hot. Change to castrol SRF racing
+1 z06's were notorious for this.. happend a few times to me
6spdg37s is offline  
0
Reply With Quote
      11-22-2012, 03:48 PM   #7
ole85
Second Lieutenant
 
ole85's Avatar
 
Drives: e92 m3/ Ferrari360
Join Date: Apr 2010
Location: melbourne

Posts: 220
iTrader: (0)

Quote:
Originally Posted by Ilia@IND
If you are stopped in a parking lot, and push the clutch in and out several times, does the clutch movement or stiffness change? Is it difficult to put the transmission into gear?
What dose it mean if its hard to put into gear. I find it hard sometimes to put into reverse
ole85 is offline   Greece
0
Reply With Quote
      11-22-2012, 03:59 PM   #8
Amri215
Banned
 
Amri215's Avatar
 
Drives: 2012 Alpine White M3
Join Date: Nov 2012
Location: New Jersey

Posts: 161
iTrader: (0)

Nothing is failing.

You glazed the clutch ...some normal driving it sould clear right up...stop launching your car..
Amri215 is offline  
0
Reply With Quote
      11-22-2012, 04:56 PM   #9
leigh
Major
 
leigh's Avatar
 
Drives: 2011 e92 zcp m3
Join Date: Aug 2010
Location: melbourne

Posts: 1,037
iTrader: (0)

Quote:
Originally Posted by Amri215 View Post
Nothing is failing.

You glazed the clutch ...some normal driving it sould clear right up...stop launching your car..
No he didn't he needs to change the fluid....how people don't know this is beyond me
leigh is offline  
0
Reply With Quote
      11-22-2012, 04:57 PM   #10
leigh
Major
 
leigh's Avatar
 
Drives: 2011 e92 zcp m3
Join Date: Aug 2010
Location: melbourne

Posts: 1,037
iTrader: (0)

Quote:
Originally Posted by 6spdg37s View Post
+1 z06's were notorious for this.. happend a few times to me
Thank you someone that knows!
leigh is offline  
0
Reply With Quote
      11-22-2012, 07:16 PM   #11
6spdg37s
Captain
 
Drives: none
Join Date: Aug 2012
Location: dirty jerz

Posts: 753
iTrader: (3)

Quote:
Originally Posted by leigh View Post
No he didn't he needs to change the fluid....how people don't know this is beyond me
yeah definitely keep the fluid clean I did this religiously on my z06
6spdg37s is offline  
0
Reply With Quote
      11-22-2012, 09:52 PM   #12
leigh
Major
 
leigh's Avatar
 
Drives: 2011 e92 zcp m3
Join Date: Aug 2010
Location: melbourne

Posts: 1,037
iTrader: (0)

Quote:
Originally Posted by 6spdg37s View Post
yeah definitely keep the fluid clean I did this religiously on my z06
And use better stuff
leigh is offline  
0
Reply With Quote
      11-22-2012, 09:55 PM   #13
6spdg37s
Captain
 
Drives: none
Join Date: Aug 2012
Location: dirty jerz

Posts: 753
iTrader: (3)

Quote:
Originally Posted by leigh View Post
And use better stuff
I used to run bel-ray dot 4 brake fluid. I started doing it cause I had it left over from my street bike but then I liked the way it worked so i continued to use it ... the car specified dot 4.
6spdg37s is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:59 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST