BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
GT Haus
Post Reply
 
Thread Tools Search this Thread
      11-01-2012, 01:49 PM   #1
ocd
Propellar Head
 
Drives: 2010 e90 DCT
Join Date: Aug 2012
Location: NorCal

Posts: 58
iTrader: (6)

Sunroof Tilt/Slide Anti-Trap Function wierdness...read on

2010 e90 DCT

I don't know if this is the correct section to post this...

I was driving home last night with the sunroof in tilt up position, as usual. The entrance into my garage is a left turn up a sharp incline and sometimes the car makes "bendy" creaking noises. As I pulled into the garage, I heard an audible "pop". I thought I struck the passenger mirror on the garage door frame. I pulled in all the way and checked the car...no damage. I get back in to shut the sunroof and see the message "Sunroof Tilt/Slide Anti-Trap Function...Contact BMW Center". I press the sunroof button and nothing works (no tilt or slide). I follow the reset directions I found on the forum, but it does nothing. I attempt to manually crank the sunroof closed because the forecast calls for rain in the morning. I can't remove the dang panel with the dome lights/ buttons...I use a plastic pry tool and eventually give up as to not damage the headliner. I go to sleep and hope for the best.

I'm ready to leave for work this morning, and grab some painters tape to block the rain. Luckily, just clouds for now. I back out of the garage and down the incline...I try the reset proceedure again. BINGO! It works! When I get to work I start playing with the sunroof again. The motor sounds like it's struggling and won't tilt back down from the open position. It starts to close then pops back up into full tilt position. No matter how many times I try, it's the same result. I'm kicking my self at this point wondering why I had to keep playing with the damn thing.

Flash of genius:

I go park on uneven ground, press the close button and it works...struggling sound, but closes. Did my sunroof come off the tracks or get misaligned? It looks perfectly flush with the roof line when closed. I'm fearful to even touch the button at this point. Has anyone had a similar problem? I enjoy the sunroof and like to use it as a vent. Up until now, I have not had one issue with the car. I only had to use the warranty once for one of the rear window shades. The car is now out of warranty (mileage) and I fear taking it to the dealer for this issue.

Any diagnosis or suggestions are appreciated.

Last edited by ocd; 11-01-2012 at 01:54 PM.
ocd is offline  
0
Reply With Quote
      11-01-2012, 07:03 PM   #2
M3PO
Colonel
 
M3PO's Avatar
 
Drives: '08 IB E92
Join Date: Sep 2011
Location: OC

Posts: 2,721
iTrader: (6)

I would guess that the flex of the car must have caused it to jump the track or something. I haven't heard of this happening before so I don't think you'll get much help here. I think that your options are to delve deeper into the issue yourself or take it to the dealer (still under warranty it looks like).
__________________
2008 IB E92 M3| BBS | KW | Arkym | Platte Forme A.G. | Active Autowerke | K&N | Fabspeed | Dinan | Evolve-R
M3PO is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:13 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST