BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Suspension | Brakes | Chassis
 
Steve Thomas BMW
Post Reply
 
Thread Tools Search this Thread
      03-01-2012, 04:21 PM   #1
LucWerkz
Banned
 
Drives: e70 X5 4.8i (Temporarily)
Join Date: Dec 2011
Location: DC/VA/MD/PA

Posts: 1,241
iTrader: (1)

Clicking sounds

So recently I have noticed that my M3 makes a clicking sound when accelerating. It's 2-3 clicks and I only hear it when accelerating from a stop. The car has also makes creaking noises when I go over bumps and potholes or when I brake really hard. The creaking noise happens when the car comes to a complete stop where it kind of pushes you back, not while stopping so it shouldn't be the brakes. Could this be a suspension problem? The car doesn't make any of these sounds when turning. I'm running stock everything and have EDC if that relates to anything and the creaks sound like their coming from the front of the car while the clicks come from the back.
LucWerkz is offline   No_Country
0
Reply With Quote
      10-24-2012, 02:31 PM   #2
Ironbutt17
New Member
 
Drives: 2012 M3
Join Date: Aug 2012
Location: Germany

Posts: 6
iTrader: (0)

Quote:
Originally Posted by lthai View Post
So recently I have noticed that my M3 makes a clicking sound when accelerating. It's 2-3 clicks and I only hear it when accelerating from a stop. The car has also makes creaking noises when I go over bumps and potholes or when I brake really hard. The creaking noise happens when the car comes to a complete stop where it kind of pushes you back, not while stopping so it shouldn't be the brakes. Could this be a suspension problem? The car doesn't make any of these sounds when turning. I'm running stock everything and have EDC if that relates to anything and the creaks sound like their coming from the front of the car while the clicks come from the back.
Mine does this too...ever find out what the cause is? It's driving me nuts.
Ironbutt17 is offline  
0
Reply With Quote
      10-24-2012, 02:53 PM   #3
LucWerkz
Banned
 
Drives: e70 X5 4.8i (Temporarily)
Join Date: Dec 2011
Location: DC/VA/MD/PA

Posts: 1,241
iTrader: (1)

Quote:
Originally Posted by Ironbutt17 View Post
Mine does this too...ever find out what the cause is? It's driving me nuts.
This was a while ago but I believe that it was a rock stuck between the oil pan and headers. The clicking and creaking sounds were from the chassis flexing with the rock stuck. I'll try to find my paperwork when I get home from work.

Hope this helps.
LucWerkz is offline   No_Country
0
Reply With Quote
      10-24-2012, 03:16 PM   #4
Ironbutt17
New Member
 
Drives: 2012 M3
Join Date: Aug 2012
Location: Germany

Posts: 6
iTrader: (0)

Quote:
Originally Posted by lthai View Post
This was a while ago but I believe that it was a rock stuck between the oil pan and headers. The clicking and creaking sounds were from the chassis flexing with the rock stuck. I'll try to find my paperwork when I get home from work.

Hope this helps.
Thanks...I'd like to think my issue is something simple like this. Hardest part is getting under the car to fish it out, I suppose. Almost impossible to isolate it though...other than directly below my feet.
Ironbutt17 is offline  
0
Reply With Quote
      10-24-2012, 03:38 PM   #5
Krozi
Deutsche Jung aus Kölle
 
Krozi's Avatar
 
Drives: 2008 E92 ///M3 Alpine White
Join Date: Oct 2009
Location: SoFla - Bonita Springs

Posts: 2,702
iTrader: (21)

I had a clicking sound when driving away from a stop and when switching from reverse/forward.

I just romped on the car and did a nasty burnout and that seemed to fix it.
__________________

2008 E92 ///M3 Alpine White//Fox Red//6MT//
Florida Bimmer - Join us on FaceBook!
Krozi is offline   Germany
0
Reply With Quote
      10-24-2012, 03:56 PM   #6
LucWerkz
Banned
 
Drives: e70 X5 4.8i (Temporarily)
Join Date: Dec 2011
Location: DC/VA/MD/PA

Posts: 1,241
iTrader: (1)

Quote:
Originally Posted by Krozi View Post
I had a clicking sound when driving away from a stop and when switching from reverse/forward.

I just romped on the car and did a nasty burnout and that seemed to fix it.
Most likely dislodged the rock
LucWerkz is offline   No_Country
0
Reply With Quote
      10-24-2012, 06:56 PM   #7
LucWerkz
Banned
 
Drives: e70 X5 4.8i (Temporarily)
Join Date: Dec 2011
Location: DC/VA/MD/PA

Posts: 1,241
iTrader: (1)

Quote:
Originally Posted by Ironbutt17 View Post
Thanks...I'd like to think my issue is something simple like this. Hardest part is getting under the car to fish it out, I suppose. Almost impossible to isolate it though...other than directly below my feet.
Sorry for the crumpled mess (it was stuffed in my glove compartment) I was wrong, turns out it was between the belly pan and oil pan. I outlined what the tech found. Hope this helps. Hopefully this prevents you from going to multiple shops like I did. I remember having to take it to 3 different shops before it was figured out.
Attached Images
 
LucWerkz is offline   No_Country
0
Reply With Quote
      10-24-2012, 07:35 PM   #8
Denk
Lieutenant Colonel
 
Drives: E92 M3 ZCP
Join Date: May 2011
Location: PNW

Posts: 1,876
iTrader: (2)

Damn rocks!
Denk is offline   United_States
0
Reply With Quote
      10-24-2012, 07:38 PM   #9
MStar
Banned
 
Drives: e92 M3
Join Date: Oct 2012
Location: Here and there

Posts: 290
iTrader: (0)

Had one get stuck in between the rear rotor and the dust shield..so annoying.
MStar is offline   No_Country
0
Reply With Quote
      10-26-2012, 01:48 AM   #10
Jremmy
Medic
 
Jremmy's Avatar
 
Drives: 2013 M3
Join Date: Oct 2012
Location: San Diego, CA

Posts: 216
iTrader: (0)

Quote:
Originally Posted by Yolkster
Had one get stuck in between the rear rotor and the dust shield..so annoying.
This same thing happened to me this week and my car has less than a 1000 miles on it. Started freaking out bc it literally sounds like a bike wheel w a broken spoke! Some rapid acceleration seems to work quite nicely in dislodging any and all rocks though...lol
Jremmy is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:17 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST