BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Suspension | Brakes | Chassis
 
Strasse Wheels
Post Reply
 
Thread Tools Search this Thread
      09-22-2012, 11:12 PM   #1
thorny
Captain
thorny's Avatar
United_States
15
Rep
947
Posts

 
Drives: M3
Join Date: Apr 2011
Location: Houston, TX

iTrader: (9)

KW CS on soft settings noise

Hi, i run KW CS and I am happy with my suspension on and off the track. Although, i have to run softer settings on the street (almost all the way open) My compression is set to 11 and rebound is somewhere at 14-15, i cant remember. Car feels fine, not as good obviously when it is stiffer, but my front suspension makes a tad of a noise going over large bumps. Noise is hard to describe. I also feel like something snaps lightly (i can hear it) when turning very slowly going into say a 90 degree to the main road steep driveway (the grade when you'd otherwise scrape your bumper if you just drive straight in, you guys know what i am talking about).

Is this normal?
Appreciate 0
      09-22-2012, 11:49 PM   #2
wwjd15
Banned
United_States
23
Rep
1,322
Posts

 
Drives: 11 E92 M3 MR
Join Date: May 2009
Location: Orange County

iTrader: (6)

In general speaking:
The slow and wide angle turn noise should be shock bearings.
Most clubsport level (or above) shocks make a little bit of noise when compression or rebound is close to full soft.
KW CS comes with alum. top hats and camber plates, it's normal to have a little bit of noise.

However, it really depends on the situation. I can't say which is your case.
Appreciate 0
      09-23-2012, 03:51 AM   #3
Beedub
Brigadier General
United Kingdom
54
Rep
4,090
Posts

 
Drives: 2007 Z4 M roadster vt2-500
Join Date: Sep 2007
Location: UK

iTrader: (0)

my CS units are silent, but then again i run them at the kw recommended settings.
__________________
Pristine Bi-colour Ti /Bsm...z4m roadster Ess vt2-500....Perfection on wheels.
Appreciate 0
      09-23-2012, 01:16 PM   #4
bigjae1976
That's what she said...
bigjae1976's Avatar
82
Rep
5,622
Posts

 
Drives: 11 E90 M3 Individual
Join Date: Mar 2006
Location: Milwaukee, WI

iTrader: (12)

Garage List
2004 BMW M3  [4.50]
2011 BMW E90 M3  [5.00]
2013 BMW 328i  [5.00]
Sway bar binding up?
__________________


Sponsored by Momentum BMW #593...We Bleed BMW BLUE!
Appreciate 0
      09-24-2012, 09:34 PM   #5
thorny
Captain
thorny's Avatar
United_States
15
Rep
947
Posts

 
Drives: M3
Join Date: Apr 2011
Location: Houston, TX

iTrader: (9)

Quote:
Originally Posted by wwjd15 View Post
In general speaking:
The slow and wide angle turn noise should be shock bearings.
Most clubsport level (or above) shocks make a little bit of noise when compression or rebound is close to full soft.
KW CS comes with alum. top hats and camber plates, it's normal to have a little bit of noise.

However, it really depends on the situation. I can't say which is your case.

Yeah Ricky. I remember you mentioned about that before. I'll see you in Buttonwillow next Sunday!
Appreciate 0
      09-24-2012, 09:36 PM   #6
thorny
Captain
thorny's Avatar
United_States
15
Rep
947
Posts

 
Drives: M3
Join Date: Apr 2011
Location: Houston, TX

iTrader: (9)

Quote:
Originally Posted by Beedub View Post
my CS units are silent, but then again i run them at the kw recommended settings.
I think I've always had that snapping sound when slowly turning into the steep driveway, road.. Even on recommended settings
Appreciate 0
      09-24-2012, 09:39 PM   #7
thorny
Captain
thorny's Avatar
United_States
15
Rep
947
Posts

 
Drives: M3
Join Date: Apr 2011
Location: Houston, TX

iTrader: (9)

Quote:
Originally Posted by bigjae1976 View Post
Sway bar binding up?

It certainly feels that way because the noise happens when sway bar is under the most stress due to twist of the chassis. I think i gotta have someone look at it.
Appreciate 0
      09-25-2012, 02:41 PM   #8
GTM_Challenge
BimmerPost Supporting Vendor
GTM_Challenge's Avatar
United_States
114
Rep
2,831
Posts


 
Drives: E92 M3,X5M,F30 335
Join Date: Jan 2010
Location: Chicago

iTrader: (7)

Send a message via AIM to GTM_Challenge
Check that the swaybars or endlinks aren't making contact with the dampeners. Also, be sure the nuts holding the tophats onto the shaft are tight - ive seen instances where they are loose and there is ample play between the shaft and the tophat. Those are the two things I'd go to first.
Appreciate 0
      09-25-2012, 02:42 PM   #9
Porschefile
Major
Porschefile's Avatar
16
Rep
1,233
Posts

 
Drives: E92 M3
Join Date: Jul 2008
Location: Tennessee

iTrader: (6)

My CS make some noise at low speed, I think it is normal.
Appreciate 0
      09-25-2012, 03:38 PM   #10
Beedub
Brigadier General
United Kingdom
54
Rep
4,090
Posts

 
Drives: 2007 Z4 M roadster vt2-500
Join Date: Sep 2007
Location: UK

iTrader: (0)

Quote:
Originally Posted by Porschefile View Post
My CS make some noise at low speed, I think it is normal.
can you describe the noise?? mine are pretty new and i guess i may get some noise as they wear in.
__________________
Pristine Bi-colour Ti /Bsm...z4m roadster Ess vt2-500....Perfection on wheels.
Appreciate 0
      09-25-2012, 03:56 PM   #11
Porschefile
Major
Porschefile's Avatar
16
Rep
1,233
Posts

 
Drives: E92 M3
Join Date: Jul 2008
Location: Tennessee

iTrader: (6)

Quote:
Originally Posted by Beedub View Post
can you describe the noise?? mine are pretty new and i guess i may get some noise as they wear in.
Mainly just a high frequency chatter. Kind of like something is loose, except that I know that it is not. I don't hear it at highway speeds or anything, just low speed stuff. I think it is a product of the spherical camber plate primarily.
Appreciate 0
      09-25-2012, 06:02 PM   #12
Jaypod
Brigadier General
Jaypod's Avatar
No_Country
64
Rep
4,961
Posts

 
Drives: Frozen M3, AM V8V, 991 GT3
Join Date: Nov 2008
Location: Toronto

iTrader: (7)

What endlinks are you running? On my old car on the soft setting of my Motons my endlinks were really noisy. I swapped them out for the turner ones and the noise went away instantly
Appreciate 0
      09-25-2012, 06:05 PM   #13
rzm3
Moderator
rzm3's Avatar
224
Rep
4,603
Posts

 
Drives: E92 M3
Join Date: Aug 2007
Location: USA

iTrader: (14)

I'd say give KW tech support a call and perhaps they can help you.

1-800-445-3767
__________________
E92 M3 DCT - AiM EVO4 Data Logger / AiM SmartyCam HD / KW Competition 2-Way / OMP ARS Racing Seats / Brembo GT 365 / Pagid Yellow RS-29 / Rear Seats Delete
Appreciate 0
      09-26-2012, 11:18 PM   #14
thorny
Captain
thorny's Avatar
United_States
15
Rep
947
Posts

 
Drives: M3
Join Date: Apr 2011
Location: Houston, TX

iTrader: (9)

Thanks for all the advice guys, I'll look into it more and report back.


Update. Noise happens only on soft settings, no noise on recommended settings

Last edited by thorny; 10-04-2012 at 08:23 PM.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:50 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST