BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
Post Reply
 
Thread Tools Search this Thread
      09-17-2012, 03:02 PM   #1
af908
Enlisted Member
 
Drives: 2008 M3
Join Date: Mar 2012
Location: Connecticut

Posts: 39
iTrader: (0)

Code P2629 - Oxygen Sensory Pumping Current

P2629
Oxygen Sensor
Pumping Current
Trim Circuit/Open
Bank 2 Sensor 1


Before i go and buy a new 02 sensor, there is a couple things to note:

I went the cheap route and bought the topspeed xpipe off ebay. Well, turns out i may be paying for it now. When installing the x-pipe, the passenger side exhaust tube, primary sensor o2 bung (am i correct in assuming this is "bank 2 sensor 1"??) had a poor welding job and a giant chunck of metal welded inside one side of the 02 bung. As a result, the 02 sensor would not fit in. I sat there for hours filing it down, untill it fit. It ended up fitting but it was pretty tight. Now, almost 3 months later, this code pops up, on the first cold day since i installed the x-pipe.

My question is: do i need to remove the x-pipe and file down the metal even further? My guess is that perhaps the 02 sensor is not getting a complete reading, since maybe 20% of one side is essentially "resting" on the "chunk of metal" that i filed down inside that o2 sensor bung. Am i correct in saying the readings from the 02 sensor come from the sides of the probe and not the very top portion?

I also installed the BMS DP Fix, however, I emailed terry and he said that this code can not be related to the DP fix.

Help!
af908 is offline  
0
Reply With Quote
      09-17-2012, 03:11 PM   #2
af908
Enlisted Member
 
Drives: 2008 M3
Join Date: Mar 2012
Location: Connecticut

Posts: 39
iTrader: (0)

Wait a minute, I may have my banks confused here....

Isn't bank #2 passenger side of the exhaust?

af908 is offline  
0
Reply With Quote
      09-17-2012, 03:26 PM   #3
IMG
VT3
 
IMG's Avatar
 
Drives: E36 M3 Track car,Ess E90 M3 DD
Join Date: Feb 2008
Location: The Couch

Posts: 6,858
iTrader: (5)

Bank 1 is the passenger side.
__________________
NO FEAR.NO LIMITS.NO EQUAL

Ess VT3 LC built motor,Volk TE37SL,Euro taillights,Dinan Xpipe,Custom Headers,Akra axle back CF tips,ModeCarbon FR lip,BMW CF wing
LOW BOOST 60-130 6.7 sec
IMG is offline  
0
Reply With Quote
      09-17-2012, 03:41 PM   #4
af908
Enlisted Member
 
Drives: 2008 M3
Join Date: Mar 2012
Location: Connecticut

Posts: 39
iTrader: (0)

Quote:
Originally Posted by img View Post
Bank 1 is the passenger side.
Thanks,

Well there goes my theory about the x-pipe. Looks like i will be buying a new o2 sensor then?

My car only has 35k on it, seems strange to go bad this early. Car runs fine too.
af908 is offline  
0
Reply With Quote
      09-17-2012, 05:07 PM   #5
M3PO
Colonel
 
M3PO's Avatar
 
Drives: '08 IB E92
Join Date: Sep 2011
Location: OC

Posts: 2,635
iTrader: (6)

Quote:
Originally Posted by af908 View Post
Thanks,

Well there goes my theory about the x-pipe. Looks like i will be buying a new o2 sensor then?

My car only has 35k on it, seems strange to go bad this early. Car runs fine too.
The location of the O2 sensors has not changed correct? The reason that I ask is that vendor was experimenting with moving the O2 sensors to a different location and had issues with fouling the sensors.
__________________
2008 IB E92 M3| BBS | KW | Arkym | Platte Forme A.G. | Active Autowerke | K&N | Fabspeed | Dinan | Evolve-R
M3PO is offline  
0
Reply With Quote
      09-17-2012, 07:30 PM   #6
Mike Benvo
BimmerPost Supporting Vendor

 
Mike Benvo's Avatar
 
Drives: 08 E90 M3 / 400whp Turbo 7
Join Date: Apr 2008
Location: SoCal

Posts: 4,289
iTrader: (6)

Garage List
1990 BMW 735i Turbo  [5.00]
2004 BMW M3  [0.00]
2008 BMW M3  [5.00]
Send a message via Skype™ to Mike Benvo
Fault: Bank 2 pre-catalyst oxygen sensor pumping current calibration error

Techy stuff:
* Engine temperature > K_LAVK_OBD_TMOT * Sensor temperature > K_LAVK_OBD_VK_TEMP * since recognition of overrun an air mass flow of K_LAVK_OBD_SA_ML_SUM must have occurred

Terminal condition: Engine running - status overrun cutoff

In English for you:
This fault happens when Oxygen sensor is available and communicating BUT sensor voltage > K_LAVK_OBD_SA_DIAG_OL (meaning the value reported by the sensor is higher than a preset limit imposed by the DME, therefore the signal is not within specified/acceptable ranges.)

What you should do:
1. Check plug and wiring harness to pre-catalyst oxygen sensor forward of Bank 2 catalyst (especially IA trim wire)
2. If OK, replace oxygen sensor and you should be good to go
__________________

-----| Like us on Facebook | Instagram || Tuning Information | Remote Coding |-----
----Visit us at www.BPMSport.com - Emotion. Driven. | Toll Free: (888) 557-5133----
Mike Benvo is offline   United_States
0
Reply With Quote
      09-17-2012, 07:39 PM   #7
af908
Enlisted Member
 
Drives: 2008 M3
Join Date: Mar 2012
Location: Connecticut

Posts: 39
iTrader: (0)

Quote:
Originally Posted by M3PO View Post
The location of the O2 sensors has not changed correct? The reason that I ask is that vendor was experimenting with moving the O2 sensors to a different location and had issues with fouling the sensors.
Unfortunately when I put the xpipe on I didn't really take this into consideration, but from what I remember, the locations looked similar. Would I have noticed this change?
af908 is offline  
0
Reply With Quote
      09-17-2012, 07:43 PM   #8
af908
Enlisted Member
 
Drives: 2008 M3
Join Date: Mar 2012
Location: Connecticut

Posts: 39
iTrader: (0)

Quote:
Originally Posted by Mike Benvo View Post
Fault: Bank 2 pre-catalyst oxygen sensor pumping current calibration error

Techy stuff:
* Engine temperature > K_LAVK_OBD_TMOT * Sensor temperature > K_LAVK_OBD_VK_TEMP * since recognition of overrun an air mass flow of K_LAVK_OBD_SA_ML_SUM must have occurred

Terminal condition: Engine running - status overrun cutoff

In English for you:
This fault happens when Oxygen sensor is available and communicating BUT sensor voltage > K_LAVK_OBD_SA_DIAG_OL (meaning the value reported by the sensor is higher than a preset limit imposed by the DME, therefore the signal is not within specified/acceptable ranges.)

What you should do:
1. Check plug and wiring harness to pre-catalyst oxygen sensor forward of Bank 2 catalyst (especially IA trim wire)
2. If OK, replace oxygen sensor and you should be good to go

Thanks mike,

What should I be looking for specifically? A frayed wire? Or is it something not so obvious? I say this because I would assume a frayed wire would warrant an o2 replacement anyways, no?

It seems strange that my o2 sensor went already, the car only has 36k miles on it

Last edited by af908; 09-17-2012 at 08:12 PM.
af908 is offline  
0
Reply With Quote
      09-17-2012, 08:23 PM   #9
Mike Benvo
BimmerPost Supporting Vendor

 
Mike Benvo's Avatar
 
Drives: 08 E90 M3 / 400whp Turbo 7
Join Date: Apr 2008
Location: SoCal

Posts: 4,289
iTrader: (6)

Garage List
1990 BMW 735i Turbo  [5.00]
2004 BMW M3  [0.00]
2008 BMW M3  [5.00]
Send a message via Skype™ to Mike Benvo
Quote:
Originally Posted by af908 View Post
Thanks mike,

What should I be looking for specifically? A frayed wire? Or is it something not so obvious? I say this because I would assume a frayed wire would warrant an o2 replacement anyways, no?

It seems strange that my o2 sensor went already, the car only has 36k miles on it
I've seen a few of them go. Usually it's the heater element/wire though.

It depends where the frayed wire is. It could be on the loom connected to the o2 sensor, or it might have somehow frayed above where it connects to the wires running back to the DME.

In my case I had a check engine light about 6 months ago due to an o2 sensor fault. It wound up being some debris the ground that happened to fray the wire underneath the car. After replacing it I've had 0 issues.

Usually these o2 sensor related errors are the sensor themselves. It's rarely the wiring unless there are extenuating circumstances.
__________________

-----| Like us on Facebook | Instagram || Tuning Information | Remote Coding |-----
----Visit us at www.BPMSport.com - Emotion. Driven. | Toll Free: (888) 557-5133----
Mike Benvo is offline   United_States
0
Reply With Quote
      09-18-2012, 03:34 PM   #10
M3PO
Colonel
 
M3PO's Avatar
 
Drives: '08 IB E92
Join Date: Sep 2011
Location: OC

Posts: 2,635
iTrader: (6)

Quote:
Originally Posted by af908 View Post
Would I have noticed this change?
Yes.
__________________
2008 IB E92 M3| BBS | KW | Arkym | Platte Forme A.G. | Active Autowerke | K&N | Fabspeed | Dinan | Evolve-R
M3PO is offline  
0
Reply With Quote
      09-19-2012, 10:38 AM   #11
Dave07997S
Colonel
 
Drives: 2011 BMW M3 ZCP Coupe
Join Date: May 2009
Location: Playa del Rey, CA

Posts: 2,285
iTrader: (1)

As Mikey knows...I've already replaced two of them....and my car only has 22k miles on the clock.

Dave
__________________
2013 M3 Coupe-MR/BLK ZCP, ACM test pipes, BPM Stg2 dev. tune and Megan catback, more to come
Previous rides: 2011 M3 Coupe-MR/Blk
2007 Porsche 997C2S Speed Yellow/Blk sport seats
2004 BMW M3 Imola/Blk
Dave07997S is offline  
0
Reply With Quote
      09-19-2012, 10:52 AM   #12
Mike Benvo
BimmerPost Supporting Vendor

 
Mike Benvo's Avatar
 
Drives: 08 E90 M3 / 400whp Turbo 7
Join Date: Apr 2008
Location: SoCal

Posts: 4,289
iTrader: (6)

Garage List
1990 BMW 735i Turbo  [5.00]
2004 BMW M3  [0.00]
2008 BMW M3  [5.00]
Send a message via Skype™ to Mike Benvo
Quote:
Originally Posted by Dave07997S View Post
As Mikey knows...I've already replaced two of them....and my car only has 22k miles on the clock.

Dave
I read my car this morning and the damn thing has a fault for Oxygen sensor precat diagnosis, coasting...

Looks like the life of the o2's goes downhill after 40K.

I'm going to drive it more and see if any more codes come up, and then off to the stealer she goes... Good seeing you the other day buddy.
__________________

-----| Like us on Facebook | Instagram || Tuning Information | Remote Coding |-----
----Visit us at www.BPMSport.com - Emotion. Driven. | Toll Free: (888) 557-5133----
Mike Benvo is offline   United_States
0
Reply With Quote
      09-19-2012, 02:43 PM   #13
M3PO
Colonel
 
M3PO's Avatar
 
Drives: '08 IB E92
Join Date: Sep 2011
Location: OC

Posts: 2,635
iTrader: (6)

Quote:
Originally Posted by Mike Benvo View Post
I read my car this morning and the damn thing has a fault for Oxygen sensor precat diagnosis, coasting...

Looks like the life of the o2's goes downhill after 40K.

I'm going to drive it more and see if any more codes come up, and then off to the stealer she goes... Good seeing you the other day buddy.
No idiot light on the dash or message in iDrive? Is it possible that some of us have this issue and don't know it? I have 53k miles...
__________________
2008 IB E92 M3| BBS | KW | Arkym | Platte Forme A.G. | Active Autowerke | K&N | Fabspeed | Dinan | Evolve-R
M3PO is offline  
0
Reply With Quote
      09-19-2012, 03:10 PM   #14
Mike Benvo
BimmerPost Supporting Vendor

 
Mike Benvo's Avatar
 
Drives: 08 E90 M3 / 400whp Turbo 7
Join Date: Apr 2008
Location: SoCal

Posts: 4,289
iTrader: (6)

Garage List
1990 BMW 735i Turbo  [5.00]
2004 BMW M3  [0.00]
2008 BMW M3  [5.00]
Send a message via Skype™ to Mike Benvo
Quote:
Originally Posted by M3PO View Post
No idiot light on the dash or message in iDrive? Is it possible that some of us have this issue and don't know it? I have 53k miles...
Yes, quite possible.

Many cars come in with faults and have no SES light.

The SES light will only illuminate if something continues to reoccur, or if it's something more serious. There are also many faults that may not trigger the light.

As an example, when my idle control valve was bad, the car misfired in all eight cylinders and had 9 fault codes stored (one for each cylinder + a multiple misfire code). No warnings, and this is with the latest stock software. You should be able to read any existing fault codes with your tuning cable
__________________

-----| Like us on Facebook | Instagram || Tuning Information | Remote Coding |-----
----Visit us at www.BPMSport.com - Emotion. Driven. | Toll Free: (888) 557-5133----
Mike Benvo is offline   United_States
0
Reply With Quote
      09-19-2012, 05:17 PM   #15
Dave07997S
Colonel
 
Drives: 2011 BMW M3 ZCP Coupe
Join Date: May 2009
Location: Playa del Rey, CA

Posts: 2,285
iTrader: (1)

Quote:
Originally Posted by Mike Benvo View Post
I read my car this morning and the damn thing has a fault for Oxygen sensor precat diagnosis, coasting...

Looks like the life of the o2's goes downhill after 40K.

I'm going to drive it more and see if any more codes come up, and then off to the stealer she goes... Good seeing you the other day buddy.
Good seeing you as well...
__________________
2013 M3 Coupe-MR/BLK ZCP, ACM test pipes, BPM Stg2 dev. tune and Megan catback, more to come
Previous rides: 2011 M3 Coupe-MR/Blk
2007 Porsche 997C2S Speed Yellow/Blk sport seats
2004 BMW M3 Imola/Blk
Dave07997S is offline  
0
Reply With Quote
      09-20-2012, 01:39 PM   #16
M3PO
Colonel
 
M3PO's Avatar
 
Drives: '08 IB E92
Join Date: Sep 2011
Location: OC

Posts: 2,635
iTrader: (6)

Quote:
Originally Posted by Mike Benvo View Post
Yes, quite possible.

Many cars come in with faults and have no SES light.

The SES light will only illuminate if something continues to reoccur, or if it's something more serious. There are also many faults that may not trigger the light.

As an example, when my idle control valve was bad, the car misfired in all eight cylinders and had 9 fault codes stored (one for each cylinder + a multiple misfire code). No warnings, and this is with the latest stock software. You should be able to read any existing fault codes with your tuning cable
I see, thanks. Too bad I don't have a PC. I don't have the software either. I thought I heard someone say that the software is on the cable?!?!
__________________
2008 IB E92 M3| BBS | KW | Arkym | Platte Forme A.G. | Active Autowerke | K&N | Fabspeed | Dinan | Evolve-R
M3PO is offline  
0
Reply With Quote
      09-20-2012, 02:05 PM   #17
THE TECH
BimmerPost Supporting Vendor

 
THE TECH's Avatar
 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

Posts: 12,567
iTrader: (39)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Quote:
Originally Posted by M3PO View Post
I see, thanks. Too bad I don't have a PC. I don't have the software either. I thought I heard someone say that the software is on the cable?!?!
You would need to have Evolve send you the program if you don't have it.

I can also check with the BT tool. I got rid of the Autologic. Worst customer service ever.
__________________
THE TECH is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:04 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST