BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > Regional Forums > USA - Southwest
 
Steve Thomas BMW
Post Reply
 
Thread Tools Search this Thread
      09-15-2012, 02:38 PM   #1
bigjae1976
Takes threads off topic...daily
 
bigjae1976's Avatar
 
Drives: 11 E90 M3 Individual
Join Date: Mar 2006
Location: Milwaukee, WI

Posts: 5,256
iTrader: (12)

Garage List
2004 BMW M3  [4.50]
2011 BMW E90 M3  [5.00]
2013 BMW 328i  [5.00]
TWS - broke 2 minutes!

I know, its non-E9X M3 material but I finally broke 2 minutes at Texas World Speedway in my 330! It all finally came together. As an added bonus, I got to drive MY car home! Between the alternator pulley, tensioner pulley, busted oil coolers, bad crank sensor, bad MAF, running hot, and software issues...I think we're good now. Quite the adventure from fireball to now! Thanks to Mayco Performance in Houston, TX. Despite numerous OEM parts issues they stuck by their work and warrantied everything without question. They drove an hour to pickup my car on July 4th when the alternator died. The owner let me drive his car on the track when my alternator pulley nut went missing. They busted their asses at the track to fix my car when there was an issue. Even this last episode with the alternator pulley nut coming off. That could be blamed on a spin at HMSR where I stalled the car...they replaced the alternator with no questions asked.

I will admit there have been times of serious doubt and frustration but I think (and hope) all is good.

A big thanks to Dan for letting me drive his car home when mine died twice!

So here's the video...

__________________


Sponsored by Momentum BMW #593...We Bleed BMW BLUE!
bigjae1976 is offline  
0
Reply With Quote
      09-15-2012, 05:45 PM   #2
ThunderMoose
Captain
 
Drives: 2009 C2S and 2003 E46 M3
Join Date: Aug 2010
Location: League City, TX

Posts: 958
iTrader: (0)

Quote:
Originally Posted by bigjae1976
I know, its non-E9X M3 material but I finally broke 2 minutes at Texas World Speedway in my 330! It all finally came together. As an added bonus, I got to drive MY car home! Between the alternator pulley, tensioner pulley, busted oil coolers, bad crank sensor, bad MAF, running hot, and software issues...I think we're good now. Quite the adventure from fireball to now! Thanks to Mayco Performance in Houston, TX. Despite numerous OEM parts issues they stuck by their work and warrantied everything without question. They drove an hour to pickup my car on July 4th when the alternator died. The owner let me drive his car on the track when my alternator pulley nut went missing. They busted their asses at the track to fix my car when there was an issue. Even this last episode with the alternator pulley nut coming off. That could be blamed on a spin at HMSR where I stalled the car...they replaced the alternator with no questions asked.

I will admit there have been times of serious doubt and frustration but I think (and hope) all is good.

A big thanks to Dan for letting me drive his car home when mine died twice!

So here's the video...

Good job!
ThunderMoose is offline  
0
Reply With Quote
      09-16-2012, 08:26 PM   #3
bigjae1976
Takes threads off topic...daily
 
bigjae1976's Avatar
 
Drives: 11 E90 M3 Individual
Join Date: Mar 2006
Location: Milwaukee, WI

Posts: 5,256
iTrader: (12)

Garage List
2004 BMW M3  [4.50]
2011 BMW E90 M3  [5.00]
2013 BMW 328i  [5.00]
Thanks! BTW, I hope you liked your Driver's Edge weekend!

I know there's another easy second if I would stop being scared and go full throttle from T9 to T7. I'm still scarred from my off last PDS. Definitely need to be more consistent through T4 and earlier on full throttle through T2-T1. Might be good for another 1/2 second...maybe break 1:58 in a couple of weeks?

I did my post tech today. My front left tire took a pounding. It is the only tire where the tread is kind of like a wave (called feathered?) and uneven. The sidewall took a beating, the little arrows are half worn off. Most other tracks, my after cold pressures are about 1psi off from side to side. I was running 38psi hot and my differential was 2psi (L/F - 26, L/R - 25, R/F - 28, R/R - 27). I wonder why I also have a PSI differential of 1 psi from front to rear as well.

And my front bumper zip tie is still holding strong and all parts are accounted for! I'm usually down a foglight trim ring after TWS...finally learned and super glued it on.
__________________


Sponsored by Momentum BMW #593...We Bleed BMW BLUE!

Last edited by bigjae1976; 09-16-2012 at 08:32 PM.
bigjae1976 is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:31 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST