BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
Evolve Automotive
Post Reply
 
Thread Tools Search this Thread
      08-30-2012, 09:10 PM   #1
kwike92
Lieutenant Colonel
United_States
28

 
kwike92's Avatar
 
Drives: 2009 m3 coupe | 2011 STi
Join Date: Feb 2010
Location: Mission Viejo, Ca


Posts: 1,570
iTrader: (6)

erratic idle

my 09 has 23xxx on the clock and about a week ago when i fired it up in the am the idle flipped out bounced from 500 to 1500 to 600 to 2k then back down to 800.. last night i was driving it to the store and at a stop light, the idle went down to like 400 and almost wanted to die... then i gave it a little gas to bring it back alive.

And just now, i was driving home from work and it did it again! No check engine lights no nothing... just feels like it lacks a little power..

i made a service appt for tuesday...


any thoughts? ive heard the idle air control sensors go out on these cars?
i had another 09 that i drove from new to 81k with no problems ever...
__________________
2009 E92 M3- basic mods, future track car.
2011 Subaru STi daily driver- Stock, for now...
Appreciate 0
      08-30-2012, 11:31 PM   #2
m3an
Banned
19

 
m3an's Avatar
 
Drives: M3
Join Date: Oct 2010
Location: South Florida


Posts: 1,611
iTrader: (2)

would guess maybe the IAC is on its way out. Although when cold and just started I seem to see a little idle hunting is normal
Appreciate 0
      08-31-2012, 07:58 AM   #3
IMG
M.POWER
103

 
IMG's Avatar
 
Drives: E36 M3 Track car,Ess E90 M3 DD
Join Date: Feb 2008
Location: Location


Posts: 7,060
iTrader: (6)

ICV I'm thinking,very common issue based on the symptoms you mentioned. Good Luck !
__________________
NO FEAR.NO LIMITS.NO EQUAL

Ess VT3 LC built motor,Volk TE37SL,Euro taillights,Dinan Xpipe,Custom Headers,Akra axle back CF tips,ModeCarbon FR lip,BMW CF wing
LOW BOOST 60-130 6.7 sec
Appreciate 0
      08-31-2012, 08:07 AM   #4
THE TECH
BimmerPost Supporting Vendor
United_States
156


 
THE TECH's Avatar
 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas


Posts: 13,116
iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Quote:
Originally Posted by m3an View Post
would guess maybe the IAC is on its way out. Although when cold and just started I seem to see a little idle hunting is normal
Quote:
Originally Posted by img View Post
ICV I'm thinking,very common issue based on the symptoms you mentioned. Good Luck !
+1
__________________
Appreciate 0
      08-31-2012, 06:36 PM   #5
kwike92
Lieutenant Colonel
United_States
28

 
kwike92's Avatar
 
Drives: 2009 m3 coupe | 2011 STi
Join Date: Feb 2010
Location: Mission Viejo, Ca


Posts: 1,570
iTrader: (6)

Thanks gentlemen for the responses.
__________________
2009 E92 M3- basic mods, future track car.
2011 Subaru STi daily driver- Stock, for now...
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:59 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST