BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
Evolve Automotive
Post Reply
 
Thread Tools Search this Thread
      07-16-2012, 03:07 AM   #1
y2_dyc
New Member
 
Drives: Soon to be S. Graphite E92 M3
Join Date: Mar 2010
Location: UK

Posts: 28
iTrader: (0)

Oil usage

Hey guys,

My car recently showed the +1 litre for my oil, so filled up 250ml...this message continued to show, and I topped up another 250ml.

The idrive showed the oil level was 'ok' but a week after topping up it's showing oil level low again!!! Should I just keep filling the oil up? Has anyone else experienced this problem?

Thanks
y2_dyc is offline  
0
Reply With Quote
      07-16-2012, 04:17 AM   #2
DJDeez
Got my license back!
 
DJDeez's Avatar
 
Drives: TransLink
Join Date: Jul 2011
Location: Surrey, BC

Posts: 200
iTrader: (1)

Quote:
Originally Posted by y2_dyc View Post
Should I just keep filling the oil up? Has anyone else experienced this problem?
According to the manual, "Add at least 0.5 US quart/0.5 liters, otherwise the oil-level monitor will be unable to display the new value reliably." I think most members have experienced this problem, our engines love burning oil!
__________________
aFe cold air intake system (stage 2) ▫ Agency Power cat delete/section 2 midpipes ▫ Agency Power exhaust system ▫ Beltronics STiR Plus ▫ BMW M style (ZHP) weighted short shift knob ▫ CIC iDrive ▫ Clutch pedal spring removal ▫ Coding ▫ Evolve-R tune ▫ Laser Interceptor ▫ LUX H8 V3 Angel Eyes ▫ pickyeater334 clutch stop ▫ Rear fog lights (2011 light control switch assembly) ▫ T3 Alpha laser gun protection ▫ Turner Motorsport power pulley kit
DJDeez is offline   Canada
0
Reply With Quote
      07-16-2012, 06:38 AM   #3
edwinm3
Lieutenant Colonel
 
edwinm3's Avatar
 
Drives: E92 MELBOURNE RED M3
Join Date: Nov 2011
Location: Doral

Posts: 1,729
iTrader: (8)

Burning oil is completely normal
__________________

Evolve Stage 2, GTS-DCT Software, Akrapovic Exhaust, AA Catless X Pipe, AA Geen Air filter, AA Pulley, Stoptech BBK, KW V3 Coilovers
"If it feels like it's on rails, you're not driving fast enough"
edwinm3 is offline   United_States
0
Reply With Quote
      07-16-2012, 10:08 AM   #4
C|3R1C
So Kewl Guy
 
C|3R1C's Avatar
 
Drives: 2010 E93 M3 DCT
Join Date: Sep 2011
Location: Los Angeles

Posts: 501
iTrader: (0)

Burning oil + unreliable measuring device is normal. If it says +1 go ahead and add 750ml. But it seems you lost 250ml in a week if I'm reading that right. Maybe see if there is a small leak, unless your driving a lot and hitting high revs often, then that's normal. Happy driving!
__________________
2010 E93 M3 / AA Catless X-Pipe / AA Catback / AA Pulley / Vorsteiner Vented Hood and Bootlid E93 Trunk / ADV1 7.1 Wheels GB / LS3 LED Lights / AFE Stage 2 / Velos Designwerks Tune
C|3R1C is offline  
0
Reply With Quote
      07-16-2012, 04:20 PM   #5
M3PO
Colonel
 
M3PO's Avatar
 
Drives: '08 IB E92
Join Date: Sep 2011
Location: OC

Posts: 2,721
iTrader: (6)

You're doing it right. Only add 250 mL at a time or you risk over filling it due to the inaccuracy of the gauge. I find that it needs different amounts to be happy each time it comes on (250, 500, or 750 mL) so adding 750 mL right out of the gate may be too much.

You didn't lose 250 mL in a week. The gauge is not exact, it's measurement has has some uncertainty so the 500 mL you added was probably borderline enough and the gauge measured it as 'OK' one time and low another time.
__________________
2008 IB E92 M3| BBS | KW | Arkym | Platte Forme A.G. | Active Autowerke | K&N | Fabspeed | Dinan | Evolve-R
M3PO is offline  
0
Reply With Quote
      07-16-2012, 04:29 PM   #6
THE TECH
BimmerPost Supporting Vendor

 
THE TECH's Avatar
 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

Posts: 13,065
iTrader: (44)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Quote:
Originally Posted by M3PO View Post
You're doing it right. Only add 250 mL at a time or you risk over filling it due to the inaccuracy of the gauge. I find that it needs different amounts to be happy each time it comes on (250, 500, or 750 mL) so adding 750 mL right out of the gate may be too much.

You didn't lose 250 mL in a week. The gauge is not exact, it's measurement has has some uncertainty so the 500 mL you added was probably borderline enough and the gauge measured it as 'OK' one time and low another time.
+1
__________________
THE TECH is offline   United_States
0
Reply With Quote
      07-16-2012, 06:20 PM   #7
Daft
Captain
 
Daft's Avatar
 
Drives: 2011 ZCP E92 M3 & 2003 E46 M3
Join Date: Jan 2009
Location: Ontario, Canada

Posts: 878
iTrader: (1)

Garage List
2011 BMW M3  [4.85]
2003 BMW M3  [5.00]
I'm having a similar problem, was about to make a new thread but I'll post here.
Recently the dash told me it was low on oil and to add +1L. So I put 0.5L just to be safe. After a day of driving it still says to add +1L. So I put the other 0.5L in. Then it wouldn't read the oil level at all, kept showing the spinning clock after 2 days of driving. Now today it finally read the oil level and is showing right at the top level of the OK marker. How the hell can it go from the very bottom to the top level with only 0.5L added?? I miss the old oil dip stick...
__________________

2011 M3 ZCP | ESS SUPERCHARGED | AKRAPOVIC EVOLUTION | 20" HRE P40 | BREMBO BBK | B&G SPRINGS
Daft is offline   Canada
0
Reply With Quote
      07-16-2012, 11:02 PM   #8
Mike Benvo
BimmerPost Supporting Vendor

 
Mike Benvo's Avatar
 
Drives: 08 E90 M3 / 400whp Turbo 7
Join Date: Apr 2008
Location: SoCal

Posts: 4,595
iTrader: (7)

Garage List
1990 BMW 735i Turbo  [5.00]
2004 BMW M3  [0.00]
2008 BMW M3  [5.00]
Send a message via Skype™ to Mike Benvo
Usually it asks me to add about 1 quart after 7,000 miles or so, around where I normally change the oil (at 1/2 the suggested interval).

I would try resetting the measurement and have it recalculate.

On my E60 550, It said low oil for 2 days, and then went away on its own. I still added a quart and now it reports ok. Yesterday in the M3 it said oil at minimum level and "+1qt". I added a quart and it also says OK.

I wish we had a dipstick!
Mike Benvo is offline   United_States
0
Reply With Quote
      07-17-2012, 03:15 PM   #9
CCLSVTM3
Lieutenant
 
Drives: Interlagos blue E90 M3
Join Date: Jul 2011
Location: Burbank, CA

Posts: 528
iTrader: (1)

Normal to burn oil.... I always keep at least one qt in my trunk...
__________________
BMC filter, OEM Exh Mod, ESS Direct Flash tune, flat black kidney grills, color painted front reflectors, LUX Angel eyes, -2012 SVT Raptor 4 dr -09 E90 M3

CCLSVTM3 is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:41 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST