BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
Racewerkz Engineering
Post Reply
 
Thread Tools Search this Thread
      06-28-2012, 02:05 AM   #1
Bel-Tirid
Private First Class
 
Drives: M3 e92 Interlagos blue
Join Date: Dec 2010
Location: Slovenia

Posts: 113
iTrader: (0)

Engine fault

Hi, i changed H&R springs and front grills (black) yesterday. This morning when i start the car there was a check engine and engine fault. The car has similar noise to the subaru. I am so sad because the car looks so good and i cant drive it.

Plz help guys , the car is m3 e92 2007 70k kilometers.

When start up the car has a normal noise 1 sec, but after 1 sec, the car is starting to shake and gives a strange noise (subaru)


Thank you
Bel-Tirid is offline  
0
Reply With Quote
      06-28-2012, 02:43 PM   #2
C|3R1C
So Kewl Guy
 
C|3R1C's Avatar
 
Drives: 2010 E93 M3 DCT
Join Date: Sep 2011
Location: Los Angeles

Posts: 512
iTrader: (0)

If you could get a scanner and post some codes that would help. Other than that it could literally be anything.
__________________
2010 E93 M3 / AA Catless X-Pipe / AA Catback / AA Pulley / Vorsteiner Vented Hood and Bootlid E93 Trunk / ADV1 7.1 Wheels GB / LS3 LED Lights / AFE Stage 2 / Velos Designwerks Tune
C|3R1C is offline  
0
Reply With Quote
      06-28-2012, 02:46 PM   #3
THE TECH
BimmerPost Supporting Vendor

 
THE TECH's Avatar
 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

Posts: 13,104
iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Quote:
Originally Posted by C|3R1C View Post
If you could get a scanner and post some codes that would help. Other than that it could literally be anything.
+1

Need the codes to figure anything out.

Spring install wouldn't normally cause an engine issue but it's all hypothetical until we have the vehicle information.
__________________
THE TECH is offline   United_States
0
Reply With Quote
      06-28-2012, 04:37 PM   #4
VCP
Captain
 
VCP's Avatar
 
Drives: F82 Sakhir / E92 Dakar
Join Date: Mar 2011
Location: Canada

Posts: 602
iTrader: (0)

sounds like its misfiring... might just be bad luck that a plug or coil pack gave up after putting springs in. but ya get the fault codes and see whats up
VCP is offline   Canada
0
Reply With Quote
      06-28-2012, 04:53 PM   #5
m3an
Banned
 
m3an's Avatar
 
Drives: M3
Join Date: Oct 2010
Location: South Florida

Posts: 1,611
iTrader: (2)

coilpack sounds like it if it's missing and sounds like a boxer... LOL at springs or grills causing it. just coincidence
m3an is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:24 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST