BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Suspension | Brakes | Chassis
 
European Auto Source
Post Reply
 
Thread Tools Search this Thread
      06-15-2012, 12:07 AM   #1
MysticBlue
Major
14

 
Drives: '09 M3 DCT Coupe, ---'15 x50i
Join Date: Apr 2008
Location: Eastern Oregon... They call 'em rigs here


Posts: 1,296
iTrader: (0)

Sticky brakes

i've got the Dinan bbk (Brembo). Anytime the car is parked overnight after getting wet, the pads are stuck to the rotors. Upon first attempt at moving, the car feels like the e-brake is on and I have to give it quite a bit of gas to break it free. It's not the e-brake, I don't use it in my garage. It definitely feels like the pads are stuck to the rotors and it makes some noise when it breaks free, then no problems. Anybody else experience this, and is there anything that can be done about it?
__________________
M3: Active Autowerke filter, Dinan underdrive pulley, Dinan full exhaust and software, 3.45 Differential, Springs, Brakes, Dinan/HRE wheels, 275/30-19 w/10mm spacer, 295/30-19 w/3mm spacer, painted front reflectors, 30% tint, Escort 8500i & Lidar Jammer, AngeliBright halos, Euro rear foglights, 3M ClearBra.
Appreciate 0
      06-15-2012, 12:13 AM   #2
italyix
Lieutenant
United_States
6

 
italyix's Avatar
 
Drives: '08 E90 M3
Join Date: Dec 2011
Location: Bay Area


Posts: 574
iTrader: (3)

My Evo used to do that. Seemed like the pad would rust on the rotor and glue itself. I was using Ferrodo DS2500 at the time.
Appreciate 0
      06-15-2012, 09:05 AM   #3
THE TECH
BimmerPost Supporting Vendor
United_States
156


 
THE TECH's Avatar
 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas


Posts: 13,116
iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Just a little rust. No biggie.
__________________
Appreciate 0
      06-15-2012, 03:28 PM   #4
MysticBlue
Major
14

 
Drives: '09 M3 DCT Coupe, ---'15 x50i
Join Date: Apr 2008
Location: Eastern Oregon... They call 'em rigs here


Posts: 1,296
iTrader: (0)

OK, just wondering what's different. It never did this with the stock brakes.
__________________
M3: Active Autowerke filter, Dinan underdrive pulley, Dinan full exhaust and software, 3.45 Differential, Springs, Brakes, Dinan/HRE wheels, 275/30-19 w/10mm spacer, 295/30-19 w/3mm spacer, painted front reflectors, 30% tint, Escort 8500i & Lidar Jammer, AngeliBright halos, Euro rear foglights, 3M ClearBra.
Appreciate 0
      06-15-2012, 05:28 PM   #5
italyix
Lieutenant
United_States
6

 
italyix's Avatar
 
Drives: '08 E90 M3
Join Date: Dec 2011
Location: Bay Area


Posts: 574
iTrader: (3)

Quote:
Originally Posted by MysticBlue View Post
OK, just wondering what's different. It never did this with the stock brakes.
Don't quote me on this, but I believe the Brembo BBK pads are actually Ferrodo DS2500, which would explain your issue, as noted in my previous reply.
Appreciate 0
      06-15-2012, 05:51 PM   #6
1SIKM
Private First Class
United_States
1

 
1SIKM's Avatar
 
Drives: 2011 E92 M3
Join Date: Oct 2011
Location: Miami, FL


Posts: 196
iTrader: (0)

Quote:
Originally Posted by MysticBlue View Post
i've got the Dinan bbk (Brembo). Anytime the car is parked overnight after getting wet, the pads are stuck to the rotors. Upon first attempt at moving, the car feels like the e-brake is on and I have to give it quite a bit of gas to break it free. It's not the e-brake, I don't use it in my garage. It definitely feels like the pads are stuck to the rotors and it makes some noise when it breaks free, then no problems. Anybody else experience this, and is there anything that can be done about it?
This happens to me as well all the time...
__________________
All Thanks 2: Velos Designwerks-Wheels Boutique-IND Distribution-McKennaBMW
Mod List: | ESS VT2-625 | Velos Designwerks Tune | HRE P40S | Brembo 380mm BBK | Akrapovic Evolution Exhaust | KW V3 Coilovers | Vorsteiner GTS3 Front Bumper | Vorsteiner Rear Diffuser 2 | BMW Blue PSW | BMW Performance Spoiler | BMW GTS Door Sills | BMW Performance High Gloss Black Grills & Gills | TiKORE Industries Titanium Lug Bolts | STRI Gauges |
Appreciate 0
      06-15-2012, 07:11 PM   #7
808MGuy
Colonel
49

 
808MGuy's Avatar
 
Drives: 2009 E90 M3
Join Date: Jun 2008
Location: Oahu, Hawaii


Posts: 2,287
iTrader: (3)

This is fairly normal and it happens to me with OEM pads due to the rust on the rotor. Roll a few feet and all the rust is gone and everything is back to normal.
__________________
09 E90 M3 - Interlagos Blue / Black Novillo / Sycamore Anthracite / Eibach / HRE

Appreciate 0
      06-16-2012, 12:48 AM   #8
radiantm3
Apex Everything!
United_States
155

 
radiantm3's Avatar
 
Drives: >1000 HP in my garage
Join Date: Sep 2008
Location: Danville, CA


Posts: 3,850
iTrader: (6)

Garage List
2011 E92 M3  [4.80]
2013 BMW X5M  [4.33]
2014 BMW i3  [0.00]
Quote:
Originally Posted by italyix View Post
Don't quote me on this, but I believe the Brembo BBK pads are actually Ferrodo DS2500, which would explain your issue, as noted in my previous reply.
Yup. I have those pads on my brembos and have the same issue after I wash the car. Always think the parking brake is still on for a second.
__________________
2013 X5M for Sale
Appreciate 0
      06-16-2012, 12:50 AM   #9
MysticBlue
Major
14

 
Drives: '09 M3 DCT Coupe, ---'15 x50i
Join Date: Apr 2008
Location: Eastern Oregon... They call 'em rigs here


Posts: 1,296
iTrader: (0)

OK, guess it's not that unusual. But it's irritating. When I pull into the garage, if it's wet, I try to remember to not just stop with the brakes on and shut off the engine... I stop, release the brakes, wait a few seconds for the hill assist, or whatever it's called, to release the brakes, then shut it down. Seems to help a bit.
__________________
M3: Active Autowerke filter, Dinan underdrive pulley, Dinan full exhaust and software, 3.45 Differential, Springs, Brakes, Dinan/HRE wheels, 275/30-19 w/10mm spacer, 295/30-19 w/3mm spacer, painted front reflectors, 30% tint, Escort 8500i & Lidar Jammer, AngeliBright halos, Euro rear foglights, 3M ClearBra.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:21 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST