BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > General M3 Forum (E90 + E92 + E93)
 
European Auto Source
Post Reply
 
Thread Tools Search this Thread
      05-22-2012, 01:16 PM   #1
jayjaybelbel
First Lieutenant
 
jayjaybelbel's Avatar
 
Drives: alpine white e92 M3
Join Date: Aug 2007
Location: Los Angeles,CA

Posts: 322
iTrader: (1)

springs installed, now with clunking sound

installed my H&R springs last night and after the installation, it now has a clunking/rattling sound. I checked the struts and everything is tightened up. driver side is good but the sound is coming from the passenger side front and rear section. Can anyone chime in? thanks is advance
jayjaybelbel is offline   Philippines
0
Reply With Quote
      05-22-2012, 02:01 PM   #2
Nati Beastcat
Trader!!
 
Nati Beastcat's Avatar
 
Drives: E55 AMG
Join Date: Jun 2011
Location: Cincinnati

Posts: 1,284
iTrader: (5)

Quote:
Originally Posted by jayjaybelbel
installed my H&R springs last night and after the installation, it now has a clunking/rattling sound. I checked the struts and everything is tightened up. driver side is good but the sound is coming from the passenger side front and rear section. Can anyone chime in? thanks is advance
I had help with my setup. But from what i've read on here, most likely one of the springs isn't seated properly. If you do a search it will pop up. Look for a thread started by edu09.

here it is not quite the same setup but you get the idea

http://www.m3post.com/forums/showthread.php?t=619215
__________________
Eisenmann race | Test Pipes | BPM Stage 2 | Vorsteiner | Black lines | AA filter | iND cosmetics | KW Sleeve over | 20" BBS LM's | Macht Schnell Tow Strap | Euro modded front bumper | Revinora lip | iND mirror caps | BMW spoiler | BMW Steering wheel | iND Interior Pkg |You bet Jerez its black and i'll never go back! Instagram @NATIBEASTCAT

Last edited by Nati Beastcat; 05-22-2012 at 02:10 PM.
Nati Beastcat is offline  
0
Reply With Quote
      05-22-2012, 02:21 PM   #3
jayjaybelbel
First Lieutenant
 
jayjaybelbel's Avatar
 
Drives: alpine white e92 M3
Join Date: Aug 2007
Location: Los Angeles,CA

Posts: 322
iTrader: (1)

will check it out, thanks. I did look around and one guy had the same problem but i believe it was from his struts. I will check it again later.
jayjaybelbel is offline   Philippines
0
Reply With Quote
      05-22-2012, 03:16 PM   #4
Nati Beastcat
Trader!!
 
Nati Beastcat's Avatar
 
Drives: E55 AMG
Join Date: Jun 2011
Location: Cincinnati

Posts: 1,284
iTrader: (5)

Quote:
Originally Posted by jayjaybelbel
will check it out, thanks. I did look around and one guy had the same problem but i believe it was from his struts. I will check it again later.
Should be the problem. You'll probably end up taking most of it apart. Hopefully you can find the problem springs and don't end up doing more work than you need too
__________________
Eisenmann race | Test Pipes | BPM Stage 2 | Vorsteiner | Black lines | AA filter | iND cosmetics | KW Sleeve over | 20" BBS LM's | Macht Schnell Tow Strap | Euro modded front bumper | Revinora lip | iND mirror caps | BMW spoiler | BMW Steering wheel | iND Interior Pkg |You bet Jerez its black and i'll never go back! Instagram @NATIBEASTCAT
Nati Beastcat is offline  
0
Reply With Quote
      05-23-2012, 01:35 AM   #5
fokus45
Enlisted Member
 
Drives: little blue dune buggy
Join Date: Jan 2011
Location: WY

Posts: 43
iTrader: (0)

Had the same thing when I put springs on a Merc that I used to have. It was coming from the passenger rear and I checked and played with the spring seating several times. Never helped so I put new shocks on even though the car had only 7,000ish miles. Sure enough, never heard the sound again.
fokus45 is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:31 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST