BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > General M3 Forum (E90 + E92 + E93)
 
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      03-10-2012, 02:53 AM   #1
aresh
First Lieutenant
 
Drives: 2006 550i
Join Date: May 2009
Location: NY

Posts: 370
iTrader: (1)

Thumbs down My dealer sucks! help

I recently lost sound and my screen went blank on my idrive screen. I have the CCC, i went to the dealer only for them to tell me it was the CCC and screen thats gone bad. I replaced it with the CIC unit and i still have no sound or screen. Whats going on?? someone have any idea? could it be possible that i ruined the digital cable (green and black) by possibly twisting it? I have the individual sound system btw
aresh is offline  
0
Reply With Quote
      03-10-2012, 06:13 AM   #2
MMME30W
Riff Raff Refugee
 
MMME30W's Avatar
 
Drives: Civic
Join Date: Mar 2012
Location: Tampa

Posts: 625
iTrader: (1)

Hard to diagnose without more information.

Are there any diagnostics you can run post-install to verify components? Are you sure you are getting power?

By the way, why does the dealer suck? You said they told you you had a fault in the CCC, this makes them suck?
MMME30W is offline   Germany
0
Reply With Quote
      03-10-2012, 06:26 AM   #3
aresh
First Lieutenant
 
Drives: 2006 550i
Join Date: May 2009
Location: NY

Posts: 370
iTrader: (1)

The cic unit works because the cd drive ejects. They suck because they were wrong! My ccc unit works fine. Im at a loss for how to fix this. I researched and found people that had this issue was usually resolved through replacing the mpm. Micro processor module. But thats found in e60 5 series trunks and i cant locate it on my e92
aresh is offline  
0
Reply With Quote
      03-10-2012, 06:27 AM   #4
aresh
First Lieutenant
 
Drives: 2006 550i
Join Date: May 2009
Location: NY

Posts: 370
iTrader: (1)

Btw they assumed the ccc unit was broke. After buying a new cic unit im still having the same exact problem i had with my old ccc unit.
aresh is offline  
0
Reply With Quote
      03-10-2012, 06:48 AM   #5
MMME30W
Riff Raff Refugee
 
MMME30W's Avatar
 
Drives: Civic
Join Date: Mar 2012
Location: Tampa

Posts: 625
iTrader: (1)

Sorry.

Dunno if it will help but these guys may have inexpensive recycled parts, if need be:

http://www.bmrparts.com/index.htm

Might also try a search on other boards or forums for similar problems on mainstream E9x vehicles for ideas on diagnosis and repair.

Good luck.
MMME30W is offline   Germany
0
Reply With Quote
      03-10-2012, 06:58 AM   #6
aresh
First Lieutenant
 
Drives: 2006 550i
Join Date: May 2009
Location: NY

Posts: 370
iTrader: (1)

Can the TCU cause this? does anyone know what modules can cause this?
aresh is offline  
0
Reply With Quote
      03-10-2012, 02:43 PM   #7
aresh
First Lieutenant
 
Drives: 2006 550i
Join Date: May 2009
Location: NY

Posts: 370
iTrader: (1)

Can anyone point me in some direction?
aresh is offline  
0
Reply With Quote
      03-10-2012, 02:48 PM   #8
Blayne
Enlisted Member
 
Drives: Escalade
Join Date: Aug 2011
Location: Canada

Posts: 44
iTrader: (0)

Quote:
Originally Posted by aresh
Can anyone point me in some direction?
Go a 100 miles NE of your current position, then from there go 50 miles west, and you should be there.
Blayne is offline  
0
Reply With Quote
      03-10-2012, 03:45 PM   #9
1sikbmr
Brigadier General
 
1sikbmr's Avatar
 
Drives: E90 M3 6MT
Join Date: Mar 2010
Location: New York

Posts: 3,277
iTrader: (14)

what dealer? take it to pace bmw
__________________

E90 ///M3 6MT Atlantis Blue - Fox red
ESS VT1-550|Gloss black grilles/Gold gills|V1 hardwire|Filled reflectors|ZHP lighted shift knob|Volk TE37 Gloss Black|Mode Carbon GT4 Lip|Umnitza V4 full blackout kit|Agency Power exhaust|Sosi x-pipe|BMW Performance Steering Wheel V1|
1sikbmr is offline  
0
Reply With Quote
      03-10-2012, 04:06 PM   #10
Moxie
Lieutenant Colonel
 
Moxie's Avatar
 
Drives: AW 328d Touring/SG 335d
Join Date: Jul 2009
Location: Stuttgart

Posts: 1,859
iTrader: (11)

Have you tried speaking with Technic? Normally he can help or point you in the right direction -
Moxie is offline   Germany
0
Reply With Quote
      03-10-2012, 05:02 PM   #11
aresh
First Lieutenant
 
Drives: 2006 550i
Join Date: May 2009
Location: NY

Posts: 370
iTrader: (1)

thanks im not bashing on my dealer, they are good but they just made the wrong analysis this time around.
aresh is offline  
0
Reply With Quote
      03-10-2012, 05:28 PM   #12
JAdamz
M3NTAL
 
JAdamz's Avatar
 
Drives: 2011 E92 M3 ZCP
Join Date: May 2010
Location: Long Island, NY

Posts: 442
iTrader: (1)

Quote:
Originally Posted by aresh View Post
thanks im not bashing on my dealer, they are good but they just made the wrong analysis this time around.
Had me fooled with "My dealer sucks!"
JAdamz is offline   United_States
0
Reply With Quote
      03-10-2012, 05:30 PM   #13
aresh
First Lieutenant
 
Drives: 2006 550i
Join Date: May 2009
Location: NY

Posts: 370
iTrader: (1)

haha getting more ppl to view this and help me out!
aresh is offline  
0
Reply With Quote
      05-02-2012, 03:46 PM   #14
sea335i
Private First Class
 
Drives: 2008 335i Coupe
Join Date: Jul 2011
Location: Seattle

Posts: 101
iTrader: (0)

just curious if you resolved your issue?
sea335i is offline  
0
Reply With Quote
      05-02-2012, 03:50 PM   #15
THE TECH
BimmerPost Supporting Vendor

 
THE TECH's Avatar
 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

Posts: 13,103
iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Pretty sure you can't just exchange one for the other. You will definitely need coding if you want to upgrade from CCC to CIC.
__________________
THE TECH is offline   United_States
0
Reply With Quote
      05-02-2012, 03:56 PM   #16
tibra1
Banned
 
Drives: 2011 ZCP M3 - 2007 335i crashd
Join Date: Apr 2009
Location: NYC

Posts: 6,777
iTrader: (4)

Quote:
Originally Posted by aresh View Post
I recently lost sound and my screen went blank on my idrive screen. I have the CCC, i went to the dealer only for them to tell me it was the CCC and screen thats gone bad. I replaced it with the CIC unit and i still have no sound or screen. Whats going on?? someone have any idea? could it be possible that i ruined the digital cable (green and black) by possibly twisting it? I have the individual sound system btw
You have just crystalized why i didnt get i-drive; e-drive; a-drive ..CCC CIC TUC>>whatever...

My car is a total stripper..not even power seats..only goodies are comp and cold package..less electronics means less crap that can go wrong..GL w everything
tibra1 is offline   No_Country
0
Reply With Quote
      05-02-2012, 04:57 PM   #17
aresh
First Lieutenant
 
Drives: 2006 550i
Join Date: May 2009
Location: NY

Posts: 370
iTrader: (1)

Yes problem was solved. Took three weeks and 1000 dollars and I ended up retrofitting cic myself no coding needed from dealer.
aresh is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:51 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST