BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing
 
BPM Sport
Post Reply
 
Thread Tools Search this Thread
      04-28-2012, 05:40 PM   #1
flip
Private First Class
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 112
iTrader: (0)

Increased Emissions? Pulled codes...

So I've already googled for a few weeks and haven't seen anything that looks just like the codes that I've pulled. I'm considering picking up an Innova 3160 to help troubleshooting but before I do I figured I'd pick you all's brains .

What happened...
The first time I was at about 1/4 tank of gas (not sure if that matters but codes mentioned fuel level so I thought it might be relevant). My car showed a check engine light and displayed "Increased Emissions" on the iDrive display.

I got the codes pulled by a friend at my shop and we reset them at that time also. I'll list the codes below...

After I reset them it stayed away for about 3 weeks and then came back last night. The car seems to run and drive fine but shows the service engine soon light and increased emissions.

Here are the codes that the car showed after the first time it faulted...

Codes:
279D - Power management, closed-circuit current violation
2722 - Fuel-pressure sensor, signal
27D0 - Fuel pressure control adaptation
27BB - Fuel system, lambda/charge plausibility, bank 2
27C1 - Info: Tank empty on fault entry

After clearing the codes and having the fault come back, this was the only code that came back...
P0175 x2 - System too rich (Bank 2)

I'm not sure if all of these codes were related to the increased emissions but I figured I'd list all of the codes that were shown when we pulled them.

Any idea what this combination of codes would point to? If theres any further information I could provide, please let me know!! Thanks in advance for your help!!

Last edited by flip; 04-29-2012 at 04:15 PM.
flip is offline  
0
Reply With Quote
      04-29-2012, 11:24 AM   #2
flip
Private First Class
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 112
iTrader: (0)

Oh, I attempted to post this in the most appropriate forum. Please move it if there is a better location...
flip is offline  
+1
Reply With Quote
      04-29-2012, 04:16 PM   #3
flip
Private First Class
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 112
iTrader: (0)

Got the codes pulled again today since it came back and this time only one code was reported.

P0175 x2 - System too rich (Bank 2)

This help at all?
flip is offline  
0
Reply With Quote
      04-29-2012, 06:14 PM   #4
Archiebabes
Lieutenant
 
Drives: 2008 BMW M3
Join Date: Jul 2011
Location: Van Nuys, CA

Posts: 507
iTrader: (10)

You need to replace one of your upstream O2 sensor. I have the same code and will get mine replaced tomorrow for $350 installed.
Archiebabes is offline  
0
Reply With Quote
      04-29-2012, 08:48 PM   #5
elm3
M3 Lover
 
elm3's Avatar
 
Drives: 2009 e92 M3 Interlagos Blue
Join Date: Sep 2008
Location: Canton, GA.

Posts: 1,849
iTrader: (1)

Garage List
Quote:
Originally Posted by flip View Post
Got the codes pulled again today since it came back and this time only one code was reported.

P0175 x2 - System too rich (Bank 2)

This help at all?
+1 on the upstream O2 sensor. It is the one that reads the mixture of the air/fuel.
__________________
'09 E92 ///M3 Interlagos Blue, 6MT, Silver Novillo Leather, CF Trim, Premium Package, Technology Package, Cold Weather Package, Premium Sound, 19" Wheels, Moonroof-Toy/ '11 E90 328i Black Saphire Metallic, Premium Package, Technology Package - Daily Driver '02 Nissan Xterra- Daily Driver/ '04 Yamaha R1-Toy/ '06 Yamaha Raptor 350-Toy
elm3 is offline   United_States
0
Reply With Quote
      04-29-2012, 09:22 PM   #6
flip
Private First Class
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 112
iTrader: (0)

Any idea how I can troubleshoot to find out which one it is? I'm planning on getting an Innova 3160 for this type of thing. I should be able to use the live data feature to check them all yes?
flip is offline  
0
Reply With Quote
      04-29-2012, 09:26 PM   #7
flip
Private First Class
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 112
iTrader: (0)

The car only has 52k miles on it. Is it really likely that the O2 has gone bad already? I've read that it could be vacuum leak somewhere or something of the sort. Would this single code leave the possibility of other problems or pretty clearly be O2?

Also, are all 4 O2 sensors the same part number? Any suggestions on the best place to order online? Upstream is the one in the manifold?

#1 on this diagram?
http://realoem.com/bmw/showparts.do?...46&hg=18&fg=10

Last edited by flip; 04-29-2012 at 10:07 PM.
flip is offline  
0
Reply With Quote
      04-30-2012, 08:35 AM   #8
elm3
M3 Lover
 
elm3's Avatar
 
Drives: 2009 e92 M3 Interlagos Blue
Join Date: Sep 2008
Location: Canton, GA.

Posts: 1,849
iTrader: (1)

Garage List
If you had a vacuum leak, it would have shown up as system too lean (too much air in the system). When it is too rich, either your system is dumping too much fuel, or the system is not reading the mixture right. And yeah, an O2 sensor can go bad at any time, but it can also last over 100k miles too. The way you can tell which one it is, the system will tell you, upstream or down stream ( upstream-before cats, down stream-after cats) and then bank 1 or bank 2 ( bank 1- where the number 1 cylinder is, bank 2- the opposite side). Hope that this will help. Let me know if you have more questions.

Eric
__________________
'09 E92 ///M3 Interlagos Blue, 6MT, Silver Novillo Leather, CF Trim, Premium Package, Technology Package, Cold Weather Package, Premium Sound, 19" Wheels, Moonroof-Toy/ '11 E90 328i Black Saphire Metallic, Premium Package, Technology Package - Daily Driver '02 Nissan Xterra- Daily Driver/ '04 Yamaha R1-Toy/ '06 Yamaha Raptor 350-Toy
elm3 is offline   United_States
0
Reply With Quote
      04-30-2012, 09:26 AM   #9
flip
Private First Class
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 112
iTrader: (0)

Quote:
Originally Posted by elm3 View Post
If you had a vacuum leak, it would have shown up as system too lean (too much air in the system). When it is too rich, either your system is dumping too much fuel, or the system is not reading the mixture right. And yeah, an O2 sensor can go bad at any time, but it can also last over 100k miles too. The way you can tell which one it is, the system will tell you, upstream or down stream ( upstream-before cats, down stream-after cats) and then bank 1 or bank 2 ( bank 1- where the number 1 cylinder is, bank 2- the opposite side). Hope that this will help. Let me know if you have more questions.

Eric
Great, that helps a ton! I'm going to get the car up in the air and visually inspect to see if anything is damaged and go from there I guess...
flip is offline  
0
Reply With Quote
      04-30-2012, 10:21 AM   #10
elm3
M3 Lover
 
elm3's Avatar
 
Drives: 2009 e92 M3 Interlagos Blue
Join Date: Sep 2008
Location: Canton, GA.

Posts: 1,849
iTrader: (1)

Garage List
Quote:
Originally Posted by flip View Post
Great, that helps a ton! I'm going to get the car up in the air and visually inspect to see if anything is damaged and go from there I guess...
Let me know if you need help. I'm probably about 30 minutes north of you. And can help you change it. I got a lot of tools and space to do this. Plus I have a scanner and can delete your codes when done.

Eric
__________________
'09 E92 ///M3 Interlagos Blue, 6MT, Silver Novillo Leather, CF Trim, Premium Package, Technology Package, Cold Weather Package, Premium Sound, 19" Wheels, Moonroof-Toy/ '11 E90 328i Black Saphire Metallic, Premium Package, Technology Package - Daily Driver '02 Nissan Xterra- Daily Driver/ '04 Yamaha R1-Toy/ '06 Yamaha Raptor 350-Toy
elm3 is offline   United_States
0
Reply With Quote
      04-30-2012, 11:01 AM   #11
flip
Private First Class
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 112
iTrader: (0)

Quote:
Originally Posted by elm3 View Post
Let me know if you need help. I'm probably about 30 minutes north of you. And can help you change it. I got a lot of tools and space to do this. Plus I have a scanner and can delete your codes when done.

Eric
Awesome, I may take you up on that! I'm fairly experienced with cars but it always helps to have experienced hands when working on a vehicle that I'm not familiar with...

So looks like this is what I'll need to order?
http://www.rmeuropean.com/Part-Numbe..._94E6B777.aspx

If you know of a better place to order please let me know. I got the part number from realoem so i believe its the correct part...
flip is offline  
0
Reply With Quote
      04-30-2012, 12:02 PM   #12
elm3
M3 Lover
 
elm3's Avatar
 
Drives: 2009 e92 M3 Interlagos Blue
Join Date: Sep 2008
Location: Canton, GA.

Posts: 1,849
iTrader: (1)

Garage List
Quote:
Originally Posted by flip View Post
Awesome, I may take you up on that! I'm fairly experienced with cars but it always helps to have experienced hands when working on a vehicle that I'm not familiar with...

So looks like this is what I'll need to order?
http://www.rmeuropean.com/Part-Numbe..._94E6B777.aspx

If you know of a better place to order please let me know. I got the part number from realoem so i believe its the correct part...
Try Autozone or Napa. You can give them the part number and see if they can do better, price wise. Usually they can.
__________________
'09 E92 ///M3 Interlagos Blue, 6MT, Silver Novillo Leather, CF Trim, Premium Package, Technology Package, Cold Weather Package, Premium Sound, 19" Wheels, Moonroof-Toy/ '11 E90 328i Black Saphire Metallic, Premium Package, Technology Package - Daily Driver '02 Nissan Xterra- Daily Driver/ '04 Yamaha R1-Toy/ '06 Yamaha Raptor 350-Toy
elm3 is offline   United_States
0
Reply With Quote
      05-01-2012, 09:51 PM   #13
flip
Private First Class
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 112
iTrader: (0)

Code came back only after a few days this time so I guess I'd better get on the fix... Going to price the O2 tomorrow.
flip is offline  
0
Reply With Quote
      05-02-2012, 06:31 AM   #14
flip
Private First Class
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 112
iTrader: (0)

One more question, does anyone know which side cylinder #1 is? From my searches I've read it should be closest to the radiator, passenger side. Is this correct?
flip is offline  
0
Reply With Quote
      05-02-2012, 06:48 AM   #15
elm3
M3 Lover
 
elm3's Avatar
 
Drives: 2009 e92 M3 Interlagos Blue
Join Date: Sep 2008
Location: Canton, GA.

Posts: 1,849
iTrader: (1)

Garage List
Quote:
Originally Posted by flip View Post
One more question, does anyone know which side cylinder #1 is? From my searches I've read it should be closest to the radiator, passenger side. Is this correct?
You are correct. So if you are looking at the engine, number one cylinder is the one on your left as you are looking at it. So bank 1 is on your left. If you need to change the upstream O2 sensor on bank 1, it is the one on your left, before the cats. Hope that this makes sense. Let me know if you need help, I don not mind.

Eric
__________________
'09 E92 ///M3 Interlagos Blue, 6MT, Silver Novillo Leather, CF Trim, Premium Package, Technology Package, Cold Weather Package, Premium Sound, 19" Wheels, Moonroof-Toy/ '11 E90 328i Black Saphire Metallic, Premium Package, Technology Package - Daily Driver '02 Nissan Xterra- Daily Driver/ '04 Yamaha R1-Toy/ '06 Yamaha Raptor 350-Toy
elm3 is offline   United_States
0
Reply With Quote
      05-02-2012, 07:12 AM   #16
flip
Private First Class
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 112
iTrader: (0)

Quote:
Originally Posted by elm3 View Post
You are correct. So if you are looking at the engine, number one cylinder is the one on your left as you are looking at it. So bank 1 is on your left. If you need to change the upstream O2 sensor on bank 1, it is the one on your left, before the cats. Hope that this makes sense. Let me know if you need help, I don not mind.

Eric
Yep, makes perfect sense, thanks! And I may still hit you up for an extra hand when I do this... I may have lost my O2 socket so extra tools may help .
flip is offline  
0
Reply With Quote
      05-02-2012, 08:35 AM   #17
elm3
M3 Lover
 
elm3's Avatar
 
Drives: 2009 e92 M3 Interlagos Blue
Join Date: Sep 2008
Location: Canton, GA.

Posts: 1,849
iTrader: (1)

Garage List
Quote:
Originally Posted by flip View Post
Yep, makes perfect sense, thanks! And I may still hit you up for an extra hand when I do this... I may have lost my O2 socket so extra tools may help .
Let me know.
__________________
'09 E92 ///M3 Interlagos Blue, 6MT, Silver Novillo Leather, CF Trim, Premium Package, Technology Package, Cold Weather Package, Premium Sound, 19" Wheels, Moonroof-Toy/ '11 E90 328i Black Saphire Metallic, Premium Package, Technology Package - Daily Driver '02 Nissan Xterra- Daily Driver/ '04 Yamaha R1-Toy/ '06 Yamaha Raptor 350-Toy
elm3 is offline   United_States
0
Reply With Quote
      05-11-2012, 12:55 AM   #18
flip
Private First Class
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 112
iTrader: (0)

Ended up replacing the O2 today. Was quite simple as expected... Car feels like it runs much smoother and I seem to have a good bit of performance back on the top end.

This time when we pulled the codes before we deleted them, we got misfires on all cyl's except for #1. I'm guessing this is simply from dumping too much fuel.

I drove it about 10 miles and the code hasn't come back but I won't be convinced for a week or so. I'll update in a bit one way or the other.

Thanks again elm3 for your offer to help and for your help here, and to everyone else who contributed! Let me know if you attend any local BMW meets, i'd still be happy to make an m3 buddy!
flip is offline  
0
Reply With Quote
      05-12-2012, 10:22 PM   #19
flip
Private First Class
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 112
iTrader: (0)

So after replacing the O2 sensor, the code came back. I've ordered an innova to pull the codes and help diagnose... Any suggestions? Not sure what else this could be.
flip is offline  
0
Reply With Quote
      05-13-2012, 09:44 AM   #20
flip
Private First Class
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 112
iTrader: (0)

Is it normal for our cars to idle rough for a bit when cold started? Mine lopes a bit when first started in the morning sometimes.
flip is offline  
0
Reply With Quote
      05-16-2012, 07:17 AM   #21
elm3
M3 Lover
 
elm3's Avatar
 
Drives: 2009 e92 M3 Interlagos Blue
Join Date: Sep 2008
Location: Canton, GA.

Posts: 1,849
iTrader: (1)

Garage List
Quote:
Originally Posted by flip View Post
Is it normal for our cars to idle rough for a bit when cold started? Mine lopes a bit when first started in the morning sometimes.
Yes, this is normal. Our cars don't have the MAF sensor. So it starts out rich, to warm up the cats. Then it will smooth out. Let me know if you still need help on your O2 sensors.

Eric
__________________
'09 E92 ///M3 Interlagos Blue, 6MT, Silver Novillo Leather, CF Trim, Premium Package, Technology Package, Cold Weather Package, Premium Sound, 19" Wheels, Moonroof-Toy/ '11 E90 328i Black Saphire Metallic, Premium Package, Technology Package - Daily Driver '02 Nissan Xterra- Daily Driver/ '04 Yamaha R1-Toy/ '06 Yamaha Raptor 350-Toy
elm3 is offline   United_States
0
Reply With Quote
      05-17-2012, 07:58 AM   #22
flip
Private First Class
 
Drives: 2008 E90 M3
Join Date: Jul 2010
Location: Marietta, GA

Posts: 112
iTrader: (0)

Quote:
Originally Posted by elm3 View Post
Yes, this is normal. Our cars don't have the MAF sensor. So it starts out rich, to warm up the cats. Then it will smooth out. Let me know if you still need help on your O2 sensors.

Eric
Ok cool. I did read that other places as well. I dont' mind, always sounds more agressive like my drift car tune .

I got the O2 done fairly easily but the code came back so I'm waiting on my code reader to get in in the mail. I'll post back up as soon as I get that and pull the codes again.

I had the codes reset JUST before I replaced the O2. I drove it home from the auto store after resetting it and replaced the O2. The code came back days later. Is there any way resetting it before replacing the O2 could cause the code to come back days later? Or is there likely simply another code (or the same code)?
flip is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:18 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST