BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
Evolve Automotive
Post Reply
 
Thread Tools Search this Thread
      04-18-2012, 02:53 PM   #1
StylePoints
Second Lieutenant
StylePoints's Avatar
7
Rep
295
Posts

 
Drives: e92 M3
Join Date: Jun 2007
Location: ca

iTrader: (1)

Engine emissions increased? dealer doesnt know whats wrong?

Last friday my engine light went off. Said engine emissions increased and i started getting slow crank on ignition? Like barely starting. I took the car to the dealer the next day. Didnt hear back for 2 days so i called the dealer and he told me they cant figure out whats wrong because the only code its throwing is a malfunction on wheel speed sensor? Also my last service was 2,200 miles ago and since then i have had to top off 2 times. About every 1000 miles. Which i have thought was very strange. I have 25k miles on the car. I searched the forums and seems most ppl who have that check engine light with increased immisions is due to faulty o2 sensor.


Anyone know why they cant figure it out and why is my engine eating up oil like that?
Yes i do drive the car pretty hard but i never track it. My only mod is dinan pulley and ms charge filter. Should i be worried that those mods could void any warantees??? Because i didnt take them off when i dropped it off at the dealer.
Appreciate 0
      04-18-2012, 03:55 PM   #2
ILSMKU
BMW FTW
ILSMKU's Avatar
No_Country
33
Rep
1,896
Posts

 
Drives: E92 M3
Join Date: Jul 2011
Location: ///OC

iTrader: (5)

Garage List
I would have taken off any mods. Especially if your not sure if your dealer is mod friendly or not. Most dealers will look for any reason to get out of warranty work. Why? Because they make way more money having you pay the bill directly. Warranty work usually gives the dealer a set price to do the repair. Good luck and sorry to hear about this.
__________________
///2013 AW 6MT E92 ZCP M3/// Black 359M Wheels/BMW Performance Carbon Fiber Spoiler and Mirror Caps/Arkym AeroSport Front Lip/Turner 15MM Spacers/LUX 8 LED Halo/IND Gloss Black Grills, Gills and M3 Emblem/30% 3M Tint/BMW Interior LED/MusicCar Subwoofer Enclosure/JL Audio 12" W6 Sub and XD600:1 Amp/Euro Sunglasses Tray/Ceramic Coated Megan Racing Exhaust/AFe Dry Air Filter/RPI Intake Scoops/Euro MDM/Feature Coded.
Appreciate 0
      04-18-2012, 04:00 PM   #3
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,121
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
If there was no code present for increased emissions, then maybe it was an isolated situation? How much specifically do you mean when you say "top off"?
__________________
Appreciate 0
      04-19-2012, 01:43 AM   #4
Mbauer
First Lieutenant
6
Rep
330
Posts

 
Drives: E92 187outx3
Join Date: Dec 2011
Location: So Cal

iTrader: (1)

Theres an SIB on K-Can faults. Theres a few places where the bus can short out. I never thought it would set an Increase Emissions check message without a powertrain fault but I saw it happen first hand.
Appreciate 0
      04-19-2012, 03:20 AM   #5
StylePoints
Second Lieutenant
StylePoints's Avatar
7
Rep
295
Posts

 
Drives: e92 M3
Join Date: Jun 2007
Location: ca

iTrader: (1)

Quote:
Originally Posted by THE TECH View Post
If there was no code present for increased emissions, then maybe it was an isolated situation? How much specifically do you mean when you say "top off"?

I've topped off twice in the last 2200 miles. First time I topped off 2 quarts at the dealers and then a month later light went off again...went back and topped off another 1 quart. 3rd day today...no call from dealer still. I am getting a little nervous.
Appreciate 0
      04-19-2012, 08:06 AM   #6
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,121
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Two quarts is A LOT for a top off. Are you sure you're not overfilling?
__________________
Appreciate 0
      04-19-2012, 08:26 AM   #7
Mbauer
First Lieutenant
6
Rep
330
Posts

 
Drives: E92 187outx3
Join Date: Dec 2011
Location: So Cal

iTrader: (1)

If you overfill it enough, it will run terrible
Appreciate 0
      04-19-2012, 02:51 PM   #8
StylePoints
Second Lieutenant
StylePoints's Avatar
7
Rep
295
Posts

 
Drives: e92 M3
Join Date: Jun 2007
Location: ca

iTrader: (1)

Quote:
Originally Posted by THE TECH View Post
Two quarts is A LOT for a top off. Are you sure you're not overfilling?
I mean this is the dealer doing it. Car shows engine oil low so I take it to the dealer...they should know how to top off right??
Appreciate 0
      04-19-2012, 08:35 PM   #9
StylePoints
Second Lieutenant
StylePoints's Avatar
7
Rep
295
Posts

 
Drives: e92 M3
Join Date: Jun 2007
Location: ca

iTrader: (1)

UPDATE** Got my car back from the dealer. The paperworks says the reason for the check engine like (increased emissions) was caused by after market wheel. I WAS LIKE WTF?!?!? Are you kidding me?

This is exactly what it says and I will take a picture of the paperwork later tonight:

Aftermarket accessories connected charger and interrogated fault memory and found due: Speed recording default. Followed test plan and wire tested the system between the DME and DSC. Found the PT can line to be fully operating at 1.5 volts and 4 volts high. Found the resistance to be at. 020 HMS. Wrote puma case 50847390 and they advised me to measure the wheels on the car verse the stock wheels. Found the rear wheels to be 63.5 MM difference and 18.24 mm in the front. Found the trans shifting to also be related due to the weight nd size of the wheels. Per puma swapped stock wheels and cleared faults drove car and found the light to not be present. Found the wheels to be the problem for check engine light.

- Customer report vehicle has slow crank when starting due to check engine light:

Faulty battery found due to 30GF shutdown. Performed migatronics test and found battery to fail.


BTW my wheels are 19x9F and 19x10.5 rear. But I still can not believe my wheels caused emission increased check engine light. Crazy! And they had my car for 3 full days to tell me this.
Appreciate 0
      04-19-2012, 08:37 PM   #10
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,121
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Wow...that's a new one.
__________________
Appreciate 0
      04-19-2012, 11:12 PM   #11
kitw
Colonel
kitw's Avatar
61
Rep
2,630
Posts

 
Drives: 2015 MW M3/2014 Boxster S
Join Date: Jun 2007
Location: Bay Area, CA

iTrader: (14)

What tire sizes are you running?
Appreciate 0
      04-19-2012, 11:55 PM   #12
tibra1
Banned
No_Country
75
Rep
6,775
Posts

 
Drives: 2011 ZCP M3 - 2007 335i crashd
Join Date: Apr 2009
Location: NYC

iTrader: (4)

Actually it makes perfect sense..I have been saying all along that this extreme plus sizing of wheels/tires upsets the balance of the car..and now apparently can be used by the dealer to deny claims
Appreciate 0
      04-19-2012, 11:59 PM   #13
1MOREMOD
2014 Track Days - 11|Ridge 1:52:24|Pacific 1:35:72
1MOREMOD's Avatar
United_States
172
Rep
12,937
Posts

 
Drives: Race car->
Join Date: Mar 2009
Location: check your mirrors

iTrader: (5)

what a joke. my SA tried that crap i smack him.
__________________

02 Tiag e46 M3|6MT|GC plates|MCS c.o.|GC bars|GC race control arms|GC bushings|BW eng. & tran. mounts|subframe kit|BW race shifter|BW Jaffster|Euro header|BW exhaust|K&N c.a.i.|Epic race tune|Rouge pulleys|Seibon CF hood|CSL bumper|ST-40|XR-2|SS lines|half cage|Recaro profi|Profi 2 harness|BMWpedals|BW studs|
Appreciate 0
      04-20-2012, 02:28 AM   #14
StylePoints
Second Lieutenant
StylePoints's Avatar
7
Rep
295
Posts

 
Drives: e92 M3
Join Date: Jun 2007
Location: ca

iTrader: (1)

I'm running Hankook v12's. 255/35/19f...285/30/19r

Car seems to be running fine and no check engine light now.
So my question is this, was there really a problem and they simply did not want to fix the issue so they just cleared the code and said it was my wheels?
Should I try taking my car to another dealer (but now theres no check engine light)?

Or maybe the wheels really was the problem....BUT i am still running 19s!! Just a little wider wheels and tires. Not like I'm rolling on 20s.
Appreciate 0
      04-20-2012, 02:49 AM   #15
kitw
Colonel
kitw's Avatar
61
Rep
2,630
Posts

 
Drives: 2015 MW M3/2014 Boxster S
Join Date: Jun 2007
Location: Bay Area, CA

iTrader: (14)

You don't seem to understand the critical part, which is the height of the tire. Stock, a 245/35r19 is ~25.75" while the rear, 265/35r19 is about ~26.25"

That is 1/2" difference.

You are running 255/35r19 which are 26" and 285/30r19 which is 25.75"

You have the opposite stagger in overall diameter. YES this will cause a problem and NO it's not the right tire sizes for the car.
Appreciate 0
      04-20-2012, 03:25 AM   #16
Singletrack
4th down; 4th quarter? Renegade.
Singletrack's Avatar
United_States
43
Rep
3,820
Posts

 
Drives: 09 SSII E92 M3; 12 AW X5d
Join Date: Aug 2008
Location: Pittsburgh, PA

iTrader: (3)

Kitw dropping the logic.

FYI also - PUMA case means a BMW engineer looked at case and helped dealer troubleshoot.
Appreciate 0
      04-20-2012, 05:27 AM   #17
arter
collecting toys
arter's Avatar
8
Rep
780
Posts

 
Drives: M3 MCB
Join Date: May 2008
Location: rochester, ny

iTrader: (0)

Customer report vehicle has slow crank when starting due to check engine light:

Faulty battery found due to 30GF shutdown. Performed migatronics test and found battery to fail.


Did they replace the battery?



Also on the oil loss, look around the filler cap as this can leak a surprising amount of oil is the gasket is not set correctly.
__________________
2011 e92 M3 Monte Carlo Blue ESS 535
2015 cayman GTS
2006 SLK 55 AMG
Appreciate 0
      04-20-2012, 08:43 AM   #18
StylePoints
Second Lieutenant
StylePoints's Avatar
7
Rep
295
Posts

 
Drives: e92 M3
Join Date: Jun 2007
Location: ca

iTrader: (1)

Quote:
Originally Posted by kitw View Post
You don't seem to understand the critical part, which is the height of the tire. Stock, a 245/35r19 is ~25.75" while the rear, 265/35r19 is about ~26.25"

That is 1/2" difference.

You are running 255/35r19 which are 26" and 285/30r19 which is 25.75"

You have the opposite stagger in overall diameter. YES this will cause a problem and NO it's not the right tire sizes for the car.

Tire rack recommended this tire size for the wheels I got. So if these are the wrong size, what size should I be running?
Appreciate 0
      04-20-2012, 08:44 AM   #19
StylePoints
Second Lieutenant
StylePoints's Avatar
7
Rep
295
Posts

 
Drives: e92 M3
Join Date: Jun 2007
Location: ca

iTrader: (1)

Quote:
Originally Posted by arter View Post
Customer report vehicle has slow crank when starting due to check engine light:

Faulty battery found due to 30GF shutdown. Performed migatronics test and found battery to fail.


Did they replace the battery?



Also on the oil loss, look around the filler cap as this can leak a surprising amount of oil is the gasket is not set correctly.
yes they replaced the battery.
Appreciate 0
      04-20-2012, 11:22 PM   #20
OC3
Havin' a blast!
OC3's Avatar
United_States
53
Rep
4,819
Posts

 
Drives: 2013 M3 E92 Jerez Blk DCT ZCP
Join Date: Nov 2010
Location: SoCal

iTrader: (1)

Quote:
Originally Posted by StylePoints View Post
Tire rack recommended this tire size for the wheels I got. So if these are the wrong size, what size should I be running?
This should help...

http://www.1010tires.com/tiresizecalculator.asp
__________________

BRP CW13 1:56 | CVR CW 2:01 | CVR CCW 2:02 | ACS 1:53 | WSIR 1:34
2013 E92 M3 Jerez Black DCT ZCP | JRZ RS Pro | Brembo | Endless | Volk TE37 18x10.5 squared | NT01/TD/ContiGrandAm | no other mods, nor weight shavings
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:59 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST