BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
Post Reply
 
Thread Tools Search this Thread
      03-25-2012, 12:11 PM   #67
Stronghammer
Lieutenant
Stronghammer's Avatar
13
Rep
589
Posts

 
Drives: E92 M3
Join Date: May 2011
Location: south carolina

iTrader: (3)

I believe there are people on this board running a full Innotech exhaust with out a tune and no CEL. Doesn't this imply a mechanical fix ? Maybe the guys from PYSpeed could chime in they have been selling this set up for awile.
__________________
2011 E92 M3 MR July 11 ED Sept 11 PCD
Mods: ESS VT1, MS test pipes, 19 BBS CH-R, Eibach pro springs, Painted reflectors, carbon fiber grills, Painted side markers with dark tinted lenses, 30% tint, Arkym rear diffuser, Innotech axle back exhaust, Performance spoiler
Appreciate 0
      03-25-2012, 01:13 PM   #68
persian54
Lieutenant General
persian54's Avatar
United_States
283
Rep
15,809
Posts

 
Drives: SL550. Prev: E93 M3/335i/Z435i
Join Date: Jun 2009
Location: The Valley, SoCal

iTrader: (291)

Quote:
Originally Posted by Stronghammer View Post
I believe there are people on this board running a full Innotech exhaust with out a tune and no CEL. Doesn't this imply a mechanical fix ? Maybe the guys from PYSpeed could chime in they have been selling this set up for awile.
I've heard of people with that system getting a CEL too


Anyways, talontid, I appreciate you sharing what you've experienced etc, but you really helped move this thread OT....
Appreciate 0
      03-25-2012, 01:39 PM   #69
Verify
Captain
9
Rep
626
Posts

 
Drives: M3
Join Date: Mar 2012
Location: MD-NY

iTrader: (1)

we'll see

Last edited by Verify; 04-04-2013 at 01:09 PM.
Appreciate 0
      03-25-2012, 03:21 PM   #70
Zaw
Private First Class
1
Rep
102
Posts

 
Drives: 2011 E90 M3 DCT Competition
Join Date: Aug 2010
Location: Studio City, CA

iTrader: (0)

Quote:
Originally Posted by Baggy_M View Post
Word I got from bms is that the "dp fix" for the M3s is about to be released out of beta testing and should allow readiness as well. Tracking says mine will be here tomorrow and I finally got a CEL today, so ill install tomorrow and report back
Nice, I live 30miles from BMS. I may take a trip out there after you review the dp fix. I saw the install instruction on their website, I wish the install was easier. Let us know how things go.
Appreciate 0
      03-25-2012, 04:38 PM   #71
Raptor251
ESS Dreaming
Raptor251's Avatar
United_States
10
Rep
870
Posts

 
Drives: 2011.5 e92 m3/Ford Raptor 6.2
Join Date: Jan 2011
Location: San Diego

iTrader: (1)

Hey Persian I have a buddy that own a BMW service shop and he has an AutoLogic scan tool. I know it can do all the coding but I'm currently trying to find out if it has the ability to shut the rear O2's off on the S65. I would leave all other programing stock. Do you know anything about that??
Appreciate 0
      03-26-2012, 12:01 PM   #72
persian54
Lieutenant General
persian54's Avatar
United_States
283
Rep
15,809
Posts

 
Drives: SL550. Prev: E93 M3/335i/Z435i
Join Date: Jun 2009
Location: The Valley, SoCal

iTrader: (291)

Quote:
Originally Posted by Raptor251 View Post
Hey Persian I have a buddy that own a BMW service shop and he has an AutoLogic scan tool. I know it can do all the coding but I'm currently trying to find out if it has the ability to shut the rear O2's off on the S65. I would leave all other programing stock. Do you know anything about that??
Nope no idea on that.... but I've heard the AutoLogic can pretty much do "anything" so perhaps???
Appreciate 0
      03-26-2012, 12:39 PM   #73
Rekrul
Captain
Rekrul's Avatar
19
Rep
799
Posts

 
Drives: Space Gray e92 M3
Join Date: Aug 2011
Location: Purgatory

iTrader: (1)

Quote:
Originally Posted by Raptor251 View Post
Hey Persian I have a buddy that own a BMW service shop and he has an AutoLogic scan tool. I know it can do all the coding but I'm currently trying to find out if it has the ability to shut the rear O2's off on the S65. I would leave all other programing stock. Do you know anything about that??
I think Evolve has got this down. Apparently, one can now pass readiness with their tune.
Appreciate 0
      03-26-2012, 01:13 PM   #74
Malek@MRF
Brigadier General
Malek@MRF's Avatar
United_States
62
Rep
3,404
Posts

 
Drives: E92 M3, E46 M3, F30, E30
Join Date: Jan 2008
Location: Irvine, California

iTrader: (5)

Send a message via AIM to Malek@MRF
Quote:
Originally Posted by spoonf20c View Post
when you say 02 sims will not work are you referring to the bms fix the op quoted? i wanted to give it a shot because its a much cheaper solution that the akra delete-r
The BMS unit that is for the N54 motor and the advertised S65 motor is simply a voltage divider circuit with an adjustable potentiometer to vary how much of the voltage is being cut down. You can make one for a few dollars and I can show you how, however it will not work.

Unfortunately, that is not going to work on the S65 motor, as the MSS60 DME looks at more than just the output voltage of the sensor.

The MSS60 is looking for voltages on a completely stock car in the range of 0.35 volts to 0.7 volts. It is also monitoring the latency of this voltage.

The MSD80 MSD81 DME's in the N54 powered cars are strictly looking for a plausible voltage range. On the late 2009+ cars, they tightened this threshold at the factory, and hence the reason BMS released the adjustable version of their "downpipe fix" as their old one which was scaling down the voltage roughly 20% was not sufficient.

The MSS60 DME, if the voltage requirements are not satisfied, we will get the typical code for catalyst inefficiency. If signal speed is not satisfied, we will get a different SES code which can vary from a plethora of codes from signal latency, sensor being stuck, low voltage and etc.

The BMS unit is not an o2 "simulator", it is simply an o2 signal modifier.
Appreciate 0
      03-26-2012, 05:45 PM   #75
Verify
Captain
9
Rep
626
Posts

 
Drives: M3
Join Date: Mar 2012
Location: MD-NY

iTrader: (1)

huh?

Last edited by Verify; 04-04-2013 at 01:09 PM.
Appreciate 0
      03-26-2012, 05:50 PM   #76
Sean05
Putcha ang ganda...
Sean05's Avatar
Philippines
89
Rep
5,331
Posts

 
Drives: 08 MR E92 M3
Join Date: Feb 2010
Location: Los Angeles, Brea CA.

iTrader: (9)

Send a message via Yahoo to Sean05
Quote:
Originally Posted by Baggy_M View Post
Installed the BMW fix at lunch today, cleared CEL, I racked about 45 miles so far and so far so good. I'll update in a new thread after I get about 200 miles on her
what do you mean BMW fix?
Appreciate 0
      03-26-2012, 06:04 PM   #77
M3SQRD
Colonel
M3SQRD's Avatar
United_States
24
Rep
2,480
Posts

 
Drives: E92 M3s,R56 CooperS,F22 228iX
Join Date: Jun 2009
Location: EC

iTrader: (2)

Quote:
Originally Posted by Sean05 View Post
what do you mean BMW fix?
I think autocorrect was turned on - "BMW" = "BMS"
Appreciate 0
      03-26-2012, 08:16 PM   #78
Verify
Captain
9
Rep
626
Posts

 
Drives: M3
Join Date: Mar 2012
Location: MD-NY

iTrader: (1)

not sure

Last edited by Verify; 04-04-2013 at 01:10 PM.
Appreciate 0
      03-26-2012, 08:20 PM   #79
Sean05
Putcha ang ganda...
Sean05's Avatar
Philippines
89
Rep
5,331
Posts

 
Drives: 08 MR E92 M3
Join Date: Feb 2010
Location: Los Angeles, Brea CA.

iTrader: (9)

Send a message via Yahoo to Sean05
Quote:
Originally Posted by Baggy_M View Post
Yea, sorry bms fix. Trying to rack up miles now. Total about 70 so far, how long does it usually take for the CEL to come on. It was like 30 miles when I did the pipes originally
Well cel shows up from 0-whenever but if you had a cel after driving 30 miles before then i guess this works...

The guys are local to me but installation seems to be a pain
Appreciate 0
      03-26-2012, 08:54 PM   #80
Malek@MRF
Brigadier General
Malek@MRF's Avatar
United_States
62
Rep
3,404
Posts

 
Drives: E92 M3, E46 M3, F30, E30
Join Date: Jan 2008
Location: Irvine, California

iTrader: (5)

Send a message via AIM to Malek@MRF
Quote:
Originally Posted by Sean05 View Post
Well cel shows up from 0-whenever but if you had a cel after driving 30 miles before then i guess this works...

The guys are local to me but installation seems to be a pain
I have gone over 900 miles on our electronic o2 signal modifier. The codes can still come up at any given time.
Appreciate 0
      03-26-2012, 10:12 PM   #81
Verify
Captain
9
Rep
626
Posts

 
Drives: M3
Join Date: Mar 2012
Location: MD-NY

iTrader: (1)

not sure

Last edited by Verify; 04-04-2013 at 01:10 PM.
Appreciate 0
      03-27-2012, 01:19 PM   #82
Verify
Captain
9
Rep
626
Posts

 
Drives: M3
Join Date: Mar 2012
Location: MD-NY

iTrader: (1)

not sure

Last edited by Verify; 04-04-2013 at 01:10 PM.
Appreciate 0
      03-27-2012, 04:22 PM   #83
persian54
Lieutenant General
persian54's Avatar
United_States
283
Rep
15,809
Posts

 
Drives: SL550. Prev: E93 M3/335i/Z435i
Join Date: Jun 2009
Location: The Valley, SoCal

iTrader: (291)

Quote:
Originally Posted by Baggy_M View Post
120 miles so far, no codes, no CEL. I think its doing its job just fine
let us know when you get over 1k
Appreciate 0
      03-27-2012, 06:20 PM   #84
Verify
Captain
9
Rep
626
Posts

 
Drives: M3
Join Date: Mar 2012
Location: MD-NY

iTrader: (1)

That will probably take some time lol

Last edited by Verify; 04-04-2013 at 01:35 PM.
Appreciate 0
      03-27-2012, 07:07 PM   #85
scalbert
Major General
scalbert's Avatar
78
Rep
5,710
Posts

 
Drives: '08 E90 M3, '13 Volt, '08 Ody
Join Date: Feb 2007
Location: Woodstock, GA

iTrader: (7)

Also check that all Readiness tests have cleared. While many think they are not getting codes, they are also not passing all OBDII tests. As such, many will not pass local emissions tests.
Appreciate 0
      03-27-2012, 07:55 PM   #86
Malek@MRF
Brigadier General
Malek@MRF's Avatar
United_States
62
Rep
3,404
Posts

 
Drives: E92 M3, E46 M3, F30, E30
Join Date: Jan 2008
Location: Irvine, California

iTrader: (5)

Send a message via AIM to Malek@MRF
Quote:
Originally Posted by scalbert View Post
Also check that all Readiness tests have cleared. While many think they are not getting codes, they are also not passing all OBDII tests. As such, many will not pass local emissions tests.
Exactly. The catalyst monitors are still probably incomplete, hence the reason these cars are not getting codes yet.

Sometimes these monitors can take a very long time to complete.

Usually the monitors that take the longest to complete are the catalyst and EVAP monitors.
Appreciate 0
      03-27-2012, 08:51 PM   #87
Verify
Captain
9
Rep
626
Posts

 
Drives: M3
Join Date: Mar 2012
Location: MD-NY

iTrader: (1)

How can I check all that? I just went to an autozone and had them clear the cel after I installed the fix
Appreciate 0
      03-27-2012, 09:32 PM   #88
kitw
Colonel
kitw's Avatar
61
Rep
2,630
Posts

 
Drives: 2015 MW M3/2014 Boxster S
Join Date: Jun 2007
Location: Bay Area, CA

iTrader: (14)

Quote:
Originally Posted by Baggy_M View Post
How can I check all that? I just went to an autozone and had them clear the cel after I installed the fix
Any OBD-II reader will tell you the readiness status.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:15 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST