BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > General M3 Forum (E90 + E92 + E93)
 
Steve Thomas BMW
Post Reply
 
Thread Tools Search this Thread
      03-21-2012, 10:08 PM   #1
zhangzeyuandss
Captain
zhangzeyuandss's Avatar
United_States
12
Rep
900
Posts

 
Drives: 2011 e92 MW m3
Join Date: Oct 2009
Location: Indianapolis,IN

iTrader: (9)

Send a message via AIM to zhangzeyuandss Send a message via MSN to zhangzeyuandss Send a message via Yahoo to zhangzeyuandss Send a message via Skype™ to zhangzeyuandss
Limp mode need help!!

I was driving down the road and stopped at a light. The car started shaking and the SES light came on and idrive said something about reduced power increased emission. I remembered read it somewhere on the forum about faulty idle control valve. But I thought I was in the clear since this is a 2011.5. For the record, I have never used the stop and start function at all. Here is some pictures. Hopefully anyone who had the same experience could chime in and tell me if it was actually the idle valve problem.



__________________

2011.5 mineral white e92 zcp 6mt m3
Appreciate 0
      03-21-2012, 10:20 PM   #2
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,121
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
You'll need to check the codes. The lights don't tell us specifics.
__________________
Appreciate 0
      03-22-2012, 10:48 AM   #3
brava09
Captain
brava09's Avatar
12
Rep
728
Posts

 
Drives: '11 Audi RS5
Join Date: Nov 2009
Location: Europe

iTrader: (0)

It happened to me and the problem was about the induction coil on cylinder #2.

Replaced it and all is good now.
__________________
11 Audi RS5 Misano Red
08 E92 M3 Jerez Black 6MT--sold
08 E92 335i 6MT traded in for M3
Appreciate 0
      03-22-2012, 11:09 AM   #4
ham96
Enlisted Member
0
Rep
33
Posts

 
Drives: jetblack e92 M3
Join Date: Sep 2010
Location: OC

iTrader: (0)

Hey I remember all those error lights. Took the dealer a while to figure out but it ended up being a faulty vacuum pump. That was replaced and the car has been great ever since.
Appreciate 0
      03-22-2012, 11:20 AM   #5
SROC5
Addicted to Track
SROC5's Avatar
United_States
29
Rep
1,647
Posts

 
Drives: E92 M3
Join Date: Apr 2009
Location: USCON

iTrader: (3)

separately, nice M perf. steering wheel!
__________________

| Akrapovic Evo | ESSi | Swift Spec-R | CF Spoiler | APEX ARC-8 | RS-3 | PFC-08 | DIF |
Appreciate 0
      03-22-2012, 11:56 AM   #6
mdosu
Banned
No_Country
119
Rep
8,517
Posts

 
Drives: Double Vanos'd Civic-M3
Join Date: Oct 2009
Location: San Francisco

iTrader: (6)

this could be many things ranging from idle air control valve to ignition coil, misfire, or bent or stuck valve stems. Those are the most common issues we've seen.

Please do keep us updated OP, good luck.
Appreciate 0
      03-22-2012, 12:16 PM   #7
Giccy
Captain
Giccy's Avatar
Canada
10
Rep
683
Posts

 
Drives: like he has much to learn
Join Date: Oct 2011
Location: Toronto

iTrader: (1)

Just happened to me the other day (idle control valve) and mine is a 2011.75.

Was replaced and works fine, all within 24 hours.

Just take it to the dealer and you should be fine.
Appreciate 0
      03-22-2012, 12:17 PM   #8
orion565
Second Lieutenant
orion565's Avatar
2
Rep
205
Posts

 
Drives: 2011 e92 m3
Join Date: Apr 2011
Location: Downtown Houston

iTrader: (2)

I have had it happen to me at the track and all I did was turn off the car waited a couple minutes turned it back on and it never came back on, would be the easiest option for now.
Appreciate 0
      03-22-2012, 06:10 PM   #9
zhangzeyuandss
Captain
zhangzeyuandss's Avatar
United_States
12
Rep
900
Posts

 
Drives: 2011 e92 MW m3
Join Date: Oct 2009
Location: Indianapolis,IN

iTrader: (9)

Send a message via AIM to zhangzeyuandss Send a message via MSN to zhangzeyuandss Send a message via Yahoo to zhangzeyuandss Send a message via Skype™ to zhangzeyuandss
Quote:
Originally Posted by brava09
It happened to me and the problem was about the induction coil on cylinder #2.

Replaced it and all is good now.
I just came back from the dealership. Tech pull out the scanner. The code was misfire on cylinder 2. They clear the code and let me go. Say if it happened again just come back if it were #2 again. They will act on it.
__________________

2011.5 mineral white e92 zcp 6mt m3
Appreciate 0
      03-22-2012, 06:11 PM   #10
zhangzeyuandss
Captain
zhangzeyuandss's Avatar
United_States
12
Rep
900
Posts

 
Drives: 2011 e92 MW m3
Join Date: Oct 2009
Location: Indianapolis,IN

iTrader: (9)

Send a message via AIM to zhangzeyuandss Send a message via MSN to zhangzeyuandss Send a message via Yahoo to zhangzeyuandss Send a message via Skype™ to zhangzeyuandss
Quote:
Originally Posted by SROC5
separately, nice M perf. steering wheel!
Thanks installed myself took a lot of time to figure out the wiring for power.
__________________

2011.5 mineral white e92 zcp 6mt m3
Appreciate 0
      03-22-2012, 08:20 PM   #11
IFX
Banned
32
Rep
2,538
Posts

 
Drives: AW e46M/N54
Join Date: Jan 2009
Location: South Fla.

iTrader: (1)

Quote:
Originally Posted by zhangzeyuandss View Post
I just came back from the dealership. Tech pull out the scanner. The code was misfire on cylinder 2. They clear the code and let me go. Say if it happened again just come back if it were #2 again. They will act on it.


I don't get it, if it's misfiring doesn't it mean it's bad?

Why didn't they just change it right there and then?

Or am I missing something?
Appreciate 0
      03-22-2012, 08:57 PM   #12
nasa60
Private First Class
nasa60's Avatar
1
Rep
160
Posts

 
Drives: 2008 M3 Sedan
Join Date: Feb 2008
Location: Alabama

iTrader: (0)

Interesting, I had the same valve icon this week but the words on idrive were Fuel Pump failure. Took it in and they replaced the fuel pump controller.
__________________
--------------------------------------------------
2008 M3 Sedan, Silverstone, Fox Red Extended, Carbon Leather Trim
Appreciate 0
      03-22-2012, 09:34 PM   #13
Singletrack
4th down; 4th quarter? Renegade.
Singletrack's Avatar
United_States
43
Rep
3,820
Posts

 
Drives: 09 SSII E92 M3; 12 AW X5d
Join Date: Aug 2008
Location: Pittsburgh, PA

iTrader: (3)

Quote:
Originally Posted by IFX View Post
I don't get it, if it's misfiring doesn't it mean it's bad?

Why didn't they just change it right there and then?

Or am I missing something?
Only misfired one time, not actively...

So what are they going to change? Spark plug? Coil? ECM? Other?

Could just be a bad tank of gas...

I would have done the same personally - just not enough data to draw any conclusions.
Appreciate 0
      03-22-2012, 09:42 PM   #14
mdosu
Banned
No_Country
119
Rep
8,517
Posts

 
Drives: Double Vanos'd Civic-M3
Join Date: Oct 2009
Location: San Francisco

iTrader: (6)

Quote:
Originally Posted by zhangzeyuandss View Post
I just came back from the dealership. Tech pull out the scanner. The code was misfire on cylinder 2. They clear the code and let me go. Say if it happened again just come back if it were #2 again. They will act on it.
dodged a big one then, no harm no foul
Appreciate 0
      03-22-2012, 09:51 PM   #15
HlydeDaue
New Member
0
Rep
8
Posts

 
Drives: audio
Join Date: Mar 2012
Location: tty

iTrader: (0)

Took the dealer a while to figure out but it ended up being a faulty vacuum pump
__________________
Appreciate 0
      03-22-2012, 09:53 PM   #16
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,121
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
This would have been a good time to own a code reader. Save you from hassles like this.
__________________
Appreciate 0
      03-22-2012, 10:26 PM   #17
PKE90
Private First Class
PKE90's Avatar
5
Rep
107
Posts

 
Drives: 2013 X5 Diesel
Join Date: Mar 2007
Location: Fairfield, CT

iTrader: (2)

Quote:
Originally Posted by zhangzeyuandss View Post
I was driving down the road and stopped at a light. The car started shaking and the SES light came on and idrive said something about reduced power increased emission. I remembered read it somewhere on the forum about faulty idle control valve. But I thought I was in the clear since this is a 2011.5. For the record, I have never used the stop and start function at all. Here is some pictures. Hopefully anyone who had the same experience could chime in and tell me if it was actually the idle valve problem.




Happened two months ago. Bad ignition coil on cylinder 8. Was rough with reduced power. Drove it to the dealer (gently). Got a loaner. Half a day later, all good.
__________________

Current: 13 X5 Diesel, 991 Carrera S 50th Anniversary Edition

Gone: 11 E90 M3 ZCP, 07 328i ZSP, 05 330i ZHP, 04 996 GT3, 02 525iA, 02 996 C2, 01 Boxster S
Appreciate 0
      03-23-2012, 12:29 PM   #18
zhangzeyuandss
Captain
zhangzeyuandss's Avatar
United_States
12
Rep
900
Posts

 
Drives: 2011 e92 MW m3
Join Date: Oct 2009
Location: Indianapolis,IN

iTrader: (9)

Send a message via AIM to zhangzeyuandss Send a message via MSN to zhangzeyuandss Send a message via Yahoo to zhangzeyuandss Send a message via Skype™ to zhangzeyuandss
Quote:
Originally Posted by THE TECH
This would have been a good time to own a code reader. Save you from hassles like this.
Yeah. I am thinking about it. Any recommendation on a good code reader that can read BMW codes
__________________

2011.5 mineral white e92 zcp 6mt m3
Appreciate 0
      03-23-2012, 12:30 PM   #19
zhangzeyuandss
Captain
zhangzeyuandss's Avatar
United_States
12
Rep
900
Posts

 
Drives: 2011 e92 MW m3
Join Date: Oct 2009
Location: Indianapolis,IN

iTrader: (9)

Send a message via AIM to zhangzeyuandss Send a message via MSN to zhangzeyuandss Send a message via Yahoo to zhangzeyuandss Send a message via Skype™ to zhangzeyuandss
Quote:
Originally Posted by mdosu
Quote:
Originally Posted by zhangzeyuandss View Post
I just came back from the dealership. Tech pull out the scanner. The code was misfire on cylinder 2. They clear the code and let me go. Say if it happened again just come back if it were #2 again. They will act on it.
dodged a big one then, no harm no foul
Yep. I am just glad it wasn't the valve problem.
__________________

2011.5 mineral white e92 zcp 6mt m3
Appreciate 0
      03-23-2012, 01:07 PM   #20
SD-E93-11
First Lieutenant
United_States
3
Rep
324
Posts

 
Drives: 2011 E93 M3 Jerez Black/Black
Join Date: Sep 2011
Location: San Diego, CA

iTrader: (0)

Quote:
Originally Posted by zhangzeyuandss View Post
Limp mode need help!
Both Pfizer and Eli Lilly have developed drugs that fix this.
Appreciate 0
      03-23-2012, 01:27 PM   #21
saeedg48
Brigadier General
Iran
133
Rep
3,499
Posts

 
Drives: 12 CLS63 + 14 M6 C
Join Date: Nov 2008
Location: Unknown

iTrader: (1)

idle valve?
__________________


2008 M3 Sedan + TestPipes + Tune [sold]

2012 CLS63 AMG + P30 Performance Package
2014 M6 Coupe + AMS Downpipes + KW V3
Appreciate 0
      03-27-2012, 12:59 AM   #22
Zzhou
Lieutenant
Zzhou's Avatar
6
Rep
529
Posts

 
Drives: 2012 E92 SSII ZCP DCT
Join Date: Aug 2011
Location: West Lafayette,IN/Shanghai,China

iTrader: (0)

Quote:
Originally Posted by zhangzeyuandss View Post
Yeah. I am thinking about it. Any recommendation on a good code reader that can read BMW codes
任何code reader都可以,我上次弄CEL的时候买了个,你需要可以找我啊~~Glad to see nothing serious happened. 也许你开的太快了~哈哈
__________________

AA Green Filter/AA Pulley/AA catless X-pipes/AA signature exhaust/AA TUNE/TMS studs/Project Kics R40/AD08/Vorsteiner GTS5 Bumper/LUX H8
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:01 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST