BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
ESS Tuning
Post Reply
 
Thread Tools Search this Thread
      03-10-2012, 02:52 AM   #1
aresh
First Lieutenant
 
Drives: 2006 550i
Join Date: May 2009
Location: NY

Posts: 370
iTrader: (1)

Thumbs down No Sound Or Screen, Dealer Sucks!

I recently lost sound and my screen went blank on my idrive screen. I have the CCC, i went to the dealer only for them to tell me it was the CCC and screen thats gone bad. I replaced it with the CIC unit and i still have no sound or screen. Whats going on?? someone have any idea? could it be possible that i ruined the digital cable (green and black) by possibly twisting it? I have the individual sound system btw
aresh is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:04 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST