BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Suspension | Brakes | Chassis
 
Race Precision Motorsport
Post Reply
 
Thread Tools Search this Thread
      07-08-2011, 03:31 PM   #1
GirlsGarage
First Lieutenant
 
GirlsGarage's Avatar
 
Drives: E92 M3 DCT
Join Date: Feb 2010
Location: AE

Posts: 306
iTrader: (3)

EDC error :mad0259:

Hi Guyz,

installed Eibach springs on my 09 M3 DCT coupe 2 days back, droved the car for 300 Miles and then Dynamic Damping Control error massage poped up as shown below

Double checked all wiring and EDC module plug on top the dampers and everything looks good and properly sit!!

Any Thoughts??!
Attached Images
 
GirlsGarage is offline  
0
Reply With Quote
      07-08-2011, 07:39 PM   #2
persian54
Lieutenant General
 
persian54's Avatar
 
Drives: SL550. Prev: E93 M3/335i/Z435i
Join Date: Jun 2009
Location: The Valley, SoCal

Posts: 15,667
iTrader: (282)

put it back to stock and see if it fixes the issue. if not, then stay stock and go to the dealer
persian54 is offline   United_States
0
Reply With Quote
      07-08-2011, 07:46 PM   #3
saeedg48
Brigadier General
 
Drives: 12 CLS63 + 14 M6 C
Join Date: Nov 2008
Location: Unknown

Posts: 3,500
iTrader: (1)

Quote:
Originally Posted by persian54 View Post
put it back to stock and see if it fixes the issue. if not, then stay stock and go to the dealer
this
__________________


2008 M3 Sedan + TestPipes + Tune [sold]

2012 CLS63 AMG + P30 Performance Package
2014 M6 Coupe + AMS Downpipes + KW V3
saeedg48 is offline   Iran
0
Reply With Quote
      07-08-2011, 09:45 PM   #4
E92_carbonm3
Second Lieutenant
 
Drives: E92 m3
Join Date: Jul 2011
Location: Allentown, pa

Posts: 221
iTrader: (3)

Quote:
Originally Posted by persian54 View Post
put it back to stock and see if it fixes the issue. if not, then stay stock and go to the dealer
+1, that sucks i have the pro kit and didnt have any problems.. hope
E92_carbonm3 is offline  
0
Reply With Quote
      07-09-2011, 03:57 AM   #5
GirlsGarage
First Lieutenant
 
GirlsGarage's Avatar
 
Drives: E92 M3 DCT
Join Date: Feb 2010
Location: AE

Posts: 306
iTrader: (3)

UPDATE:

Hit the start button this morning and drove the car DID NOT see the error massage!!
Car was fine untill I came across 3 humps and the Error massage poped up again after the 3rd hump!!
GirlsGarage is offline  
0
Reply With Quote
      07-09-2011, 05:40 AM   #6
LarThaL
Colonel
 
LarThaL's Avatar
 
Drives: 2011 M3
Join Date: Apr 2011
Location: West Springfield, MA

Posts: 2,374
iTrader: (0)

Quote:
Originally Posted by M3sexMT View Post
Hi Guyz,

installed Eibach springs on my 09 M3 DCT coupe 2 days back, droved the car for 300 Miles and then Dynamic Damping Control error massage poped up as shown below

Double checked all wiring and EDC module plug on top the dampers and everything looks good and properly sit!!

Any Thoughts??!
Welcome to the world of modding !! Basically it sounds like the springs rates are out of spec are for the shocks. You might try seeing if you get the message on all EDC settings or only on certain settings. You may have to drive only in one particular mode. There may not actually be anything "wrong" here. The car's brain may only think there is something wrong due to your altered spring rates. Much like HFC's generating check engine lights. Of course, I am not certain how it will affect the life of your shocks, however. How does the car ride/drive? Does it feel weird or handle badly?

Anyway....first place to start is to see if you get the message in all EDC modes or not.

That said, I would never simply change out the springs on an EDC system. And keep in mind, in general, the more complex, the more integrated, and the more electronics that are involved, the more you run into the risk of problems.
__________________
Precision tool: 2011 BMW ///M3
Sledgehammer: 2014 Audi S6

LarThaL is offline  
0
Reply With Quote
      07-09-2011, 06:05 AM   #7
GirlsGarage
First Lieutenant
 
GirlsGarage's Avatar
 
Drives: E92 M3 DCT
Join Date: Feb 2010
Location: AE

Posts: 306
iTrader: (3)

Quote:
Originally Posted by VVG View Post
Welcome to the world of modding !! Basically it sounds like the springs rates are out of spec are for the shocks. You might try seeing if you get the message on all EDC settings or only on certain settings. You may have to drive only in one particular mode. There may not actually be anything "wrong" here. The car's brain may only think there is something wrong due to your altered spring rates. Much like HFC's generating check engine lights. Of course, I am not certain how it will affect the life of your shocks, however. How does the car ride/drive? Does it feel weird or handle badly?

Anyway....first place to start is to see if you get the message in all EDC modes or not.

That said, I would never simply change out the springs on an EDC system. And keep in mind, in general, the more complex, the more integrated, and the more electronics that are involved, the more you run into the risk of problems.
-Comfort and normal mode is fine, massage appears on the sport mode!
-The ride is stiffer now.

I think when you change the springs the only difference would be compressing the shocks by approximately an inch more than the stock rate! and this should not throw an error massage i beleive since rebound factor is still there!!!
GirlsGarage is offline  
0
Reply With Quote
      07-11-2011, 12:20 AM   #8
Technic
Lieutenant General
 
Technic's Avatar
 
Drives: 2012 E92 M3, 2014 528i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

Posts: 10,568
iTrader: (15)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by M3sexMT View Post
-Comfort and normal mode is fine, massage appears on the sport mode!
-The ride is stiffer now.

I think when you change the springs the only difference would be compressing the shocks by approximately an inch more than the stock rate! and this should not throw an error massage i beleive since rebound factor is still there!!!
Double check the front shocks EDC OEM connectors, please. I bet that one -or both of them- is defective, either by your install or simply the stiffer ride of the Sport mode is increasing the stress (by shock and vibration) to the connectors, thus the disconnection thus error prompt.
__________________
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: September ED
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
-2002 E46 330i Orient Blue/Natural Brown, 5MT: Gone
Technic is offline   United_States
0
Reply With Quote
      07-11-2011, 03:04 AM   #9
GirlsGarage
First Lieutenant
 
GirlsGarage's Avatar
 
Drives: E92 M3 DCT
Join Date: Feb 2010
Location: AE

Posts: 306
iTrader: (3)

Mmmm

Car is fine now, no error!! Not sure if its lasting long error free!
GirlsGarage is offline  
0
Reply With Quote
      07-11-2011, 11:43 AM   #10
LiM3y
Major
 
LiM3y's Avatar
 
Drives: 2008 E90 M3
Join Date: Jun 2009
Location: CT

Posts: 1,139
iTrader: (2)

I think you might have a bad EDC shock. I had this after 400 miles. Since then, I have installed Eibach's and had no problems.
__________________
LiM3y is offline   United Kingdom
0
Reply With Quote
      07-14-2011, 07:48 PM   #11
GirlsGarage
First Lieutenant
 
GirlsGarage's Avatar
 
Drives: E92 M3 DCT
Join Date: Feb 2010
Location: AE

Posts: 306
iTrader: (3)

Ride is perfect now, front right spring was not sitting preperly

Very happy with Eibachs
GirlsGarage is offline  
0
Reply With Quote
      02-08-2012, 02:00 AM   #12
Endless619
DHS
 
Endless619's Avatar
 
Drives: bmw x5, m3, Acura TL
Join Date: Oct 2010
Location: Disneyland

Posts: 3,892
iTrader: (14)

Sorry to revive but have a quick question which I probably already know the answer too..

So I take it this is the same message some of us will get with running H&R suspension kit on an EDC car without the EDC modules? IE meaning error message is shown but nothing is actually wrong with your suspension. Similar to not having TPMS sensors on your aftermarket wheels. Light comes up, but means nothing. This is what I am taking from this, since member still drove with no issues.
Endless619 is offline   Spain
0
Reply With Quote
      02-08-2012, 02:25 AM   #13
Richard@M-World
 
Richard@M-World's Avatar
 
Drives: NASA TTA #92 M3
Join Date: May 2011
Location: TX/IL

Posts: 683
iTrader: (0)

Quote:
Originally Posted by EndlessZ4M View Post
Sorry to revive but have a quick question which I probably already know the answer too..

So I take it this is the same message some of us will get with running H&R suspension kit on an EDC car without the EDC modules? IE meaning error message is shown but nothing is actually wrong with your suspension. Similar to not having TPMS sensors on your aftermarket wheels. Light comes up, but means nothing. This is what I am taking from this, since member still drove with no issues.
With aftermarket springs (H&R, Eibach, Dinan, etc.), since they still utilize the factory shocks, you should not be getting any error messages, unless there is a loose plug, etc.

Only when you remove the factory shocks, i.e. KW Clubsport, will you need the EDC cancellation module to eliminate EDC error.
__________________
Authorized AiM Dealer - Solo/Solo DL | SmartyCam HD | www.m-world.us
Richard@M-World is offline   United_States
0
Reply With Quote
      02-08-2012, 02:28 AM   #14
Endless619
DHS
 
Endless619's Avatar
 
Drives: bmw x5, m3, Acura TL
Join Date: Oct 2010
Location: Disneyland

Posts: 3,892
iTrader: (14)

Quote:
Originally Posted by Richard@M-World View Post
With aftermarket springs (H&R, Eibach, Dinan, etc.), since they still utilize the factory shocks, you should not be getting any error messages, unless there is a loose plug, etc.

Only when you remove the factory shocks, i.e. KW Clubsport, will you need the EDC cancellation module to eliminate EDC error.
Not talking about just springs. I have those and no issues there but switching back to H&R coilovers and really don't want to spend another $300 on the EDC cancellation modules right now. I can run it for a few months without I am assuming. I can care less about a simple error light.

What if you don't care about EDC error? Means nothing right? You don't actually need the EDC cancellation module since in reality there is nothing wrong with the H&R coilovers or KW V3s or whatever suspension you're running, correct?
Endless619 is offline   Spain
0
Reply With Quote
      02-08-2012, 10:10 AM   #15
Richard@M-World
 
Richard@M-World's Avatar
 
Drives: NASA TTA #92 M3
Join Date: May 2011
Location: TX/IL

Posts: 683
iTrader: (0)

^correct.
__________________
Authorized AiM Dealer - Solo/Solo DL | SmartyCam HD | www.m-world.us
Richard@M-World is offline   United_States
0
Reply With Quote
      02-08-2012, 10:32 AM   #16
KennyPowers
Brigadier General
 
Drives: .....
Join Date: Oct 2010
Location: Gulf Coast

Posts: 3,387
iTrader: (13)

Quote:
Originally Posted by VVG View Post
Welcome to the world of modding !! Basically it sounds like the springs rates are out of spec are for the shocks. You might try seeing if you get the message on all EDC settings or only on certain settings. You may have to drive only in one particular mode. There may not actually be anything "wrong" here. The car's brain may only think there is something wrong due to your altered spring rates. Much like HFC's generating check engine lights. Of course, I am not certain how it will affect the life of your shocks, however. How does the car ride/drive? Does it feel weird or handle badly?

Anyway....first place to start is to see if you get the message in all EDC modes or not.

That said, I would never simply change out the springs on an EDC system. And keep in mind, in general, the more complex, the more integrated, and the more electronics that are involved, the more you run into the risk of problems.
Im sorry, but what?

Im not sure that you understand how EDC functions. It has nothing to do with, and is independant of spring rates. It is very simply an electronic connection that enables you to change the characteristics of the compression and rebound of the shocks / struts by pressing a button in your car.

The only way an error message could occur is that A ) a connection was screwed up in the wiring or B ) something internally on one of the shocks / struts was damaged.

The pothole could have made sense by jarring the wiring possibly.

HFC's generate check engine lights because they change the amount of emissions post cat to rates that are higher than factory tolerances. Just like a cat delete would, or the same thing that would happen if you just unplugged your o2 sensors altogether.
__________________
2009 AW E92 M3 DCT

M359 ZCP wheels w/ AD08R / OEM Competition Package Suspension Retrofit / LCI Taillights
KennyPowers is offline  
0
Reply With Quote
      02-08-2012, 10:21 PM   #17
Endless619
DHS
 
Endless619's Avatar
 
Drives: bmw x5, m3, Acura TL
Join Date: Oct 2010
Location: Disneyland

Posts: 3,892
iTrader: (14)

Quote:
Originally Posted by Richard@M-World View Post
^correct.
Thanks Richard. Thats what I thought but wanted to hear it from some of you.
Endless619 is offline   Spain
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:39 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST