BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
GT Haus
Post Reply
 
Thread Tools Search this Thread
      01-09-2012, 05:23 PM   #1
ILSMKU
BMW FTW
ILSMKU's Avatar
No_Country
33
Rep
1,888
Posts

 
Drives: E92 M3
Join Date: Jul 2011
Location: ///OC

iTrader: (5)

Garage List
aFe Drop in filter with scoop flutter sound?

Hey all,

I recently installed an aFe drop in filter (dry one) and scoops. I made sure to install my intake cover the exact way it came off. I had already read about how to install the filter and saw many posts of guys who did not seat the cover back on correctly. My cover is on correctly.

That said, I now hear a funky flutter sound between 3-4K that does not sound normal to me. I also noticed that the top of the aFe dry filter (that the spring loaded nipped presses against) seems flimsy.


A buddy of mine has a K&N filter and he said he doesnt have any flutter sounds with his at all. Ive seen a few posts in here saying its normal. Or somethings on my cover is not sealed, and others say its just how this filter sounds.

Any one have any experience with this? At this point, Im not to thrilled with this piece at all.
__________________
///2013 AW 6MT E92 ZCP M3/// Black 359M Wheels/BMW Performance Carbon Fiber Spoiler and Mirror Caps/Arkym AeroSport Front Lip/Turner 15MM Spacers/LUX 8 LED Halo/IND Gloss Black Grills, Gills and M3 Emblem/30% 3M Tint/BMW Interior LED/MusicCar Subwoofer Enclosure/JL Audio 12" W6 Sub and XD600:1 Amp/Euro Sunglasses Tray/Ceramic Coated Megan Racing Exhaust/AFe Dry Air Filter/RPI Intake Scoops/Euro MDM/Feature Coded.
Appreciate 0
      01-09-2012, 06:51 PM   #2
binz135
New Member
binz135's Avatar
Taiwan
0
Rep
12
Posts

 
Drives: 135I with COBB !
Join Date: May 2011
Location: Taiwan

iTrader: (0)

I suspect that you have purchased wrong model year of AFE filter ! Yours M3 is newer model from 09~now ! The filter on TOP is different.
Appreciate 0
      01-10-2012, 11:44 AM   #3
ILSMKU
BMW FTW
ILSMKU's Avatar
No_Country
33
Rep
1,888
Posts

 
Drives: E92 M3
Join Date: Jul 2011
Location: ///OC

iTrader: (5)

Garage List
Thanks, but nope. I got the correct part for the 2011. Mine was a kit. filter and scoops for the 11.
__________________
///2013 AW 6MT E92 ZCP M3/// Black 359M Wheels/BMW Performance Carbon Fiber Spoiler and Mirror Caps/Arkym AeroSport Front Lip/Turner 15MM Spacers/LUX 8 LED Halo/IND Gloss Black Grills, Gills and M3 Emblem/30% 3M Tint/BMW Interior LED/MusicCar Subwoofer Enclosure/JL Audio 12" W6 Sub and XD600:1 Amp/Euro Sunglasses Tray/Ceramic Coated Megan Racing Exhaust/AFe Dry Air Filter/RPI Intake Scoops/Euro MDM/Feature Coded.
Appreciate 0
      01-10-2012, 12:19 PM   #4
kitw
Colonel
kitw's Avatar
60
Rep
2,627
Posts

 
Drives: 2015 MW M3/2014 Boxster S
Join Date: Jun 2007
Location: Bay Area, CA

iTrader: (14)

My AFE didn't do this. Take a picture and post it, even though you may have ordered the right one, you might not have the right one
__________________

IMG_4631 by kitwetzler, on Flickr
Appreciate 0
      01-10-2012, 12:22 PM   #5
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,122
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
I've used the AFE stuff on other vehicles and never have been impressed by their quality or their power claims.
__________________
Appreciate 0
      01-10-2012, 01:04 PM   #6
ModBargains III
Lieutenant
United_States
4
Rep
423
Posts

 
Drives: E92 335i, 135i, E46 M3, 540i
Join Date: Sep 2011
Location: 1721 E. Lambert Rd. Unit C, 90631 La Habra, CA

iTrader: (0)

The only instances where I've heard of an intake fluttering, regardless if it was aFe or not, was if you either A. Installed the incorrect filter from the wrong year (as mentioned), or if the top of the intake cover wasn't installed correctly, or torqued down to the right spec to avoid any air getting in from the seems. Other than that, there shouldn't be a problem, so I would check, and double check to make sure there aren't any seems that are open that shouldn't be open.

Best Regards,
__________________
Appreciate 0
      01-10-2012, 01:18 PM   #7
tom @ eas
BimmerPost Supporting Vendor
tom @ eas's Avatar
United_States
324
Rep
10,614
Posts


 
Drives: BMW
Join Date: Nov 2005
Location: Anaheim, CA

iTrader: (13)

Garage List
Quote:
Originally Posted by ILSMKU View Post
Hey all,

I recently installed an aFe drop in filter (dry one) and scoops. I made sure to install my intake cover the exact way it came off. I had already read about how to install the filter and saw many posts of guys who did not seat the cover back on correctly. My cover is on correctly.

That said, I now hear a funky flutter sound between 3-4K that does not sound normal to me. I also noticed that the top of the aFe dry filter (that the spring loaded nipped presses against) seems flimsy.


A buddy of mine has a K&N filter and he said he doesnt have any flutter sounds with his at all. Ive seen a few posts in here saying its normal. Or somethings on my cover is not sealed, and others say its just how this filter sounds.

Any one have any experience with this? At this point, Im not to thrilled with this piece at all.
If you are in the Anaheim area anytime soon, feel free to drop by and we can take a look for you and verify correct installation.
__________________
Appreciate 0
      01-10-2012, 02:21 PM   #8
DylanMckay
Banned
2
Rep
122
Posts

 
Drives: e92 m3
Join Date: Jan 2012
Location: armpit of the USA

iTrader: (0)

This is actually normal with the high flow filters on this car. Some others describe the sound with different adjectives but in essense it is the ITB and vanos chatter that resonates at certain RPM's which is the loudest at 3-4.5k. The reason you do not hear it with OEM filter is it is more restrictive and keeps more sound out.

Some call this a "rattle" as well. As long as you do not mind it there is nothing wrong with the filter or install. IMO I think it is worth the sound it makes after 4k but some do not agree.

Good luck!
Appreciate 0
      01-10-2012, 06:35 PM   #9
GIdriver
Major
GIdriver's Avatar
United_States
17
Rep
1,342
Posts

 
Drives: 2014 E63 AMG-S
Join Date: Dec 2010
Location: Somewhere in Time

iTrader: (0)

Quote:
Originally Posted by DylanMckay View Post
This is actually normal with the high flow filters on this car. Some others describe the sound with different adjectives but in essense it is the ITB and vanos chatter that resonates at certain RPM's which is the loudest at 3-4.5k. The reason you do not hear it with OEM filter is it is more restrictive and keeps more sound out.

Some call this a "rattle" as well. As long as you do not mind it there is nothing wrong with the filter or install. IMO I think it is worth the sound it makes after 4k but some do not agree.

Good luck!
^ This. Even with the OEM filter, in the lower gears (e.g. 3rd gear), when you accelerate (but not WOT), if you listen very very carefully (AC off, radio off, etc), you can hear it. Very distantly, but is there.
Appreciate 0
      01-10-2012, 11:58 PM   #10
Mike Benvo
BimmerPost Supporting Vendor
Mike Benvo's Avatar
United_States
96
Rep
4,798
Posts


 
Drives: Harrop SC M3 / E46 M3 / 7Turbo
Join Date: Apr 2008
Location: SoCal

iTrader: (7)

Garage List
2008 BMW M3  [5.00]
1990 BMW 735i Turbo  [5.00]
2004 BMW M3  [0.00]
Send a message via Skype™ to Mike Benvo
Totally normal from my experience. I had the same thing with my AFE intake mainly between 3,200 and 3,700 RPM - it's like a crazy resonance sound.

I'd have to hear it but initial gut feeling says its normal.
__________________

-----| Like us on Facebook | Instagram || Tuning Information | Remote Coding |-----
----Visit us at www.BPMSport.com - Emotion. Driven. | Toll Free: (888) 557-5133----
Appreciate 0
      01-11-2012, 07:38 PM   #11
sard
Major
81
Rep
1,330
Posts

 
Drives: 2008 M3
Join Date: Oct 2008
Location: Southern California

iTrader: (1)

Send a message via AIM to sard
My BMC does it.. sounds like shit .. oh and the Macht Schnell did it also... I'm guessing it's normal
__________________

E92 M3 - DCT - 20" BBS LM-R - KW Clubsport - Akrapovic Exhaust - Powerchip Tune - Arkym Aero Kit - HID Halo

Last edited by sard; 01-11-2012 at 07:54 PM.
Appreciate 0
      01-12-2012, 01:48 PM   #12
ILSMKU
BMW FTW
ILSMKU's Avatar
No_Country
33
Rep
1,888
Posts

 
Drives: E92 M3
Join Date: Jul 2011
Location: ///OC

iTrader: (5)

Garage List
Quote:
Originally Posted by **********s III View Post
The only instances where I've heard of an intake fluttering, regardless if it was aFe or not, was if you either A. Installed the incorrect filter from the wrong year (as mentioned), or if the top of the intake cover wasn't installed correctly, or torqued down to the right spec to avoid any air getting in from the seems. Other than that, there shouldn't be a problem, so I would check, and double check to make sure there aren't any seems that are open that shouldn't be open.

Best Regards,
Thanks, But I dont hear this on my stock filter, or my buddies K&N. I tried it, heard it, opened it up, removed it, replaced it, tried again, same sound. Put my friends K&N on, and it sounded normal. I then put my stock back on and I dont hear anything. The filter in the package is the labeled with a PN that is what Af3 shows for a 11. At this point, I would really like to return this since my wife bought it from you guys. I spoke to a lady there a couple days ago and havent hear back... She was going to call afe and see if they would allowe her to return it since I test fitted it twice.

Quote:
Originally Posted by tom @ eas View Post
If you are in the Anaheim area anytime soon, feel free to drop by and we can take a look for you and verify correct installation.
Thanks Tom, I appreciate the support. Im 99.999% positive my lid was on correctly. I did it twice and had a friend who did his with me. Considering the K&N one didnt make this odd noise, Im pretty sure I did it correctly. Im OCD about things being done right and I made sure it all lined up.

However, I would like to come see you for some wheel spacers! And perhaps some new painted reflectors. I bought clear ones and they fogged up.
__________________
///2013 AW 6MT E92 ZCP M3/// Black 359M Wheels/BMW Performance Carbon Fiber Spoiler and Mirror Caps/Arkym AeroSport Front Lip/Turner 15MM Spacers/LUX 8 LED Halo/IND Gloss Black Grills, Gills and M3 Emblem/30% 3M Tint/BMW Interior LED/MusicCar Subwoofer Enclosure/JL Audio 12" W6 Sub and XD600:1 Amp/Euro Sunglasses Tray/Ceramic Coated Megan Racing Exhaust/AFe Dry Air Filter/RPI Intake Scoops/Euro MDM/Feature Coded.
Appreciate 0
      01-12-2012, 02:00 PM   #13
tom @ eas
BimmerPost Supporting Vendor
tom @ eas's Avatar
United_States
324
Rep
10,614
Posts


 
Drives: BMW
Join Date: Nov 2005
Location: Anaheim, CA

iTrader: (13)

Garage List
Quote:
Originally Posted by ILSMKU View Post
Thanks Tom, I appreciate the support. Im 99.999% positive my lid was on correctly. I did it twice and had a friend who did his with me. Considering the K&N one didnt make this odd noise, Im pretty sure I did it correctly. Im OCD about things being done right and I made sure it all lined up.

However, I would like to come see you for some wheel spacers! And perhaps some new painted reflectors. I bought clear ones and they fogged up.
The lid isn't the issue, the AFEs have a very soft polyurethane cap that can distort the seat when pressure is placed from the centering pin.

Drop on by, we'll take a look when you have time. Spacers are always in stock and a large shipment of Prepainted reflectors just arrived from IND.
__________________
Appreciate 0
      01-12-2012, 02:46 PM   #14
ModBargains III
Lieutenant
United_States
4
Rep
423
Posts

 
Drives: E92 335i, 135i, E46 M3, 540i
Join Date: Sep 2011
Location: 1721 E. Lambert Rd. Unit C, 90631 La Habra, CA

iTrader: (0)

Quote:
Originally Posted by ILSMKU View Post
Thanks, But I dont hear this on my stock filter, or my buddies K&N. I tried it, heard it, opened it up, removed it, replaced it, tried again, same sound. Put my friends K&N on, and it sounded normal. I then put my stock back on and I dont hear anything. The filter in the package is the labeled with a PN that is what Af3 shows for a 11. At this point, I would really like to return this since my wife bought it from you guys. I spoke to a lady there a couple days ago and havent hear back... She was going to call afe and see if they would allowe her to return it since I test fitted it twice.
Sent you a PM, we'll see what we can do for you
__________________
Appreciate 0
      01-19-2012, 11:13 PM   #15
dagolfpro
Lieutenant Colonel
dagolfpro's Avatar
Taiwan
30
Rep
1,911
Posts

 
Drives: 2011 E90 M3
Join Date: Sep 2011
Location: SF Bay Area, CA

iTrader: (9)

This is one of my fears of installing aftermarket air filter.
__________________
2011 E90 AW | DCT | ZCP | ZCV | ZCW | ZP2 | Prem Sound | Moonroof | BMW Apps |
Evolve Exhaust | M Perf Steering Wheel | Tint | Lux | Painted Reflectors | Hardwired V1 | KW V3 | Volshlag CP | Brembo BBK | 18" Volks TE37SL Pressed Graphite | Yokohama AD08 | Schroth 4 Point Harness | Challenge GT Diffuser | I lied earlier, I wasn't done with mod, but I swear, I'm done now, no more mods...
Appreciate 0
      01-20-2012, 08:21 AM   #16
DylanMckay
Banned
2
Rep
122
Posts

 
Drives: e92 m3
Join Date: Jan 2012
Location: armpit of the USA

iTrader: (0)

Fears? Its 90 bucks. Drop it in, if you do not like it than take it out. Not worth 90 dollars to even worry about it or waste time thinking about it.
Appreciate 0
      01-21-2012, 01:55 AM   #17
Limey
EXC MIII
Limey's Avatar
United_States
11
Rep
238
Posts

 
Drives: on the wrong side
Join Date: Nov 2011
Location: 949

iTrader: (0)

Garage List
I just installed the bmc filter and personally love the more pronounced growl/flutter. Perfectly normal. This vid depicts it well several times:


Last edited by Limey; 01-21-2012 at 02:06 AM.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:07 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST