BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Wash, Wax, Detail, Cosmetic Maintenance & Repairs
 
Lux Angel Eyes
Post Reply
 
Thread Tools Search this Thread
      12-18-2011, 10:33 AM   #1
SamS
Brigadier General
SamS's Avatar
61
Rep
4,577
Posts

 
Drives: 2013 ActiveHybrid 3
Join Date: Jul 2010
Location: Dallas, TX

iTrader: (0)

P21S to clean up oil from loose fill cap?

Hey gang,

Just took re-delivery of my car at PCD and drove 1100 miles back home. Before I left Spartanburg, I popped the hood and noticed a few drips of oil from the fill port. I figured PCD topped it off. I wiped it down, made sure the cap was tight and went on my way.

A few hundred miles into the trip, I got the Add 1qt message. Since no dealer parts department was open, BMW Assist supervisor said it was OK to use Castol Edge 10W30 until I could make it to my dealer (need 1200 mile service, anyways). So, I added a qt and everything is OK.

But, I noticed that the top must have been loose (hence the oil got out) and created a minor mess. Nothing on the hood, but there is oil in a 1ft radius around the cap. I wiped some of it down, but I need to clean up the rest. There is some on the engine cover, valve cover, and hoses.

I already have some P21S, should I use this? Any recommended procedures? If it would be better served by something other than P21S, is there something at Walmart/Autozone? I hate for the oil to sit while I wait a week for something ordered online to show up.

Thanks!
Appreciate 0
      12-18-2011, 10:45 AM   #2
DetailersDomain
BimmerPost Supporting Vendor
DetailersDomain's Avatar
United_States
63
Rep
3,805
Posts


 
Drives: 15 MW M3
Join Date: Nov 2008
Location: New Jersey

iTrader: (22)

Quote:
Originally Posted by SamS View Post
Hey gang,

Just took re-delivery of my car at PCD and drove 1100 miles back home. Before I left Spartanburg, I popped the hood and noticed a few drips of oil from the fill port. I figured PCD topped it off. I wiped it down, made sure the cap was tight and went on my way.

A few hundred miles into the trip, I got the Add 1qt message. Since no dealer parts department was open, BMW Assist supervisor said it was OK to use Castol Edge 10W30 until I could make it to my dealer (need 1200 mile service, anyways). So, I added a qt and everything is OK.

But, I noticed that the top must have been loose (hence the oil got out) and created a minor mess. Nothing on the hood, but there is oil in a 1ft radius around the cap. I wiped some of it down, but I need to clean up the rest. There is some on the engine cover, valve cover, and hoses.

I already have some P21S, should I use this? Any recommended procedures? If it would be better served by something other than P21S, is there something at Walmart/Autozone? I hate for the oil to sit while I wait a week for something ordered online to show up.

Thanks!
sorry to hear about that.

you can use the P21S total autowash on your engine bay for sure.

make sure you rinse the area thoroughly
Appreciate 0
      12-18-2011, 10:54 AM   #3
SamS
Brigadier General
SamS's Avatar
61
Rep
4,577
Posts

 
Drives: 2013 ActiveHybrid 3
Join Date: Jul 2010
Location: Dallas, TX

iTrader: (0)

Thanks for the reply, Phil.

Yes, I have P21S TAW right now. So, I should rinse first, then just cover the affected area with P21S sprayed on? I have a soft bristle brush I can use.

Any and all tips are appreciated!
Appreciate 0
      12-18-2011, 11:08 AM   #4
DetailersDomain
BimmerPost Supporting Vendor
DetailersDomain's Avatar
United_States
63
Rep
3,805
Posts


 
Drives: 15 MW M3
Join Date: Nov 2008
Location: New Jersey

iTrader: (22)

yes you can spray the area that you need to clean up agitate with a brush and rinse it, what I usually do next is turn the engine on to make sure everything will dry out quickly.

lmk how that goes will have no access to the internet till later today.

here is an engine clean up video.

click here.
Appreciate 0
      12-18-2011, 09:21 PM   #5
SamS
Brigadier General
SamS's Avatar
61
Rep
4,577
Posts

 
Drives: 2013 ActiveHybrid 3
Join Date: Jul 2010
Location: Dallas, TX

iTrader: (0)

Worked great, thanks Phil!
Appreciate 0
      12-18-2011, 09:59 PM   #6
DetailersDomain
BimmerPost Supporting Vendor
DetailersDomain's Avatar
United_States
63
Rep
3,805
Posts


 
Drives: 15 MW M3
Join Date: Nov 2008
Location: New Jersey

iTrader: (22)

that's great, glad it worked out.
Appreciate 0
      12-18-2011, 11:55 PM   #7
SamS
Brigadier General
SamS's Avatar
61
Rep
4,577
Posts

 
Drives: 2013 ActiveHybrid 3
Join Date: Jul 2010
Location: Dallas, TX

iTrader: (0)

Ha. Did a bit of searching on this site, and found a loose oil cap has caused problems for several folks. I got the engine bay pretty well (for what I can see), but when I take it to the dealer, I'm going to make them clean underneath. The car was leaking oil enough for a decent size puddle to form behind the passenger from wheel. Not a good feeling, for a brand new car.
Appreciate 0
      12-20-2011, 07:55 AM   #8
BimmerM
Lieutenant
BimmerM's Avatar
United_States
24
Rep
528
Posts

 
Drives: '11.5 E92 M3, '05 X5 4.8is
Join Date: Mar 2008
Location: NYC

iTrader: (0)

Garage List
2005 BMW X5 4.8is  [0.00]
2011 BMW M3  [0.00]
Take off the engine oil cap and inspect the rubber seal on the cap to make sure it didn't get creased or something. This could cause oil to leak out as well.
__________________

Drives: '11.5 Interlagos Blue E92 M3, '05 LeMans Blue X5 4.8is
Sold: '03.5 Mystic Blue E46 M3
DIYs: Enable Rear Fog | Easy Side Gill Replacement | Front Grill Replacement
Appreciate 0
      12-20-2011, 08:43 AM   #9
SamS
Brigadier General
SamS's Avatar
61
Rep
4,577
Posts

 
Drives: 2013 ActiveHybrid 3
Join Date: Jul 2010
Location: Dallas, TX

iTrader: (0)

Quote:
Originally Posted by BimmerM View Post
Take off the engine oil cap and inspect the rubber seal on the cap to make sure it didn't get creased or something. This could cause oil to leak out as well.
Thanks for the tip. I'll be taking it into the dealer in a few days for the 1200 mile service. I'm going to make them clean the undercarriage. I'm pretty frustrated by this, the car is brand new! Never had anything similar happen on the dozen vehicles I've owned before.
Appreciate 0
      12-20-2011, 10:58 AM   #10
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,121
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Informative thread. Thanks.
__________________
Appreciate 0
      12-20-2011, 11:22 AM   #11
SamS
Brigadier General
SamS's Avatar
61
Rep
4,577
Posts

 
Drives: 2013 ActiveHybrid 3
Join Date: Jul 2010
Location: Dallas, TX

iTrader: (0)

Just to clarify my situation: the oil cap was loose from the VPC/PCD service dept. and as a result lost enough oil to activate the Add 1qt message.

Once I added oil and secured the cap, everything appears OK now.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:54 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST