BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing
 
Lux Angel Eyes
Post Reply
 
Thread Tools Search this Thread
      12-14-2011, 11:15 AM   #1
GregW / Oregon
Commander-In-Chief
United_States
137
Rep
7,647
Posts

 
Drives: 2015 M4 Coupe, 2012 ML350
Join Date: Nov 2005
Location: Lake Oswego, OR

iTrader: (2)

Garage List
Clunking from left rear suspension

My car started "clunking" from the left rear over bumps at even slow speeds in the past couple months. I'm running Dinan springs and RAC wheels, but no other suspension modifications, and am at 37k miles. My dealer diagnosed it as a loose antiroll bar end link, which is being installed today. Hope it works because it's been really annoying to drive like that.
__________________

Greg Lake Oswego, Oregon, USA
2015 M4 Coupe - Silverstone/Sakhir/CF
2012 ML350
Appreciate 0
      12-14-2011, 11:17 AM   #2
elm3
M3 Lover
elm3's Avatar
United_States
26
Rep
1,864
Posts

 
Drives: 2009 e92 M3 Interlagos Blue
Join Date: Sep 2008
Location: Canton, GA.

iTrader: (1)

Garage List
I was going to suggest the swaybar link. It should fix your problem. The other thing that I was going to say would be the spring was not sitted correctly in the cup/spring purge?

Eric
__________________
'09 E92 ///M3 Interlagos Blue, 6MT, Silver Novillo Leather, CF Trim, Premium Package, Technology Package, Cold Weather Package, Premium Sound, 19" Wheels, Moonroof-Toy/ '14 335i, Sport Line, Premium Package, Technology Package, 19" wheels, Heated Seats - Daily Driver/ '04 Yamaha R1 - Toy/ '06 Yamaha Raptor 350-Toy
Appreciate 0
      12-15-2011, 09:31 AM   #3
GregW / Oregon
Commander-In-Chief
United_States
137
Rep
7,647
Posts

 
Drives: 2015 M4 Coupe, 2012 ML350
Join Date: Nov 2005
Location: Lake Oswego, OR

iTrader: (2)

Garage List
Clunk gone

Quote:
Originally Posted by elm3 View Post
I was going to suggest the swaybar link. It should fix your problem. The other thing that I was going to say would be the spring was not sitted correctly in the cup/spring purge?
It was just that the nut attaching the swaybar link was loose. New Nyloc nut and all is good again!
__________________

Greg Lake Oswego, Oregon, USA
2015 M4 Coupe - Silverstone/Sakhir/CF
2012 ML350
Appreciate 0
      12-15-2011, 10:22 AM   #4
elm3
M3 Lover
elm3's Avatar
United_States
26
Rep
1,864
Posts

 
Drives: 2009 e92 M3 Interlagos Blue
Join Date: Sep 2008
Location: Canton, GA.

iTrader: (1)

Garage List
Quote:
Originally Posted by GregW / Oregon View Post
It was just that the nut attaching the swaybar link was loose. New Nyloc nut and all is good again!
Greg good to hear.
__________________
'09 E92 ///M3 Interlagos Blue, 6MT, Silver Novillo Leather, CF Trim, Premium Package, Technology Package, Cold Weather Package, Premium Sound, 19" Wheels, Moonroof-Toy/ '14 335i, Sport Line, Premium Package, Technology Package, 19" wheels, Heated Seats - Daily Driver/ '04 Yamaha R1 - Toy/ '06 Yamaha Raptor 350-Toy
Appreciate 0
      12-15-2011, 10:32 AM   #5
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,121
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Good to hear that it was minor.
__________________
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:35 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST