BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      05-27-2011, 10:33 AM   #1
m3.santorini
Formerly known as e92 M3
m3.santorini's Avatar
United_States
197
Rep
917
Posts

Drives: Santorini
Join Date: Apr 2008
Location: Tri-State

iTrader: (12)

My i-Drive just shut off?

So I'm waiting in line for a hand wash. While idling for a good 15 minutes, my music stops playing and I look at the screen and it's completely off with no menu. I press all of the buttons and nothing. Then it comes back on (need I remind you the engine is running) with the BMW sign as if I just started the car. Has this happened to anyone else?

Also, it's a 2011 e92 if that helps.
__________________
instagram: m3.santorini | 2008 E92 M3 Jerez/Bamboo: SOLD | 2011 E92 M3 Alpine White/Fox Red: SOLD | 2016 F80 M3 Santorini Blue/Amaro Brown

FS/Trade: BC Forged RZ05 Wheels/Tires
Appreciate 0
      05-27-2011, 11:18 AM   #2
elp_jc
Brigadier General
United_States
104
Rep
4,910
Posts

Drives: .
Join Date: May 2008
Location: .

iTrader: (0)

I've had similar electronic gremlins, but not exactly that. Every one I've gotten, with the exception of a momentary speaker blast when I was punching buttons while changing modes (I attribute it to that), has showed up when starting the car, from all my settings being gone to the speakers not sounding at all. And everything was back to normal after the next ignition cycle. ALL of those episodes happened just once.

Your problem strikes me as a real problem, not one of those gremlins, because it happened all of a sudden, and corrected itself moments later. Sounds to me like a short or a bad connection of some sort. I'd still wait until it happens again, but if it does, then take it in; something will need replacing. I remember reading about that exact problem, and if memory serves me right, the screen had to be changed. Try searching for that thread. Good luck man.
Appreciate 0
      05-27-2011, 01:26 PM   #3
m3.santorini
Formerly known as e92 M3
m3.santorini's Avatar
United_States
197
Rep
917
Posts

Drives: Santorini
Join Date: Apr 2008
Location: Tri-State

iTrader: (12)

Thanks elp for the info. I hope it was only a one time thing. I was scared this was going to be one of those scenarios where the whole car shuts off. I remember reading someone's post about their fairly new MY11 shutting off while driving.
__________________
instagram: m3.santorini | 2008 E92 M3 Jerez/Bamboo: SOLD | 2011 E92 M3 Alpine White/Fox Red: SOLD | 2016 F80 M3 Santorini Blue/Amaro Brown

FS/Trade: BC Forged RZ05 Wheels/Tires
Appreciate 0
      05-27-2011, 01:51 PM   #4
radiantm3
Apex Everything!
radiantm3's Avatar
United_States
445
Rep
4,289
Posts

Drives: 2007 Honda S2000
Join Date: Sep 2008
Location: Danville, CA

iTrader: (6)

Garage List
2011 E92 M3  [4.66]
2014 BMW i3  [5.00]
I've had my iDrive get stuck on a red screen a few times. Nothing worked. Had to fully power cycle iDrive to get it back. Also the new combox seems to crash my iPod quite often. Never had this issue in a pre-combox car. Music just stops and I have to hard reset my iPod.
__________________
2011 E92 M3(Sold). 2007 Honda S2000 (Track Car). Cayman GT4 (Daily + Track Car)
Appreciate 0
      05-27-2011, 02:00 PM   #5
bubu
Bunny Slayer
United_States
20
Rep
501
Posts

Drives: E92 M3 - DCT (2013)
Join Date: Apr 2010
Location: Orange County - Southern California

iTrader: (0)

had mine reboot multiple times

...my I-Drive crashes on a consistent basis in 90+ in direct sunlight summer heat (cabin temps & internal temp probably get much much higher, proly 140ish?). I-Drive reboots...or hangs. Have to completely powercycle the car to get it running in most cases.

Dealer says its normal and refuses to do anything about it. Claims they can't duplicate it, standard line...system is overheating blah blah blah.

I've never had the electronics package in a lexus, porsche, or infiniti crash under these weather conditions. Love my M, mechanically could not have asked for a better car...on the flip-side I think the electronics are "sketchy".
Appreciate 0
      11-05-2011, 10:00 AM   #6
Mike van D
Major
Mike van D's Avatar
Germany
11
Rep
1,114
Posts

Drives: SG X6 35i; MW e92 M3
Join Date: Jan 2011
Location: Germany

iTrader: (0)

Quote:
Originally Posted by radiantm3 View Post
I've had my iDrive get stuck on a red screen a few times. Nothing worked. Had to fully power cycle iDrive to get it back. Also the new combox seems to crash my iPod quite often. Never had this issue in a pre-combox car. Music just stops and I have to hard reset my iPod.
80GB iPod Classic does the same...crashes constantly. Pain as it works fine in my '12 X6 w/BMW APPS. Don't get it...
__________________
...just enjoying life.
Appreciate 0
      11-12-2011, 03:16 AM   #7
Zaw
Private First Class
2
Rep
103
Posts

Drives: 2011 E90 M3 DCT Competition
Join Date: Aug 2010
Location: Studio City, CA

iTrader: (0)

I've had the same issue with my 80GB iPod. The iPod freezes up, some time I can't even switch to the radio, and even once when the iDrive blacked out completely and I had to do a full power cycle. I am sure there are more people with this problem. I have brought this up at my service visit and was given a line with out resolution. I hope BMW acknowledge and fix this problem because we each paid extra for this ipod option. We've been sold a defective product. I am going to go back to have my service manager log it into my service history just in case of future legal options.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 05:45 PM.




m3post
m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST