BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      11-09-2011, 05:44 PM   #23
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,121
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Quote:
Originally Posted by Mike Lu View Post
Just got the car back from dealer, because I can't get my wheel to memorize the setting. My Tech rerouted my power wiring from cigarette lighter to CAS Modules, and now my PSW works perfectly like it's supposed to.
And just to be clear : there's no coding needed. and like what Tom said, the PSW requires constant power to memorize all the setting.
Excellent news!!!!!!
__________________
Appreciate 0
      11-09-2011, 05:51 PM   #24
tvl1219
Private
2
Rep
64
Posts

 
Drives: white E92 m3
Join Date: Mar 2011
Location: cherry hill

iTrader: (0)

Quote:
Originally Posted by Mike Lu View Post
Just got the car back from dealer, because I can't get my wheel to memorize the setting. My Tech rerouted my power wiring from cigarette lighter to CAS Modules, and now my PSW works perfectly like it's supposed to.
And just to be clear : there's no coding needed. and like what Tom said, the PSW requires constant power to memorize all the setting.
where is the CAS module!!! can u post a picture of it!!
Appreciate 0
      11-09-2011, 05:52 PM   #25
tom @ eas
BimmerPost Supporting Vendor
tom @ eas's Avatar
United_States
328
Rep
10,632
Posts


 
Drives: BMW
Join Date: Nov 2005
Location: Anaheim, CA

iTrader: (13)

Garage List
Quote:
Originally Posted by Mike Lu View Post
Just got the car back from dealer, because I can't get my wheel to memorize the setting. My Tech rerouted my power wiring from cigarette lighter to CAS Modules, and now my PSW works perfectly like it's supposed to.
And just to be clear : there's no coding needed. and like what Tom said, the PSW requires constant power to memorize all the setting.
Bingo - IBS will cut cigarette lighter power after ~35min. Tapping power from the JBE or CAS module will be perfectly fine as these modules do not see interrupted power.

Does the wheel switch off when the key is removed from the ignition or does it require you manually turn it off?
__________________
Appreciate 0
      11-09-2011, 06:13 PM   #26
Mike Lu
Z
Mike Lu's Avatar
10
Rep
633
Posts

 
Drives: E92 AW M3
Join Date: Feb 2011
Location: E. Lansing

iTrader: (6)

Garage List
2010 BMW M3  [0.00]
2009 BMW/M3  [5.00]
The PSW switches off when key's removed; and turns on when key's in ignition no matter Engine is started or not.

Quote:
Originally Posted by tom @ eas View Post
Bingo - IBS will cut cigarette lighter power after ~35min. Tapping power from the JBE or CAS module will be perfectly fine as these modules do not see interrupted power.

Does the wheel switch off when the key is removed from the ignition or does it require you manually turn it off?
__________________
Challenge V-weave Front Lip & Mirror Caps | WSTO painted AW front grill & Mag Blue side grill & Mag Blue Tow Hook & Mag Blue mirror inner ring | Te-37 Mag Blue wrapped with R-S3 | Kreissieg F1 exhaust & X-pipe | KW V3 | Vortex EVO X GT-wing | Tinted LCI taillight | Nadi steering wheel & IND shift extension |
Appreciate 0
      11-09-2011, 07:34 PM   #27
Elliott@DetailAddict
Brigadier General
United_States
81
Rep
4,448
Posts

 
Drives: E90
Join Date: May 2011
Location: Santa Clara, CA

iTrader: (0)

Quote:
Originally Posted by tom @ eas View Post
If there are reported problems with the original installation, this would be the alternative. This was present also on the Gen 1 PSWs.

Seems like the instructions are request power from the CAS, which would also have constant power. Either option is fine, the JBE module is simply easier to access.
Quote:
Originally Posted by THE TECH View Post
What was present? A memory issue?

So in your observations, this has been an issue yet the instructions and the way you are suggesting are the same? If this is true, what is the solution?
So strange as I have the PSW v1 and tapped my Cig Lighter when I did the install.
Never had an issue with settings staying in memory.
Glad you guys solved your issue though
Appreciate 0
      11-09-2011, 09:46 PM   #28
Brooklyn Mark
Banned
United_States
21
Rep
509
Posts

 
Drives: 2013 M3 MR E92 DCT
Join Date: Feb 2010
Location: Brooklyn, NY

iTrader: (1)

Send a message via AIM to Brooklyn Mark
What would be a cause for DBS and DSC malfunctions after the install?
Appreciate 0
      11-09-2011, 10:09 PM   #29
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,121
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Quote:
Originally Posted by Grant@DetailAddict View Post
So strange as I have the PSW v1 and tapped my Cig Lighter when I did the install.
Never had an issue with settings staying in memory.
Glad you guys solved your issue though
Is it possible there's a difference in wiring for the pre-lci cars vs lci cars?
__________________
Appreciate 0
      11-09-2011, 10:28 PM   #30
Mike Lu
Z
Mike Lu's Avatar
10
Rep
633
Posts

 
Drives: E92 AW M3
Join Date: Feb 2011
Location: E. Lansing

iTrader: (6)

Garage List
2010 BMW M3  [0.00]
2009 BMW/M3  [5.00]
Probably you pulled the whole assembly out of the column (or moved the angel sensor) instead of just the coil spring, if that's the case, your angel sensor has to be re-calibrated, which is about 3hrs labor.

Quote:
Originally Posted by Brooklyn Mark View Post
What would be a cause for DBS and DSC malfunctions after the install?
__________________
Challenge V-weave Front Lip & Mirror Caps | WSTO painted AW front grill & Mag Blue side grill & Mag Blue Tow Hook & Mag Blue mirror inner ring | Te-37 Mag Blue wrapped with R-S3 | Kreissieg F1 exhaust & X-pipe | KW V3 | Vortex EVO X GT-wing | Tinted LCI taillight | Nadi steering wheel & IND shift extension |
Appreciate 0
      11-09-2011, 11:05 PM   #31
tom @ eas
BimmerPost Supporting Vendor
tom @ eas's Avatar
United_States
328
Rep
10,632
Posts


 
Drives: BMW
Join Date: Nov 2005
Location: Anaheim, CA

iTrader: (13)

Garage List
Quote:
Originally Posted by Brooklyn Mark View Post
What would be a cause for DBS and DSC malfunctions after the install?
Likely crossing the CAN high/low wires or low battery voltage. Make sure the wiring is correct before firing up the ignition.

Quote:
Originally Posted by Grant@DetailAddict View Post
So strange as I have the PSW v1 and tapped my Cig Lighter when I did the install.
Never had an issue with settings staying in memory.
Glad you guys solved your issue though
Quote:
Originally Posted by THE TECH View Post
Is it possible there's a difference in wiring for the pre-lci cars vs lci cars?
There are no settings to store in PSW1, therefore constant power was not necessary. PSWII is a bit more advanced.

There have been no changes in wiring (at least where steering wheel installation is affected) from pre-LCI to LCI.
__________________
Appreciate 0
      11-10-2011, 12:21 AM   #32
Elliott@DetailAddict
Brigadier General
United_States
81
Rep
4,448
Posts

 
Drives: E90
Join Date: May 2011
Location: Santa Clara, CA

iTrader: (0)

Quote:
Originally Posted by Mike Lu View Post
Probably you pulled the whole assembly out of the column (or moved the angel sensor) instead of just the coil spring, if that's the case, your angel sensor has to be re-calibrated, which is about 3hrs labor.
It is at most less than an hour to re-calibrate the Steering Angle Sensor. In-fact it is even a feature on the BT tool. Couple of clicks and done.

Quote:
Originally Posted by tom @ eas View Post
Likely crossing the CAN high/low wires or low battery voltage. Make sure the wiring is correct before firing up the ignition.

There are no settings to store in PSW1, therefore constant power was not necessary. PSWII is a bit more advanced.

There have been no changes in wiring (at least where steering wheel installation is affected) from pre-LCI to LCI.
Almost definitely the DSC and DBS and uncalibrated SAS not crossed wires. Those are exactly the errors that are thrown until it is recalibrated (I know because they were on my own dash after install and disappeared after reseting the SAS). Also the signals wouldn't turn off automatically and is therefore another tell tale sign of needing to reset the SAS.

PSW1 does have memory (the same RPM redline that is user set being discussed in this thread that is constantly being reset), as I have one. Also the memory of the RPM calibration (different than the stored user defined RPM redline).

Last edited by Elliott@DetailAddict; 11-10-2011 at 12:28 AM.
Appreciate 0
      11-10-2011, 08:01 AM   #33
SEI
Second Lieutenant
Indonesia
9
Rep
275
Posts

 
Drives: M3
Join Date: Jul 2007
Location: Jakarta

iTrader: (0)

Garage List
Confirmed! will post pics in a new thread..

THANKS SO SO SO MUCH TOM!
__________________

now: 2008 335i (E92), 2011 M3 (E92), X3 35i (F25),2012 E63 AMG (W212)
gone:2009 GTR, 2007 335i (E93) 2004 M3 (HPF stg 3), 2008 Civic Lx, 2007 Z4M Roadster, 2001 Gembala GT550, 2007 CLS 55, 2007 STI, 2004 M3
Appreciate 0
      11-10-2011, 09:09 AM   #34
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,121
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Thanks to everyone for the info. I hope we got this issue straightened out!
__________________
Appreciate 0
      11-10-2011, 12:24 PM   #35
tom @ eas
BimmerPost Supporting Vendor
tom @ eas's Avatar
United_States
328
Rep
10,632
Posts


 
Drives: BMW
Join Date: Nov 2005
Location: Anaheim, CA

iTrader: (13)

Garage List
Quote:
Originally Posted by SEI View Post
Confirmed! will post pics in a new thread..

THANKS SO SO SO MUCH TOM!
Glad I could help, looking forward to seeing some installed pics!
__________________
Appreciate 0
      11-16-2011, 01:32 AM   #36
KrazyM3
Enlisted Member
0
Rep
38
Posts

 
Drives: 2008 AW M3
Join Date: Jan 2009
Location: Bay Area, CA

iTrader: (1)

Quote:
Originally Posted by tom @ eas View Post
e9x M3 models do not have a powered OBD port.

I have not seen the installation instructions for the PSWII yet, does it specify switched or keep-alive memory? There are only a few locations that provide constant power in this model and will not shut off when the command is given by the IBS.
Correct me if I'm wrong but I thought all cars had a powered OBD port? Pin 16 is always hot, which means power at all times.
Appreciate 0
      11-16-2011, 01:46 PM   #37
tom @ eas
BimmerPost Supporting Vendor
tom @ eas's Avatar
United_States
328
Rep
10,632
Posts


 
Drives: BMW
Join Date: Nov 2005
Location: Anaheim, CA

iTrader: (13)

Garage List
Quote:
Originally Posted by KrazyM3 View Post
Correct me if I'm wrong but I thought all cars had a powered OBD port? Pin 16 is always hot, which means power at all times.
If this were the case, installs would be much easier.
__________________
Appreciate 0
      11-20-2011, 01:12 AM   #38
CasperSYTFU
SYTFU Crew
CasperSYTFU's Avatar
No_Country
13
Rep
1,180
Posts

 
Drives: 2010 Toyota FJ
Join Date: Aug 2010
Location: Bay Area, CA

iTrader: (8)

Garage List
Quote:
Originally Posted by tom @ eas View Post
Instructions state that power line is KL30, which requires constant power.



Disregard the orange/green harness w/ terminal connectors, as this is related to something else.

PIN3 on the JBE module (, left side connector, red/blue wire) will provide constant power for the PSW. PIN6 can be used for ground.

Hope this helps!
Hi Tom,
Would that PIN3 be the same for a non-m 335? And the ground? Been scouring the internet for that harness pinout.
__________________
Appreciate 0
      11-21-2011, 01:03 PM   #39
tom @ eas
BimmerPost Supporting Vendor
tom @ eas's Avatar
United_States
328
Rep
10,632
Posts


 
Drives: BMW
Join Date: Nov 2005
Location: Anaheim, CA

iTrader: (13)

Garage List
Quote:
Originally Posted by Grant@DetailAddict
Hi Tom,
Would that PIN3 be the same for a non-m 335? And the ground? Been scouring the internet for that harness pinout.
Pinout is the same on all e9x and e8x models that I've seen in the past. Please verify all connections/colors before attempting this install on your own.
__________________
Appreciate 0
      11-21-2011, 01:09 PM   #40
Elliott@DetailAddict
Brigadier General
United_States
81
Rep
4,448
Posts

 
Drives: E90
Join Date: May 2011
Location: Santa Clara, CA

iTrader: (0)

Thanks Tom. Sure enough the settings reset.
I'm going to go for the OBD source since it's not M.
Unfortunately the JBE harness on the 335 seems to not have the same placement of wires in the connector. Solid brown thick wire was actually pin 8 and the blue/red wire was on the bottom connector.
Thanks for clarifying.
Appreciate 0
      11-19-2013, 12:30 AM   #41
endofanera7
Major General
endofanera7's Avatar
No_Country
118
Rep
5,188
Posts

 
Drives: 08 JB E92 M3
Join Date: Sep 2008
Location: Bay Area, CA

iTrader: (15)

Garage List
2008 E92 M3  [5.00]
Send a message via AIM to endofanera7 Send a message via MSN to endofanera7
Quote:
Originally Posted by tom @ eas View Post
Instructions state that power line is KL30, which requires constant power.



Disregard the orange/green harness w/ terminal connectors, as this is related to something else.

PIN3 on the JBE module (, left side connector, red/blue wire) will provide constant power for the PSW. PIN6 can be used for ground.

Hope this helps!
I followed this and tap mine to JBE Module. My memory has been saving, it has been 1 week since I have installed the wheel.

I guess it might be with the year now. I have 03/2008 built. Hope my info helps whoever still trying to find a way for their wheel to memorize settings
Appreciate 0
      01-13-2014, 06:24 PM   #42
DimitrisM3
e90 my big fat lady!
DimitrisM3's Avatar
Greece
8
Rep
234
Posts

 
Drives: e90
Join Date: Oct 2011
Location: Greece Naoussa

iTrader: (0)

from the first day the sift lights never work in my v1 steering wheel
only work oil and water temp
i just do not know what to do!!
if same one can help..
__________________
Appreciate 0
      01-16-2014, 03:25 PM   #43
dave7101
Enlisted Member
0
Rep
31
Posts

 
Drives: 2013 M3 Convertible LCI
Join Date: Sep 2013
Location: Ontario, Canada

iTrader: (0)

Really thinking about pulling the trigger on this. The official BMW position however is that these are not available for M3 with DCT trans. Has anyone here got one to work on a DCT? I have 2013 e93, and if it works, ill be doing this.
Appreciate 0
      03-09-2014, 07:47 AM   #44
phrankeee
Registered
0
Rep
4
Posts

 
Drives: 2012 E92 M3
Join Date: Mar 2014
Location: China

iTrader: (0)

Quote:
Originally Posted by dave7101 View Post
Really thinking about pulling the trigger on this. The official BMW position however is that these are not available for M3 with DCT trans. Has anyone here got one to work on a DCT? I have 2013 e93, and if it works, ill be doing this.
I would like to know as well... If this works for M3 with DCT?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:02 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST