BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
Post Reply
 
Thread Tools Search this Thread
      10-19-2011, 08:53 PM   #23
orion565
Second Lieutenant
 
orion565's Avatar
 
Drives: 2011 e92 m3
Join Date: Apr 2011
Location: Downtown Houston

Posts: 205
iTrader: (2)

all is good now, shadeD1 is a god send, after getting v1.2, it worked out. I will follow up with paul and sal, but I think everything is fine now
orion565 is offline  
0
Reply With Quote
      10-20-2011, 02:00 AM   #24
0-60Motorsports
Major
 
0-60Motorsports's Avatar
 
Drives: BMW M3 JB 04 Coupe
Join Date: Aug 2007
Location: Kingdom of Bahrain

Posts: 1,291
iTrader: (1)

Send a message via AIM to 0-60Motorsports Send a message via MSN to 0-60Motorsports Send a message via Yahoo to 0-60Motorsports
Great to hear it worked
__________________
Current Mods: GC Coilovers, Eibach Sways, PF RTABs, RE RCAs, INTRAVEE II + Alpine KCA-420i, Black Roundels, ///MFEST Badges, Depo's, Screen protector for OEM 16:9 display, VCSL Bumper + Race Lip + CF Boot + CF Rear Diffusor, DIETZ TV in Motion, SuperSprint V1 Headers + Catless S-pipes + Res Sec 2 + Race Exhaust, Z8 Starter Button, Lamin-X, OME CSL Steering, OEM CSL Interior, OEM CSL Intake, OEM CSL Roof, EVOLVE Alpha-N, BBS CH's, LIGHTWERKZ....
0-60Motorsports is online now   Bahrain
0
Reply With Quote
      10-20-2011, 09:05 AM   #25
ShadeD1
First Lieutenant
 
Drives: 2011 X5 xDrive 35i
Join Date: Feb 2010
Location: Houston, TX

Posts: 329
iTrader: (0)

Great, I'm glad I could help!

Quote:
Originally Posted by orion565 View Post
all is good now, shadeD1 is a god send, after getting v1.2, it worked out. I will follow up with paul and sal, but I think everything is fine now
ShadeD1 is offline   United_States
0
Reply With Quote
      10-22-2011, 03:31 PM   #26
kyleb350
Brigadier General
 
kyleb350's Avatar
 
Drives: F30 335i M-Sport
Join Date: Jun 2008
Location: LoMbard, IL

Posts: 4,170
iTrader: (6)

Has anyone else been waiting on a modified file?
kyleb350 is offline   United_States
0
Reply With Quote
      10-22-2011, 11:09 PM   #27
alpine335i
Captain
 
alpine335i's Avatar
 
Drives: 08 e92 M3 6MT, 08 e90 328xi
Join Date: Nov 2006
Location: Poughkeepsie, NY

Posts: 687
iTrader: (2)

This seems to happen alot!
__________________
2008 Alpine White E92 ///M3
alpine335i is offline   United_States
0
Reply With Quote
      10-22-2011, 11:19 PM   #28
MaxBoost335
Private First Class
 
MaxBoost335's Avatar
 
Drives: 2011 e90 M3 DCT ZCP
Join Date: Oct 2009
Location: Orange County, CA

Posts: 167
iTrader: (0)

Quote:
Originally Posted by orion565 View Post
all is good now, shadeD1 is a god send, after getting v1.2, it worked out. I will follow up with paul and sal, but I think everything is fine now
Let us know how you are liking the tune.
MaxBoost335 is offline   United_States
0
Reply With Quote
      10-23-2011, 09:52 AM   #29
P@Evolve
BimmerPost Supporting Vendor

 
P@Evolve's Avatar
 
Drives: Quick enough
Join Date: Apr 2011
Location: US

Posts: 352
iTrader: (1)

Glad its sorted, we did believe it was a low powered battery hence our discussion on giving it a good charge before trying again. First we've heard of using an earlier version and something we are certainly looking into immediately. Just happened to catch us on a late night when all our technicians were overseas at the same time which is very rare.

We've been backed up this last week so sorry to those who have been waiting on files but will be catching up with them over the next few days.

Also this is a rare case but everything is recoverable with either the built-in recovery mode or special software.
P@Evolve is offline  
0
Reply With Quote
      10-23-2011, 12:35 PM   #30
dasvolk
Obersturmbannführer
 
Drives: 2013 E92 6MT, CF roof
Join Date: May 2009
Location: Bay Area

Posts: 72
iTrader: (0)

Garage List
2013 BMW M3  [4.50]
Is this something that is a fluke or is it related to newer versions of the DME? I just updated mine to the very latest 231E and want to plan for it if I am going to have to dick around with it to get it working.
dasvolk is offline   United_States
0
Reply With Quote
      10-23-2011, 12:42 PM   #31
P@Evolve
BimmerPost Supporting Vendor

 
P@Evolve's Avatar
 
Drives: Quick enough
Join Date: Apr 2011
Location: US

Posts: 352
iTrader: (1)

Quote:
Originally Posted by dasvolk View Post
Is this something that is a fluke or is it related to newer versions of the DME? I just updated mine to the very latest 231E and want to plan for it if I am going to have to dick around with it to get it working.
Very rare, we've tuned tons worldwide with the latest software on now, this is the only one that kept getting stuck. We're looking into the issue and like any others, resolve them quickly to ensure it doesn't happen in the future.
P@Evolve is offline  
0
Reply With Quote
      10-24-2011, 01:03 AM   #32
cookdesk
Private
 
Drives: M3
Join Date: Jun 2011
Location: Sydney

Posts: 59
iTrader: (0)

Hey Kyleb350 - yes I am waiting too but sounds like the guys are onto it...
__________________
AW E92, Innotech Evo, Evolve Tune, CAI, Pulley, ZCP Wheels, CF Cosmetics.... Done for now.
cookdesk is offline   Australia
0
Reply With Quote
      10-24-2011, 07:57 AM   #33
flipm3
E46 + E90
 
Drives: E46 M3 + E90 M3
Join Date: Jul 2008
Location: Illinois

Posts: 2,772
iTrader: (1)

Garage List
2009 BMW M3  [0.00]
2002 BMW M3  [0.00]
I'm glad you got it all sorted out. It's good knowing that the latest evolve-R software continues to become more and more stable and working out little kinks here and there.

I'm pretty pumped to tune my otherwise stock E90 M3 when I'm back in the country!

Let us know what you think of the tune!
__________________
E90 M3 DCT|Melbourne Red . Speed Cloth | My Build Thread
E46 M3 6MT|Jet Black . Black Nappa Leather | My Build Thread
flipm3 is offline   Philippines
0
Reply With Quote
      10-24-2011, 08:22 AM   #34
ShadeD1
First Lieutenant
 
Drives: 2011 X5 xDrive 35i
Join Date: Feb 2010
Location: Houston, TX

Posts: 329
iTrader: (0)

I don't think it was a real bug, the OP was using version 1.18 of the cable firmware to load his ecu and it was barfing. I had the exact same issue when upgrading from my old tune so I sent him version 1.20 of the firmware and it loaded just fine
ShadeD1 is offline   United_States
0
Reply With Quote
      10-24-2011, 10:42 AM   #35
P@Evolve
BimmerPost Supporting Vendor

 
P@Evolve's Avatar
 
Drives: Quick enough
Join Date: Apr 2011
Location: US

Posts: 352
iTrader: (1)

Quote:
Originally Posted by ShadeD1 View Post
I don't think it was a real bug, the OP was using version 1.18 of the cable firmware to load his ecu and it was barfing. I had the exact same issue when upgrading from my old tune so I sent him version 1.20 of the firmware and it loaded just fine
I just reread it and yes, I got confused with that. The latest software is emailed along with the invoice to every customer. I guess if you miss it, you might use the software on the supplied USB (which gets out of date very quickly with all the updates we do). We'll have to figure out a more obvious way until the USB's are phased out. Thanks for helping out
P@Evolve is offline  
0
Reply With Quote
      10-24-2011, 11:39 AM   #36
kyleb350
Brigadier General
 
kyleb350's Avatar
 
Drives: F30 335i M-Sport
Join Date: Jun 2008
Location: LoMbard, IL

Posts: 4,170
iTrader: (6)

Quote:
Originally Posted by Paul@Evolve View Post
I just reread it and yes, I got confused with that. The latest software is emailed along with the invoice to every customer. I guess if you miss it, you might use the software on the supplied USB (which gets out of date very quickly with all the updates we do). We'll have to figure out a more obvious way until the USB's are phased out. Thanks for helping out
Perhaps, along with the initial software on the flash drive, you could include a link to a web page with a link to the latest version (dated) for the user to verify they have the latest.

The e-mails are a nice reminder though
kyleb350 is offline   United_States
0
Reply With Quote
      10-24-2011, 06:33 PM   #37
KennyPowers
Brigadier General
 
Drives: .....
Join Date: Oct 2010
Location: Gulf Coast

Posts: 4,048
iTrader: (13)

did you need a battery charger to do this?

how long did the initial read take, and then how long did the rewrite take?

glad you got it all worked out mate
__________________
PCD 10/10 on 2015 M3 : MW / SB Full Leather / HK audio / Adaptive Suspension / Silver 19s / 6MT / CF Roof
KennyPowers is offline  
0
Reply With Quote
      10-24-2011, 06:58 PM   #38
ShadeD1
First Lieutenant
 
Drives: 2011 X5 xDrive 35i
Join Date: Feb 2010
Location: Houston, TX

Posts: 329
iTrader: (0)

You guys rock! I'm happy to help you out anytime
Great Tune!

Quote:
Originally Posted by Paul@Evolve View Post
I just reread it and yes, I got confused with that. The latest software is emailed along with the invoice to every customer. I guess if you miss it, you might use the software on the supplied USB (which gets out of date very quickly with all the updates we do). We'll have to figure out a more obvious way until the USB's are phased out. Thanks for helping out
ShadeD1 is offline   United_States
0
Reply With Quote
      10-24-2011, 07:00 PM   #39
flipm3
E46 + E90
 
Drives: E46 M3 + E90 M3
Join Date: Jul 2008
Location: Illinois

Posts: 2,772
iTrader: (1)

Garage List
2009 BMW M3  [0.00]
2002 BMW M3  [0.00]
Quote:
Originally Posted by KennyPowers View Post
did you need a battery charger to do this?

how long did the initial read take, and then how long did the rewrite take?

glad you got it all worked out mate
For me, the initial read took just about an hour and I did not use a battery charger. Unfortunately, I didn't get the chance to flash in the new tune since I had to fly back out of the country. the ".bin" file on my computer taunts me everyday until I get back home to finally flash the beast...haha
__________________
E90 M3 DCT|Melbourne Red . Speed Cloth | My Build Thread
E46 M3 6MT|Jet Black . Black Nappa Leather | My Build Thread
flipm3 is offline   Philippines
0
Reply With Quote
      10-24-2011, 09:48 PM   #40
cookdesk
Private
 
Drives: M3
Join Date: Jun 2011
Location: Sydney

Posts: 59
iTrader: (0)

guys got my file today and loaded with no problems at all - think my ecu might be super simple (08 manual) but my read and programed in about 30 seconds !

Intial impressions are very good but have only had one drive in traffic so will report back later.
__________________
AW E92, Innotech Evo, Evolve Tune, CAI, Pulley, ZCP Wheels, CF Cosmetics.... Done for now.
cookdesk is offline   Australia
0
Reply With Quote
      10-26-2011, 10:21 AM   #41
orion565
Second Lieutenant
 
orion565's Avatar
 
Drives: 2011 e92 m3
Join Date: Apr 2011
Location: Downtown Houston

Posts: 205
iTrader: (2)

To answer some of the questions:

I had to get a battery charger because I tried to re-load the tune (stock and evolve) that the battery charge started getting low, about 6x times or about ~ 2 hrs. And since the car would not start due to a half loaded file there was no way to charge the battery without one.

After hooking up the battery charge and letting it sit for another 6 hrs, I tried with the older 1.18 software and it continued to fail. ShadeD1 sent me his later version of 1.2 and it loaded just fine. I did a stock flash then a flash to evolve, after that my battery was too low to start to car even though the software loaded.

I used another car to jump my car and everything started up fine, no codes, no CEL, nothing.

I only had the car for about 15 minutes to drive before I hit a patch of nails and it took out 2 passenger tires, and now the car has been waiting for about a week for those damn tires, so I can't comment on the performance yet. I will be going to the track this weekend, so I will keep you guys updated from there.

It took about 15-20 minutes to read, and 30 minutes to flash.

Last edited by orion565; 10-26-2011 at 10:27 AM.
orion565 is offline  
0
Reply With Quote
      10-26-2011, 10:10 PM   #42
cookdesk
Private
 
Drives: M3
Join Date: Jun 2011
Location: Sydney

Posts: 59
iTrader: (0)

Orion - that's some bad luck I hope it's all worth it in the end !

Hey Paul - not that it's an issue but any idea why mine scans / loads so quick compared to others ? Just interested...
__________________
AW E92, Innotech Evo, Evolve Tune, CAI, Pulley, ZCP Wheels, CF Cosmetics.... Done for now.
cookdesk is offline   Australia
0
Reply With Quote
      10-27-2011, 08:20 AM   #43
P@Evolve
BimmerPost Supporting Vendor

 
P@Evolve's Avatar
 
Drives: Quick enough
Join Date: Apr 2011
Location: US

Posts: 352
iTrader: (1)

Quote:
Originally Posted by cookdesk View Post
Orion - that's some bad luck I hope it's all worth it in the end !

Hey Paul - not that it's an issue but any idea why mine scans / loads so quick compared to others ? Just interested...
Just a different software version, only requires the data area to be written which is only a few hundred kb
P@Evolve is offline  
0
Reply With Quote
      10-28-2011, 11:15 AM   #44
orion565
Second Lieutenant
 
orion565's Avatar
 
Drives: 2011 e92 m3
Join Date: Apr 2011
Location: Downtown Houston

Posts: 205
iTrader: (2)

update

just to give an update to all those interested: I have driven the car on the street for a couple days and have noticed a large difference between stock and the tune. The biggest thing I have noticed is much more power in the lower rpm level 2-4k.

I can actually spin the tires while driving in 2,3 rd gear from a rolling punch, around 3k rpm level, wasn't able to do that before, with the same tires as before.

For this (not spinning the tires, but the power), it was worth it as I am usually in that rpm range on the street. I haven't been above 5k yet so I can't say for the upper rpm band but I will be on the track tomorrow so we will see.
orion565 is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:56 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST