BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
OneEighty
Post Reply
 
Thread Tools Search this Thread
      04-26-2011, 10:33 AM   #133
phrogbubbaE92
Heavy Footed..
phrogbubbaE92's Avatar
United_States
2
Rep
206
Posts

 
Drives: '08 DCT E92 M3
Join Date: Aug 2010
Location: San Diego, CA

iTrader: (0)

I personally have the kit and am not impressed. in the HP department, I can feel a little difference in the 5-7k rpm range (i think a little mental HP is involved) and wish i would have done a baseline dyno before i installed and then after.

However, the most upsetting part of this is the fitment and the overall build quality. I have had the filter pop off many times and had to use duct tape to keep it secured (ill explain why I didnt just send it back). The filter will not secure with the clamp and the plastic warps once there is any pressure to keep the filter on. Also, the tube attachment on the side of the charge tube (I believe it is for the egr) broke off, and being that i was in a serious bind and HAD to use that intake (i threw away my old filter, and had no other vehicle, and had to be somewhere), I had to use epoxy to put it back on. Originally, it appears as if it was glued on from the factory and not a single unit, like most other intakes. After that, I knew i could not send it back and just dealt with the duct tape and epoxy. If i had to do it all again, I would have just purchased the drop in filter.

This was not meant to insult MS or their associates, this was my experience and if anyone has this intake, I would check their filters to make sure that they did not come off as well.. Thanks, and I hope that this helps.. I am considering just purchasing the drop in and doing a dyno. If i have the time, and patience, I will post up results. Thank you!

JP
Appreciate 0
      08-19-2011, 06:21 PM   #134
aka_phox
Captain
aka_phox's Avatar
20
Rep
609
Posts

 
Drives: 2011 M3 Convertilble
Join Date: Jun 2010
Location: Italy

iTrader: (0)

still no dyno results???
__________________

'11.5 SG E93/6MT/ALL BOXES CHECKED
BLACK GRILL/BLACK SIDE GILLS/15% TINT/PAINTED REFLECTORS/SPACERS/ANGEL iBRIGHTS/20'' VOSSEN CV3/VINYL WRAPPED SHADOW LINE TRIM/ETS-POWER TUNE/
///M-FLIGHT MEMBER
Appreciate 0
      08-24-2011, 11:21 PM   #135
Q8_TwinTurbo
New Member
0
Rep
11
Posts

 
Drives: 2010 E93 M3
Join Date: Jul 2011
Location: Kuwait

iTrader: (0)

For the guys that think this intake is not making much more than a drop in filter. The Intake scoops that some sponsers and aftermarket companies offer. Give a Ram-Air effect. They come into plhen the vehicle is doing 60+mph. There would be a huge difference if you can have a dyno facillity with powerful fans that can send air equivelant to the air flowing into the scoops. Just my 2c. Kindly, correct me if i am wrong.
Appreciate 0
      08-25-2011, 09:44 AM   #136
M3DCTBT
First Lieutenant
6
Rep
368
Posts

 
Drives: E92 M3
Join Date: May 2011
Location: New England

iTrader: (2)

SAME PROBLEM HERE.

I do have problems with my kits not sealing and letting in unfiltered air:

Exhibit A:



Exhibit B:



There is a gap where you can't create a seal. The full system by itself HUGE and barely fits when you put it on, so you must be careful, the airbox pin is a pain but do-able. I need some assistance with a new elbow as mine appears to be warped and sucking in unfiltered air to the motor.

Performance: I'm usually really sensitive to this, I can't really tell the difference. I was easily impressed by gains with: cat delete, pulleys, tune. I never noticed rear muffler or the MS Stage 2. Slightly better on/off throttle response. I'm not sold on it yet for $499, until I get some time on the dyno. My car gets 402-403whp regularly on a fat AFR tune, with the previous setup.

Sound: Sound is minimal. I had RPi Scoops/MS filter prior. Hard to notice anything. The rattle is gone, a slightly deeper hum and growl is there on WOT. After 1 day I was used to it and couldnt hear it anymore. The noise really blend in with the exhaust.

Tom/MS please help us out. I feel like this is like my AiB V1 fiasco all over again with beta parts.

Quote:
Originally Posted by phrogbubbaE92 View Post
I personally have the kit and am not impressed. in the HP department, I can feel a little difference in the 5-7k rpm range (i think a little mental HP is involved) and wish i would have done a baseline dyno before i installed and then after.

However, the most upsetting part of this is the fitment and the overall build quality. I have had the filter pop off many times and had to use duct tape to keep it secured (ill explain why I didnt just send it back). The filter will not secure with the clamp and the plastic warps once there is any pressure to keep the filter on. Also, the tube attachment on the side of the charge tube (I believe it is for the egr) broke off, and being that i was in a serious bind and HAD to use that intake (i threw away my old filter, and had no other vehicle, and had to be somewhere), I had to use epoxy to put it back on. Originally, it appears as if it was glued on from the factory and not a single unit, like most other intakes. After that, I knew i could not send it back and just dealt with the duct tape and epoxy. If i had to do it all again, I would have just purchased the drop in filter.

This was not meant to insult MS or their associates, this was my experience and if anyone has this intake, I would check their filters to make sure that they did not come off as well.. Thanks, and I hope that this helps.. I am considering just purchasing the drop in and doing a dyno. If i have the time, and patience, I will post up results. Thank you!

JP

Last edited by M3DCTBT; 08-25-2011 at 09:54 AM.
Appreciate 0
      08-25-2011, 09:45 AM   #137
Templar
Lieutenant Colonel
Templar's Avatar
United_States
40
Rep
1,824
Posts

 
Drives: 2011 E92 M3
Join Date: Feb 2009
Location: One of the coasts...

iTrader: (1)

Garage List
2011 BMW M3  [5.00]
Drop in filter and you're done.
__________________
'11 BMW E92 ///M3 - ZCP and DCT
'13 Toyota Tundra - 4x4 Platinum CrewMax, 5.7l iForce V8
Appreciate 0
      08-26-2011, 09:18 AM   #138
M3DCTBT
First Lieutenant
6
Rep
368
Posts

 
Drives: E92 M3
Join Date: May 2011
Location: New England

iTrader: (2)

Update: MS is sending me a new filter housing and responded quickly.

They think I tightened it too hard and collapsed the housing. I was told to simply tighten the filter clamp snug, enough to stick to the housing.

I did not over tighten it before, but just to let others know - be gentle with it!
Appreciate 0
      08-26-2011, 06:29 PM   #139
TheStigsCanadianCousin
Private First Class
TheStigsCanadianCousin's Avatar
7
Rep
147
Posts

 
Drives: e93
Join Date: Oct 2010
Location: Canada

iTrader: (0)

Quote:
Originally Posted by M3DCTBT View Post
SAME PROBLEM HERE.

I do have problems with my kits not sealing and letting in unfiltered air:

Exhibit A:



Exhibit B:



There is a gap where you can't create a seal. The full system by itself HUGE and barely fits when you put it on, so you must be careful, the airbox pin is a pain but do-able. I need some assistance with a new elbow as mine appears to be warped and sucking in unfiltered air to the motor.

Performance: I'm usually really sensitive to this, I can't really tell the difference. I was easily impressed by gains with: cat delete, pulleys, tune. I never noticed rear muffler or the MS Stage 2. Slightly better on/off throttle response. I'm not sold on it yet for $499, until I get some time on the dyno. My car gets 402-403whp regularly on a fat AFR tune, with the previous setup.

Sound: Sound is minimal. I had RPi Scoops/MS filter prior. Hard to notice anything. The rattle is gone, a slightly deeper hum and growl is there on WOT. After 1 day I was used to it and couldnt hear it anymore. The noise really blend in with the exhaust.

Tom/MS please help us out. I feel like this is like my AiB V1 fiasco all over again with beta parts.
I had the exact same problem, i swapped it out for a MS drop in filter. I have to say EAS was really good to me, was impressed with their service on this issue.
Appreciate 0
      08-28-2011, 10:40 PM   #140
Singletrack
4th down; 4th quarter? Renegade.
Singletrack's Avatar
United_States
43
Rep
3,820
Posts

 
Drives: 09 SSII E92 M3; 12 AW X5d
Join Date: Aug 2008
Location: Pittsburgh, PA

iTrader: (3)

Quote:
Originally Posted by M3DCTBT View Post
Update: MS is sending me a new filter housing and responded quickly.

They think I tightened it too hard and collapsed the housing. I was told to simply tighten the filter clamp snug, enough to stick to the housing.

I did not over tighten it before, but just to let others know - be gentle with it!
Sucks it collapsed. Over-tightening intake parts is something I'm always cautious with - known to cause problems on my last few cars. Although, sort-of sucks that the intake couldn't take the pressure. When did you buy it originally if I may ask and how did you discover it wasn't sealed?
Appreciate 0
      08-29-2011, 09:21 AM   #141
M3DCTBT
First Lieutenant
6
Rep
368
Posts

 
Drives: E92 M3
Join Date: May 2011
Location: New England

iTrader: (2)

Quote:
Originally Posted by Singletrack View Post
Sucks it collapsed. Over-tightening intake parts is something I'm always cautious with - known to cause problems on my last few cars. Although, sort-of sucks that the intake couldn't take the pressure. When did you buy it originally if I may ask and how did you discover it wasn't sealed?
I bought it 2 weeks ago. I did not notice it on install. It installed fine.

I had the worm clamp pointed to the furthest away point initially. After opening the hood a week later I noticed the gap. I moved the clamp to the gap to try to close it up and realized it was to no avail.
Appreciate 0
      08-29-2011, 09:39 AM   #142
Singletrack
4th down; 4th quarter? Renegade.
Singletrack's Avatar
United_States
43
Rep
3,820
Posts

 
Drives: 09 SSII E92 M3; 12 AW X5d
Join Date: Aug 2008
Location: Pittsburgh, PA

iTrader: (3)

Quote:
Originally Posted by M3DCTBT View Post
I bought it 2 weeks ago. I did not notice it on install. It installed fine.

I had the worm clamp pointed to the furthest away point initially. After opening the hood a week later I noticed the gap. I moved the clamp to the gap to try to close it up and realized it was to no avail.
Thanks. Little scary.
Appreciate 0
      08-29-2011, 09:58 AM   #143
leigh
Major
leigh's Avatar
20
Rep
1,103
Posts

 
Drives: 2011 e92 zcp m3
Join Date: Aug 2010
Location: melbourne

iTrader: (0)

So if I'm getting aa pulley akra evo tune do u get a MS stage 2 or a drop in air filter
Appreciate 0
      08-29-2011, 10:02 AM   #144
Singletrack
4th down; 4th quarter? Renegade.
Singletrack's Avatar
United_States
43
Rep
3,820
Posts

 
Drives: 09 SSII E92 M3; 12 AW X5d
Join Date: Aug 2008
Location: Pittsburgh, PA

iTrader: (3)

Quote:
Originally Posted by M3DCTBT View Post
I bought it 2 weeks ago. I did not notice it on install. It installed fine.

I had the worm clamp pointed to the furthest away point initially. After opening the hood a week later I noticed the gap. I moved the clamp to the gap to try to close it up and realized it was to no avail.
FYI - Just checked mine after 2 weeks of use and a 730mi continuous drive in 90F+ weather and no issue. It was a bear getting everything fitted perfectly though.
Appreciate 0
      08-30-2011, 10:43 AM   #145
phrogbubbaE92
Heavy Footed..
phrogbubbaE92's Avatar
United_States
2
Rep
206
Posts

 
Drives: '08 DCT E92 M3
Join Date: Aug 2010
Location: San Diego, CA

iTrader: (0)

Quote:
Originally Posted by M3DCTBT View Post
Update: MS is sending me a new filter housing and responded quickly.

They think I tightened it too hard and collapsed the housing. I was told to simply tighten the filter clamp snug, enough to stick to the housing.

I did not over tighten it before, but just to let others know - be gentle with it!
who did you contact? it would be really nice to get those replacement parts since all i did was tighten the hardware to what i thought was snug.. i know i didnt over torque the clamp so it has been extremely frustrating.. thanks in advance..
__________________
IB E92 - DCT - MS Stage 2 Intake - RPI exhaust - AiB - Matte black badges - Matte black grills - Reflector delete - Hardwired V1 - Loaded
Previous: '05 STi @408 awhp ~ Gone but definitely not forgotten...
Appreciate 0
      08-30-2011, 11:17 AM   #146
M3DCTBT
First Lieutenant
6
Rep
368
Posts

 
Drives: E92 M3
Join Date: May 2011
Location: New England

iTrader: (2)

Quote:
Originally Posted by phrogbubbaE92 View Post
who did you contact? it would be really nice to get those replacement parts since all i did was tighten the hardware to what i thought was snug.. i know i didnt over torque the clamp so it has been extremely frustrating.. thanks in advance..
info@machtschnell.com - they came through quick, props to them for sending replacement quick.

I didn't, IMO, overtorque mine either. If a euro wimpy worm clamp can warp plastic by a small flathead screw driver then .

Lately I'm not entirely happy with the way it fits, looks like no matter what it puts pressure upwards on my airbox lid. After replacement shows up if I don't see much on the dyno justifying it I will be going back to stock + MS, it sure fit alot better.
Appreciate 0
      08-30-2011, 11:52 AM   #147
M3roar
Lieutenant
M3roar's Avatar
6
Rep
453
Posts

 
Drives: 2010 e92 M3
Join Date: Sep 2009
Location: Houston, Texas

iTrader: (0)

Garage List
2010 BMW M3 e92  [4.67]
1998 BMW M3  [4.25]
just checked my Stage 2 Fittings and nothing has collapsed. Ran some track events in 90+ degree weather and daily driving in 105+ weather. Everything looks great!
Appreciate 0
      09-01-2011, 12:11 PM   #148
M3DCTBT
First Lieutenant
6
Rep
368
Posts

 
Drives: E92 M3
Join Date: May 2011
Location: New England

iTrader: (2)

All fixed - thanks MS.
Attached Images
 
Appreciate 0
      09-01-2011, 02:01 PM   #149
H2OENG
New Member
0
Rep
5
Posts

 
Drives: flintstone mobile
Join Date: Sep 2011
Location: neither here nor there

iTrader: (0)

Quote:
Originally Posted by M3DCTBT View Post
SAME PROBLEM HERE.

I do have problems with my kits not sealing and letting in unfiltered air:

Exhibit A:



Exhibit B:


One thing I noticed with the kit and should be stated is that the tightening screw of the hose clamps are best suited on the radius on all parts. This better distributes the pressure evenly. On a circular part you can place it anywhere because the shape is uniform and therefore the pressure is evenly distributed. With the given shapes of where the hose clamps go, if you place the tightening screw on a staright portion it is going to apply more force in that area and cause it to cave in as we see. (I learned this the hard way myself) The other thing is you don't need to torque the clamp a lot. Hose clamps deliver a alot of pressure and I have come across some clamps that will actually strip if over tightened (once again something I learned the hard way early in the car modding hobby career). All in all I am happy with the kit, especially since it has better revised with a thread in breather fitting.

FTR I had the first version had the breather issue, then went to the AFE kit and was not pleased, then went back to the MS kit once they resolved the issue. The AFE kit is nice except for the tiny filter they put on. All in all
Appreciate 0
      09-01-2011, 02:57 PM   #150
M3DCTBT
First Lieutenant
6
Rep
368
Posts

 
Drives: E92 M3
Join Date: May 2011
Location: New England

iTrader: (2)

First post? LOL

Car feels ALOT BETTER and sounds better with a perfectly sealed system after fixing the above.
Appreciate 0
      09-01-2011, 03:36 PM   #151
J08M3
Major General
J08M3's Avatar
United_States
102
Rep
6,012
Posts

 
Drives: 2011 M3 COUPE
Join Date: May 2008
Location: NEW YORK

iTrader: (8)

Quote:
Originally Posted by M3DCTBT View Post
First post? LOL
.
__________________
Appreciate 0
      09-01-2011, 08:26 PM   #152
MJM
BMW CCA Boston Chapter - Member
MJM's Avatar
United_States
7
Rep
514
Posts

 
Drives: 2011 E90 M3, ZCP
Join Date: Apr 2007
Location: Massachusetts

iTrader: (0)

I installed the MS Stage 2 kit myself (except the scoops) and install went fine, fitment was perfect and alignment hasn't varied from initial install three weeks ago.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:52 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST