View Single Post
      05-28-2011, 02:49 AM   #3
ducman
Second Lieutenant
United_States
5
Rep
257
Posts

 
Drives: E92 M3
Join Date: Jun 2010
Location: OC

iTrader: (5)

Quote:
Originally Posted by alefcole View Post
Help!!, I was installing my WeissLicht PY24W and the driver side turn fine, the passenger side doesnt turn at all, even after placing the OEM bulb in it. Is there a fuse blown just for the passenger side??. It was kind of a challenge to align the socket properly is there a chance that I have messed up the interior contacts?. Please share your experience. Thank you.
You might have broke the prongs in your headlight housing when you were trying to slide the prongs into the PY24W connector holes.

I tried this and failed miserably. First the PY24W didn't even fit on the oem base. I bruise my hand trying to twist it. Even in the video they don't even show you (sorry, but this diy isn't that great). I had to sand down the plastic on the PY24W and got it to twist in place. After that, more pain. I was never able to align the PY24W to the prongs (mad props to you to be able to do it on the drive side). I gave up and decided to put the oem bulb back in and it won't work. Car threw errors. It ended up that the prongs were bent due to me not being able to align the PY24W. It made a mark on the oem base, so I bent the prongs gently in the opposite direction and that's when the oem started to work again.

I don't recommend this aftermarket part at all unless you got more hands helping you. I just had 2, with the wheel in the way, and in total darkness (iphone flashlight .. so now I have 1 hand). I'm waiting until I get some stuff from EAS and ask them to give it a try for me.

I just hope your prongs aren't f'up because that mean you have to replace the entire headlight housing which is mad $$$.