View Single Post
      04-24-2011, 05:05 PM   #35
knifegun
Major
knifegun's Avatar
Turkmenistan
24
Rep
1,069
Posts

 
Drives: M3
Join Date: May 2008
Location: Where the weather is always the same

iTrader: (0)

Quote:
Originally Posted by taleof2bricks View Post
Newbie here, unfortunately, chiming in on a (possibly) related problem. Bought a 2008 M3 Sedan with 28k on the clock and all dealer records since new. Pristine paint & interior, snatched it up on the spot. Though the car was just serviced (oil, included), while driving from work, noticed the car had a very rough idle and reduced power. Service Engine Soon (or something to that effect) light went on, and I headed for the dealership. I will note this is after less than 1 month of ownership, and about 600 miles - just to & from work & 1 road trip about 130 miles each way (no "spirited driving", at all).

Didn't make it. Car died as I crossed an intersection, and I had it towed to the dealership. Service Advisor told me the next day that they found an engine problem and are contacting BMW (N. America?) to know if they will "rebuild or ship out a new engine". All he said when I questioned was that this was likely "some rare defect", but said no more.

It has been about a week, and no further reply. I understand the whole buying a used car "risk", but this 'just doesn't feel right', after dropping a good chunk of cash on a fully documented vehicle, putting about 600 miles on it & having all this.

I, too, will post any updates, but my guess is that I will be out my M3 for a few months!
Sorry to hear the bad news. At least BMW should replace or rebuild your engine. I would push for an extended warranty in either case.

This type of issues were exactly the reasons I pushed so hard to get into a 2009 after having the same issue with 2 2008s.