View Single Post
      10-08-2010, 04:17 PM   #42
Lodaka
Second Lieutenant
Lodaka's Avatar
Canada
2
Rep
203
Posts

 
Drives: 2011 E92 M3 DCT
Join Date: Apr 2007
Location: Vancouver, BC

iTrader: (4)

Ah... what some of you have been waiting for. I got a call from the dealership yesterday. I will try my best to reproduce what they told me here:

They said that there is a "slab of metal panel" between the engine blocks and the oil pan. They tracked the source of the noise down to this metal panel. In their opinion, the clicking sound is originating from this metal panel being torqued out of spec, i.e. they think it's torqued too hard. They ordered a new part from Germany and will attempt to fix this. They also told me that they did actually saw this problem before and are relatively confident that this will address the issue.

A few comments on this explanation:

- I heard all of the above from a service advisor who was not involved with the process, as the responsible SA was away yesterday. Therefore, he didn't really understand (and he told me as much) the situation but was just relaying the message from the technicians. I was promised a full explanation when I go there to pick up the car.

- I am a little perplexed why they now say that they had this problem before, because when I first brought the car to them, they had no idea what the noise was. I will give them the benefit of the doubt though; at least, there is some hope. I am keeping my fingers crossed about this.

- The new part will arrive in 9 days. Ugh. So, hopefully I can update this issue at that time, depending on people's interest on finding out what happens.

In the meantime, I am hoping for snow in October so I can take advantage of xDrive. J/K.