View Single Post
      04-18-2010, 08:42 PM   #112
saeedg48
Brigadier General
 
Drives: 12 CLS63 + 14 M6 C
Join Date: Nov 2008
Location: Unknown

Posts: 3,500
iTrader: (1)

Perfection

Quote:
Originally Posted by GregW / Oregon View Post
I changed mine today at 8k miles (in 8 1/2 months) -- Service Indicator is showing 8k to service.

I used ramps at the rear, and jacked the front fromt the central jack point and supported the front on jack stands at the suspension arm pivot points. I noticed when the filter is removed there is about 1/10 liter of oil in the bottom of the housing. I used my MityVac to suck it out, though you could use an old turkey baster. I poured about the same amount of fresh oil into the bottom before reinstalling the filter.

I put in 8 1/4 liters before restarting the car. It took quite a while to get a reading, and was then showing near the bottom of ths scale with a "+1" notation. I added another 1/2 liter, but was unable to get a different reading in the garage. I'll check it again after driving.

The car always seems to run better after an oil change--pyscholocical, I know, but it makes you feel good.

Edit: The electronic oil monitoring system and lack of a dipstick continue to frustrate me. If the system were secondary, that's fine, but why do away with the dipstick? After putting in 8.75 liters (stated capacity is 8.8) and driving a couple times, the system is still telling me to add 1 quart -- would you trust it? If it had a disptick there would be no question. Just really stupid!
__________________


2008 M3 Sedan + TestPipes + Tune [sold]

2012 CLS63 AMG + P30 Performance Package
2014 M6 Coupe + AMS Downpipes + KW V3
saeedg48 is offline   Iran
0
Reply With Quote