View Single Post
      07-16-2009, 01:54 PM   #14
lugnut
First Lieutenant
lugnut's Avatar
4
Rep
344
Posts

 
Drives: 2008 E92 M3 Space/Fox
Join Date: Jun 2008
Location: Springfield, NJ

iTrader: (0)

This is where I am at so far. I have a 2/08 production E92 M3.

I ordered P/N 51 16 7 903 960 (6mt M3 Center Console Cover) and
65-82-9-213-311 (New Idrive controller unit)

Plugged it all in and swapped everything out (takes about 15 min total), and of course, the idrive doesn't work. No response to any of the shortcut buttons, nor does the selector knob function in anyway. I can not even click "Accept" when the car starts up.

The system is backlit, so I know that the controller is getting power, however it is not functioning. Does anyone know if the controller needs to be coded to the car by the dealership?

No matter which P/N the parts counter entered into their computer system it was always automaticly turned into the -311 part number. This means that even if you wanted a -048, or -309 controller YOU WILL ONLY RECIEVE -311. I would imagine then that if I had a 9/08 build 5 series, that originally used the -048 controller I think, and that controller broke, it would be replaced w/ a -311 controller. This leads me to think that since the problem must be with the TCU change that took place in 4/08 since both the OP and I have the older CDMA setup, and both are having issues; him with -309, and me with -311.

Any thoughts?
__________________
12 E70 X5d Black Saphire/ Tobacco
08 E92 M3 SG/Fox Red Gintani Race, RG63
09 E90 335xi Crimson/Saddle 02 E46 M3 Cab Imola/Black (Sold-RIP)97 E36 Z3 1.9 Atlanta Blue/Tan (Sold)