View Single Post
      07-15-2009, 02:21 PM   #1
Ben335
Captain
Ben335's Avatar
12
Rep
891
Posts

 
Drives: 09 M3 Finally here
Join Date: Jul 2008
Location: Virginia

iTrader: (2)

Thumbs down Active Autowerke

After seeing so many good reviews on them, I have to say I am very disappointed with Active.

So I ordered the Power Pulley and ECU flash from them. I ordered both before the car arrived since they were running a special. When they car arrived and I had gotten through break in, I called them and asked them to ship the pulley out to me so I can get that installed and do the ECU flash later. The person that I spoke to promised to get the pulley out to me. 4 days later, still no pulley so I call them and find out they never shipped the pulley out. 1st Mistake.

The pulley arrives and I go to have it installed. The pulley ships with 2 belts, one fits fine and the other one is so short, there is no way to get the belt on. I will also add that the person doing my install is a Master Shop Foreman at a large BMW dealership. I call tech support and they just say to keep trying and it will fit. So my installer spends a couple more hours on it and even unbolts the hydraulic tensioner from the car in an attempt to get the belt to fit. Even if he had gotten the belt to fit somehow, it was so tight, it would have destroyed all the bearing in the pulley system as it was just too tight. Bottom line, I was sent the wrong belot. I had to do my own research and call Active to ask them to send me a 1070 belt, which is a slightly longer belt to make it work. Active did overnight me a new belt to their credit and it went on without a hitch. 2nd Mistake though.

I was ready to do my ECU. I took it out Sunday and overnight it to Active on Monday. They received it on Tuesday and I call them to confirm and they confirmed that they will turn it around and get it back in the mail to me that afternoon so I would get it Wednesday morning. I checked the UPS shipper notification Tuesday evening and thank god that I did as Active had my ECU going to some shop that I had never heard of in Chicago, Illinois. I live in VA. Worse, they ship it 2nd day air instead of next day air. So, if I had not checked, someone else would have gotten my ECU and who know if would have seen it again. I immediately called Active when I saw the email and informed them. They called UPS to intercept the package and had them send it to my correct address. They promised me that I would get it Wednesday morning. Wednesday morning comes and goes and no ECU. I call Active and they tell me after calling UPS that my ECU will not get to me until Thursday now. So my car is still down and Active cannot do anything for me but to offer to help me with shipping if I buy more stuff from them. Third Mistake!

We'll see if my ECU arrives Thursday morning now.
__________________
09 SG E90, Black on Carbon Leather, Tech, Premium, Cold, iPod, Premium Sound, 19s, OEM Alarm, PDC, Moonroof, Sirius
Eisenmann Sport / Eibach Springs / 35% F1 Pinnacle Tint / Macht Schnell Air Filter / LUX Angel Eyes / Black Grill / AA Pulley / Powerchip Stage II Tune / Fabspeed X-Pipe & HFC / RAC Monolites RG63