View Single Post
      06-08-2009, 09:31 AM   #122
askiles
Major
 
askiles's Avatar
 
Drives: 2008 M3 Sedan - Alpine White
Join Date: Apr 2009
Location: Phoenix, AZ

Posts: 1,164
iTrader: (2)

Quote:
Originally Posted by Forged DST View Post
Andy, not sure what the problem is. Your fitments were not off, the 275 tire in the front is completely wrong for starters causing your fitment issues. Your rubbing in the rear is caused by your selection of a 305/30 for an aggressive offset. You say that your paint was peeling, we said no problem we will pick them up and pay for the shipping back and forth to get them fixed. Once received inspection CLEARLY showed it was caused during improper installation with a large tool causing scuffing to the edge of the bolt holes. If the paint was actually peeling it would be in other areas not involving being impacted. We took care of it anyway.

In the end we sent you a set out with your custom finish in a very timely manner. You were not happy with fitments or finish, so no questions asked we picked them up to fix them. We had to order new outers upon your request, rebuild, re-seal, and re-mount your wheels out of our own expense and then ship them back to you. We actually completely re built them to fit your tire set up and never complained during the process. We would also update you right away when you needed an update. Again not sure what the problem is, your tracking number shows that you will receive the wheels latest tomorrow and they look incredible. I hope when you get them you are more than satisfied with them!

please pm me or call me if you need any more information on them
I will post this again...

You are absolutely wrong. I worked with Miguel in the beginning, asking if the 275 & 305 would work, and he said those would be good, and look awesome. The fronts were built wrong, and you guys verified that. IT is funny how you still are lying! It was worked out in the beginning, 360 knowing that I would be using these tires, and knowing that my car was lowered, and I wanted absolutely no rubbing. This just proves that you guys don't know how to make wheels, as you made them WRONG!!

As far as the paint chipping, I told you guys a million times, and I will say it one time again, I installed them myself, and did them by hand. I never hit the paint at all. Plus, if all it took was me touching it, they must be absolute shit, as the paint does not stick. Your mistake is using paint to begin with.

You took them back because you had no choice, you guys royally screwed up. You also did not do it in a timely manner. It took you longer to fix the stupid wheels, than it did to make them in the beginning! On top of that, if you would have told me it would be several weeks, I wouldn't be so irate, but I was told countless times that they would either ship out on a certain day, or they HAD shipped. I don't know what I ever did to you to make you think you could just outright LIE to me, but you did. I paid you a ton of money for these wheels, and you treated me like trash.

It is funny how they were shipped out, right after you saw PayPal coming after my money, and no sooner. Bastards. I will get my full refund, and nothing less at this point.

-Andy
__________________
2008 M3 Sedan- Alpine White
askiles is offline  
0
Reply With Quote