View Single Post
      02-15-2013, 10:47 AM   #2
THE TECH
BimmerPost Supporting Vendor

 
THE TECH's Avatar
 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

Posts: 13,030
iTrader: (42)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Quote:
Originally Posted by BigApple View Post
I am shocked that it comes to this...

a 90day old e93 M3.

I had aftermarket Alarm and Radar protection installed from a Professional Location.

All fine about 3 weeks later (2 days ago) my Engine showed a Engine Malfunction Message. Went to the Dealer ... Dealer says it could be because of the Aftermarket install... And that there is possible no more warranty protection because of it... I cant belive it. Now they dont knwo what causes it and how to fix it. I Called the Aftermarket installer and they say they get that a lot that Dealers blame outside companies.
The funny thing is the aftermarket installers do work for other BMW dealerships. They install Radars for them also. Just not for this specific Dealer.
Now i am stuck in the middle of this Blame Shifting game.

How do you tackle this mess... i am not sure... any thoughts...
I had the same nonsense happen with another vehicle we used to own. Total BS. You just have to put your foot down about it. Tell them by law to void your warranty, they have to prove that the parts in question caused the issue at hand. Since they cannot do so, they have no grounds for voiding.
__________________
THE TECH is offline   United_States
0
Reply With Quote