View Single Post
      12-31-2012, 02:11 AM   #46
blackmist222777
Captain
10

 
blackmist222777's Avatar
 
Drives: E92 M3
Join Date: Apr 2012
Location: SF Bay Area


Posts: 783
iTrader: (6)

Quote:
Originally Posted by JAJ View Post
When I installed my KW ClubSport suspension, I was very careful to make sure my headlight aim sensors remained undamaged and were reconnected every time I had it apart. At the rear, you have to drop the rear lower control arm to adjust the ride height, so it was apart four or five times by the time I was happy with it.

I have to admit that I've always been baffled by the posts about "my headlights are out of alignment after a suspension change". The whole point of the aim sensors is to keep the headlights at exactly the right angle, regardless of the front or rear ride heights. The system uses two sensors, a computer and a servomotor in each headlight to make sure that if either end is unusually high or low, the headlight aim is correct. It just didn't make sense to me how, if the sensors were undamaged, it could go wrong.

That was before MY headlight aim went wrong after I installed my Clubsport suspension. I did it all perfectly, and yet there the headlights were, fixed in one position, refusing to adjust. Luckily, the ride height was so close to normal that it was ok, at least for a few days.

When I had the next chance to dig into it, I jacked the car up and messed with the sensors a bit. Now, when I had an aim problem on my E39 M5, I learned a lot about the sensor system. For instance, it's fast. You can unscrew the sensor rod, move the arm with your fingers and the headlights will respond immediately, moving up and down as you move the arm. So, I put the car on the lift, pulled the left front wheel, unscrewed the sensor rod and started moving the front sensor arm. No dice. Headlights were staring straight ahead, not moving. I figured that whatever was wrong must be wrong somewhere else.

Here's how the front sensor is supposed to look when it's connected properly to the rod assembly:

Attachment 388804

As you can see, the rod is actually bent from the factory and there's only one way to put it together (that's important).

Well, if the front sensor wasn't producing any adjustment, how about the rear one? I pulled the left rear wheel off and took a look (the sensor is immediately inboard of the spring). Sure enough, the rods and ball joints were connected but something didn't look right.

After I studied it for a while, I realized that it was possible to put it together two ways - the wrong way and the right way, and mine was wrong!

Here's a picture of the the right way to put it together:

Attachment 388805

In the wrong way, you position the sensor arm (at the top, plastic with cross ribs) hanging straight down, so the H-shaped arm that links it to the bracket at the bottom reaches sideways instead of up and down. In that "wrong" position, there's no stress on the sensor (it doesn't get broken) but it doesn't work either. Hence the system locks the headlights in one place and waits for someone to repair it.

When I undid the sensor arm and moved it up (to where you see it in the picture) the headlights started to move as I moved it. System function was fully restored, and there was no need to adjust the manual headlight adjusters.

So, if you're one of the guys who've had to do a manual headlight adjustment after a spring or suspension install, check the rods and arms on the rear headlight sensor. If they don't look like the picture, get it checked out by a qualified mechanic.

[By the way, if you look at the photos on an iPad, they're the wrong way up. On my PC and Mac browsers, Chrome, IE, Safari and Firefox, they work fine. On the iPad Safari browser, they revert to the original camera orientation, which was determined by getting the lens aimed at the sensors for the pictures. The front picture was taken upside down and the rear was taken sideways. If they look strange, switch browsers.]


you sir are a life saver. thank you! fixed my issue. now i dont need to worry about getting pulled over
__________________

2011 E92 BMW M3 AW (current)
2004 E46 BMW M3 TIAG
2004 E46 BMW M3 LSB