Thread: 2012 DCT
View Single Post
      10-23-2012, 01:52 PM   #28
Donbona
Lieutenant Colonel
Donbona's Avatar
United Kingdom
40
Rep
1,668
Posts

 
Drives: E93 M3 DCT 2008
Join Date: May 2009
Location: London UK

iTrader: (0)

Quote:
Originally Posted by THE TECH View Post
Unfortunately, this is something that should have been taken care of prior to the s/c install. Now it's coming back to haunt you.
I know

Quote:
Originally Posted by Templar View Post
You're so far off. Most people have no issues with their DCT. The lag issues have been eliminated with software updates. Stop trying to make this into a DCT vs. 6MT thread.

Anyway OP, it sounds really strange to me. When did it start happening? Before or after mods, if you can remember. Just curious... Hope it gets resolved soonest.
I'm not sure when it started... That's a problem, but I'm pretty sure it happened before the SC kit. I have a couple of cheaper ways to try resolving this issue. One is to take the throttle actuators out and see if they are sticking ( apparently this has been an issue before ). The other is to try a newer DCT box out of a 2011 model which I know that someone has and is willing to let me try before buying. Hopefully it's the actuators.
__________________
M3 E93 DCT, Space Grey,BC HB29 Forged Deep Concave Wheels, Ericsson Amuse F/R Bumper, Evolve Full Exhaust System, INTRAX Coilovers, STOPTECH BBK, Performance Steering Wheel,Custom Red/Black Leather Seats,///M3 ||Bimmerpost M3 Car Of The Month May - 2010SOLD
2010 R35 GTR