View Single Post
      07-31-2012, 06:14 PM   #20
morfinx
Shenanigans
morfinx's Avatar
United_States
22
Rep
1,240
Posts

Drives: Audi R8 V10
Join Date: Jul 2010
Location: Austin, TX

iTrader: (1)

Won't install on my phone, says "This app is incompatible with your phone". Also, doesn't look like 3-series is even supported?? In fact, everything EXCEPT for the 3-series and the X5 are supported. WTF?